Jump to content
stephena

Stella 4.7.3 released

Recommended Posts

It's long past time for a new release of Stella. This release contains a few features that have been done for quite some time, but I didn't release (for reasons explained below). Anyway, changes as follows:

 

 

* Added preliminary support for the 3E+ bankswitching scheme, developed by Thomas Jentzsch.

* Fixed HMOVE positioning bug that occurred under certain circumstances. Thanks to Omegamatrix of AtariAge for the bug report and patch to fix the issue.

* Added 'trapm', 'trapreadm', 'trapwritem' commands to debugger prompt. These are similar to the non-'m' versions, except that they also trap on all mirrors of the given address.

* Fixed bug in debugger 'reset' command; it wasn't resetting the bankswitching, so after a reset the banks were in an undefined state.

* Updated UNIX configure script to fix a bug where it fails in cross-compilation under certain circumstances. Thanks to Vlad Zakharov for providing a patch to fix this issue.

 

As usual, Stella can be downloaded from http://stella.sf.net/downloads.php, and donations can be made at http://stella.sf.net/donations.php. Bug reports can be made here or by PM.

 

Anyhow, with that out of the way, some other news. As some of you may have known and/or read in other posts, I haven't been feeling well for the past few months. Work was hectic, and there are also some real-life issues. So I haven't done a new release of Stella since March; that's the longest stretch without a new release since I started on the project in 2001. On the bright side, things are starting to improve. I'm feeling better, and in 3 weeks I will be off for a 3 week Christmas break, which is badly needed.

 

Also, something unexpected happened over the past month or so; Christian Speckner has offered to port his 6502ts TIA core to Stella! I'm happy to say that this is now proceeding fairly quickly in a forked project on Github (https://github.com/DirtyHairy/stella). When it's all done, it will be imported into the main Stella codebase. Finally, we have hope for a more modern TIA core :)

 

You may also remember that I was working on a new TIA sound core, based on work from Chris Brenner. I did eventually mostly finish that code, but integrating it into Stella with the old TIA code proved too difficult. The good news is, this code looks like a perfect fit for the new TIA core :)

 

Finally, I've been planning on a large improvement to event remapping, where joystick buttons and axes are no longer tied to one specific virtual device. Currently, if you map joy button 0 to virtual left joystick, you can no longer use that button for anything else. So even if you aren't currently using the left virtual joystick, button 0 is still not available. This will change to being able to map buttons to each virtual device (so joy button 0 may be 'Fire' when in joystick mode, one of the keypad buttons while in keyboard mode, etc).

 

Anyway, the above is (I'm hoping) what will eventually become Stella 5.0. No hints or guesses on when this will happen, but rest assured that it's well in hand.

 

Thanks for the support emails I've received over the past few months,

Steve A.

Stella maintainer

  • Like 15

Share this post


Link to post
Share on other sites

Also, something unexpected happened over the past month or so; Christian Speckner has offered to port his 6502ts TIA core to Stella! I'm happy to say that this is now proceeding fairly quickly in a forked project on Github (https://github.com/DirtyHairy/stella). When it's all done, it will be imported into the main Stella codebase. Finally, we have hope for a more modern TIA core :)

 

You may also remember that I was working on a new TIA sound core, based on work from Chris Brenner. I did eventually mostly finish that code, but integrating it into Stella with the old TIA code proved too difficult. The good news is, this code looks like a perfect fit for the new TIA core :)

Yay!

  • Like 2

Share this post


Link to post
Share on other sites

I've said this before, but every time an update comes out it's like I'm taking my virtual VCS into the shop for PM and a tune-up. On occasion it gets a new mod here and there. That's cool.

Share this post


Link to post
Share on other sites

Nice work, I always look forward to Stella updates! :)

 

I'm using Windows 7, so I had a bit a hiccup since MSVCP140.dll was missing, but installing the "Microsoft Visual C++ 2015 Redistributable Update 3" did the trick, just scroll down a little over half way and you'll see it.

 

I'm on Windows 10, so I didn't notice it. I'll get the packages updated soon.

Share this post


Link to post
Share on other sites

Do you have any SHA checksums we could check for the new release?

https://sourceforge.net/projects/stella/files/stella/ --> https://sourceforge.net/projects/stella/files/stella/4.7.3/

 

Win 32-bit self extract: Win 64-bit self extract: Combined Win 32/64-bit zip:

post-18-0-61144600-1479946749_thumb.pngpost-18-0-02765300-1479946750_thumb.pngpost-18-0-36931000-1479946750_thumb.png

d9389b49a0b7b8c7c2bd321c5d4dd80f765ff880 | 07586cf5a51961985b3b6f9ac03a7cc292917a18 | eae0b0dcfe5ff2e49aa49eda85c8fe1db71d961a

For another release-build SHA checksum just click the respective post-18-0-87940500-1479946810.png

Share this post


Link to post
Share on other sites

 

I'm on Windows 10, so I didn't notice it. I'll get the packages updated soon.

 

 

I don't know if this would qualify as a bug report or just Mac OS X observations.

 

Through 3.9.3 I used to leave phosphor off. It closely matched real hardware.

Now it is more of a a scrolling mix of flicker and solid diagonal solid sections.

I have a top-of-the line i7 quad core iMac and 8GB Ram.

So is it SDL2, the OS X 10.

Share this post


Link to post
Share on other sites

Even though there are plans for improvement, AFAIK nothing in phosphor emulation has changed lately.

Share this post


Link to post
Share on other sites

Stephen, can you replace SDL 2.0.4 with 2.0.5 in the next release, please? The new version fixes the annoying extra character when starting the debugger.

 

Thanks!

Share this post


Link to post
Share on other sites

I've just uploaded new builds for Windows and OSX, that contain the latest SDL version (2.0.5). In addition, the Windows builds include the latest VC runtime libraries (140). Otherwise, nothing else has changed in the code itself.

 

You should be able to just re-download the files, and you'll get the latest versions.

  • Like 4

Share this post


Link to post
Share on other sites

Nice work, I always look forward to Stella updates! :)

 

I'm using Windows 7, so I had a bit a hiccup since MSVCP140.dll was missing, but installing the "Microsoft Visual C++ 2015 Redistributable Update 3" did the trick, just scroll down a little over half way and you'll see it.

 

 

Same problem here. My EEE-PC-Netbook from 2009 (Intel Atom, Windows 7 with all updates, 2GB Ram) is not able to install Visual C++2015 Redistributable. Crashes while installation. Tried it for HOURS! I have to stay at Stella Version 4.7.2. :-(

Share this post


Link to post
Share on other sites

Do you get any error message? Or maybe a log file?

 

I got the error message "api-ms-win-crt-runtime-l1-1-0.dll is missing".

I started googeling until I found out to install Visual C++ redistibutable. Did not work. Hangs for half an hour.

Tried to get that freakin dll somewhere. Nothing did work.

/*Rant on*/ Crappy Microsoft crap that feels still as crappy as windows 95 felt 20 years ago!!!!!!!! /*Rant off*/

After all that i finally found this thread. :-)

Edited by biobern

Share this post


Link to post
Share on other sites

Fingers crossed, but I somehow I doubt that Microsoft will consider your hardware.

Share this post


Link to post
Share on other sites

Feature request:

 

Typing the letters in the launcher is IMO way too sensitive. You have to type really fast, else the launcher will assume that you started a new search. That restart period should at least be doubled (better even more).

Share this post


Link to post
Share on other sites

Feature request:

 

Typing the letters in the launcher is IMO way too sensitive. You have to type really fast, else the launcher will assume that you started a new search. That restart period should at least be doubled (better even more).

 

Functionality is already present in "UI Settings -> Misc -> List quick delay". By default it is 300ms, but it can be increased up to 1 second (over 3 times 'slower'). This time is the amount between which each character is entered is considered part of the previous search, or the start of a new one.

Share this post


Link to post
Share on other sites

Ah, thanks. It shows that I almost never used the launcher before testing the new core. :)

Share this post


Link to post
Share on other sites

Found a VERY minor bug: Setting Debugger window size requires restart too (not mentioned in UI by (*)). Same for Font Type.

Share this post


Link to post
Share on other sites

While your are at it, I hope you can include that on real hardware CX22 sensitivity is only 50% compared to Atari ("CX80") and Amiga mouse.

Share this post


Link to post
Share on other sites

While your are at it, I hope you can include that on real hardware CX22 sensitivity is only 50% compared to Atari ("CX80") and Amiga mouse.

 

Hi Thomas...Just curious about the above. How was the 50% difference measured? Not doubting the figure, just semi-blown away by the sensitivity delta between the devices.

 

Does one device come across as "super-sensitive" to movement, or does one device come across as requiring *a lot* more effort to move a character around?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...