Jump to content
7800fan

Just got my SGM, no SGM cart to use yet any ROM for testing?

Recommended Posts

Assuming the AtariMax SD cart works, is there a ROM out there I can use to test SGM to ensure it's working and the connector didn't crap out. The front connector tended to be bad due to oxidation as it didn't get used much compared to the main cart slot.

Share this post


Link to post
Share on other sites

I could use some help troubleshooting this. When I power the CV on without the cart, half of the time I get error message telling me to turn off the system before inserting a cart or expansion module. Other half of the time I get solid black screen. When I power on with the SD cart, usually I get the menu but sometimes I can't get to SGM test ROM as it either leads to black screen or "No SGM detected". I noticed the red power LED were flickering or dim when I get solid black screen.

 

Once I got something different:

i28MJS1m.jpg

 

I can't tell if this can be caused by bad expansion slot or something else. I don't have any working 2600 module to test with.

 

PS instruction book mentions 90 days from date of purchase like old time but considering I bought this back in March and just got it a few days ago, I'd assume it meant 90 days from date of shipment in this recently completed SGM wave.

Share this post


Link to post
Share on other sites

I suspect your Colecovision is faulty, the SRAM or the Z80, don't worry, it's normal because the Z80 has zero protection from the cartridge port. Test other game cartridges like Pepper II.

 

I'm the test developer and I'm still far away of seeing the day one single SGM is faulty because Eduardo tests each one before sending it.

  • Like 2

Share this post


Link to post
Share on other sites

So probably the front connector. I have Pepper II, Smurf's Rescue, and Ladybug cart and they played fine when SGM isn't plugged in. I'll pick up contact cleaner. If it comes to it, I'll take apart my CV system and really clean the connector. My system does have a brand new cart connector and RAM mod to eliminate the old RAM chip that required negative voltage and is prone to blowing out. And BIOS chip swap, the one I have allows me to skip the splash screen by pressing fire button.

Share this post


Link to post
Share on other sites

Take a pencil eraser to the gold fingers/contacts on the expansion port. You should be able to sneak one in there without having to take apart the shell again to clean them. Definitely invest in a can of DeOxit D5 though, it goes a long way along with good 'ol fashion isopropyl alcohol and some Qtips. Hopefully it's just a dirty connector and not a more serious problem.

Share this post


Link to post
Share on other sites

Assuming the AtariMax SD cart works, is there a ROM out there I can use to test SGM to ensure it's working and the connector didn't crap out. The front connector tended to be bad due to oxidation as it didn't get used much compared to the main cart slot.

 

Very unusual. Have you tried any actual SGM games?

Share this post


Link to post
Share on other sites

It did give me a few tries to boot up a SGM game from cold boot until it finally recognize the 24KB RAM and boot the game when I first got the unit. The RED LED is great indicator that it is receiving power from the power adapter. The power adapter I have that came with the unit eventually drove me crazy because with the modded controller with passthrough, SGM, and SD cartridge. Plus, touching/moving the wire or touching the plug that goes into the Colecovision will definitely corrupt the VRAM data. It was drawing a lot more power, so and started to undervolt(I think) the video chip. So sprites would be somewhat mirrored if x position is more than 128. So I got tired of messing around with that power adapter to get it to work, I went ahead and brought the Canadian power supply, and the problems went away.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...