Jump to content
alsp

SDrive-ARM preorder

Recommended Posts

Ok.  I guess I didn't understand how the Sdrive worked.  I didn't know I had to run sdrive.xex everytime I booted.   I had saved the config for the two ATR's I had set for D1 and D2.  I was assuming they would be visible when powered up.  Running sdrive.xex and reseting works. Thank you.

Share this post


Link to post
Share on other sites
2 hours ago, tep392 said:

Ok.  I guess I didn't understand how the Sdrive worked.  I didn't know I had to run sdrive.xex everytime I booted.   I had saved the config for the two ATR's I had set for D1 and D2.  I was assuming they would be visible when powered up.  Running sdrive.xex and reseting works. Thank you.

Ah, I understand. Yes, that´s the downside of that device. When you power the computer off, the configuration made is lost.

Maybe it´s possible to install a buffer battery, to keep it? @alsp, would that be possible?

Share this post


Link to post
Share on other sites
On 2/5/2021 at 6:58 PM, skr said:

Ah, I understand. Yes, that´s the downside of that device. When you power the computer off, the configuration made is lost.

Maybe it´s possible to install a buffer battery, to keep it? @alsp, would that be possible?

It will not be needed in next firmware update - I've already done configuration saving on the FAT partition

  • Like 1
  • Thanks 4

Share this post


Link to post
Share on other sites
12 minutes ago, alsp said:

It will not be needed in next firmware update - I've already done configuration saving on the FAT partition

This will make the device ever so much better, thank you!

Share this post


Link to post
Share on other sites
2 hours ago, alsp said:

It will not be needed in next firmware update - I've already done configuration saving on the FAT partition

Great news. Thank you so much for still improving it. :)

Share this post


Link to post
Share on other sites

I received my sdrive with passthru.

 

I plug it in, it flashes a red light and does nothing else.

I put a micro sd card in it, it flashes a green light and does nothing else.

 

I read part of the 19 pages here - some of you are talking about "sdrive.xex" - is this a program that I have to download and install?

 

Is it attached to this thread somewhere?

 

 

Share this post


Link to post
Share on other sites

OK, I picked up a fat32 sd card, placed the github files on it, and it now works - such as it works.

 

It's not for me, I'll be putting it on e-bay.


Personally, what I'd like as a device, is one that just could be setup in my sio chain as a regular "hard drive" and didn't otherwise, change my experince.

So, say you configured it (ONCE!) as D8: presenting a 16mb ATR.  In this sense it would become a 'hard drive' in my setup.

 

My first time use impressions are the left/right buttons change the LED lights in a way that is in no way intuitive, a light will turn on, then two lights, then back to one, zero clue what it is trying to indicate.  Therefore instructions should have been included, but whiel I did pop around that github sight looking for the missing instructions, what pdfs I found were clearly for an older version, and anyway, I'm just too busy to dedicate time to that.   

 

Suffice to say, it boots up to a game loader - I personally have no interest in game loaders, even if I understand many people do, I'm just not one of them.

For me, it downgrades my Atari experience to have a game loader put in front of me every time I turn the machine on.

 

I see in this thread that the config will be saved - good improvement.  Also I think it'd be an improvement if the config screen was optional, so that some folks would never have to see it at all.

 

But, every device isn't for everyone - I'm sure this is great for most folks.  The pass-thru - is a much appreciated feature, I do not like devices that terminate the sio bus.

The look of it, is superb.  Packaging, superb.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
55 minutes ago, Mark2008 said:

Suffice to say, it boots up to a game loader - I personally have no interest in game loaders, even if I understand many people do, I'm just not one of them. For me, it downgrades my Atari experience to have a game loader put in front of me every time I turn the machine on.

 

I see in this thread that the config will be saved - good improvement.  Also I think it'd be an improvement if the config screen was optional, so that some folks would never have to see it at all.

 

But, every device isn't for everyone - I'm sure this is great for most folks.  The pass-thru - is a much appreciated feature, I do not like devices that terminate the sio bus.  The look of it, is superb.  Packaging, superb.

 

It's not a game loader per se, the list represents ATR disk images and XEX (executable) programs that happen to be on the SD card.  The default SD setup provided does assume you are into gaming, but those ATR and XEX games files could be removed/substituted for any disk images from your library. SpartaDOS, MyDOS, app and utilities, etc.  I do look forward to being able to save a startup config in the next firmware. 

 

This version of SDrive is limited by its on-screen interface, and it does want to be your primary drive unit.  The screen that comes up is there for us to select however many ATR images we want online at one time and assigned to what disk drive number (or just load a XEX directly).  The lights and touch sensors on top allow for on-the-fly disk swapping with programs that assume you are using a real floppy D1.  It works, but takes some getting used to.

 

You might prefer a SDrive-Max as it has a touch screen on the device for selecting and ejecting disk images and stays on all the time with its own power supply.

Edited by RodLightning

Share this post


Link to post
Share on other sites

Good point, letting it just boot whatever unless you hold down one of it's buttons during power up to get the config screen would definitely be very nice!

Share this post


Link to post
Share on other sites

WOW, 43 days and still at the Russian post office(according to the tracking). NOT mad at the shipper but wish the political BS would stop and let US, the low people on the ladder, live.

Sorry but I was hopping to get this faster but... I also ordered some eprom's from China and it is here, only took about 12 days.. How come???

 

Well sitting back and awaiting.

 

O yes I am in the USA, West coast, if I could walk on water I could have got by now LOL.

 

Peter

Share this post


Link to post
Share on other sites
16 hours ago, Peter Rabitt said:

WOW, 43 days and still at the Russian post office

Hi, Peter, Russian post tracking for American parcels works not very well - on 14th Feb its sent out of Russia, Lets wait for 1-2 weeks, and if its didn't come to you - I'll write request for parcel searching.
BTW I've already sent hundreds of parcels and only one has lost in Brazil. In the USA all delivered successfully.

Share this post


Link to post
Share on other sites

image.thumb.png.e9e259c583a22a404c952b175f7ab18f.png

Like I said I am not upset, just waiting.. Will wait as long as it takes.. By the way USPS (USA postal service) also has it in Russia, but they have been wrong before also LOL

 

Peter

Edited by Peter Rabitt

Share this post


Link to post
Share on other sites

WOW, OK anyone ordering this product and live in the USA be very slow to judgment. Yes it took 72 days to go from Russia to USA and AZ. And yes it only took about two week for products ordered from Poland and Germany to get here... This was not the fault of the shipper but the SYSTEM....

 

Thanks to @alsp for sending it and the fine pkg'ing it had. All looks good...

 

Peter

  • Like 2

Share this post


Link to post
Share on other sites

Last year, I send a package to the US East Coast, 1 day here from my hometown to Frankfurt, next day in New York, then 6 weeks(!) until arrival in New Jersey... Long, long before the election...

 

Same here, if a packages arrives from a foreign country with 'Atari' in the papers, it takes 3 weeks alone at the customs office here, the other post offices can be added to this. There must be great Atari fans in the post/customs worldwide... ;-)

 

We have ordered several packages from alsp, all are marvelous and O. K.

 

Just give the people their time. 🙂

Edited by luckybuck

Share this post


Link to post
Share on other sites
2 hours ago, luckybuck said:

Last year, I send a package to the US East Coast, 1 day here from my hometown to Frankfurt, next day in New York, then 6 weeks(!) until arrival in New Jersey... Long, long before the election...

 

Same here, if a packages arrives from a foreign country with 'Atari' in the papers, it takes 3 weeks alone at the customs office here, the other post offices can be added to this. There must be great Atari fans in the post/customs worldwide... ;-)

 

We have ordered several packages from alsp, all are marvelous and O. K.

 

Just give the people their time. 🙂

yep, they are worried it's new Atari goods... and inspect... best to just label it more generically... anything that isn't a full system could be labeled more creatively as well...

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

OK, now I am trying to use the sdrive and plug it into my 400 with 64k memory (Mosaic 64k). I get the main menu, I think, but can not do anything else. I can, using the arrow keys go up and down the displayed menu and hit return and the file jumps to the "window" next to it but how do you get something to work. Yes when it comes up it has two windows with the dir. of the SD card in the left side and the 4 drives d1: thru d4: on the right. Just the d1: with out any other names. Looks like it is great any file/folder I put on it, it shows me, but what can I do to make something work??What are the commands to do something or where is the list so I can learn how to use it...

 

Thanks

 

Peter

Share this post


Link to post
Share on other sites
56 minutes ago, Peter Rabitt said:

OK, now I am trying to use the sdrive and plug it into my 400 with 64k memory (Mosaic 64k). I get the main menu, I think, but can not do anything else. I can, using the arrow keys go up and down the displayed menu and hit return and the file jumps to the "window" next to it but how do you get something to work.

I don't have an Atari 400 but I assume if it has no BASIC cart in you just need to put the file you want to load in the D1 slot on the right side then hit RESET and it will load.

 

If it's a two disk game then put disk 1 file in D1, disk 2 file in D2 then RESET.  When it asks to swap disks you use the touch sensitive top of the SDRIVE to swap disks. 

Share this post


Link to post
Share on other sites

Thanks for the info but it did not seem to load. It just went to Atari note pad.. 

I still do not understand why NEW Atariites who do not understand the different names and new products are not helped!!!

Yes back in the 1980's I was a sysop and had my own BBS. Also President of a Atari club. That lasted until 1990 when I had to move for work and was started in the MS dos then Windows..

I have forgot most of the Atari world but am now retired and dug out the old Atari to find out how it works,again...

All I am asking is HOW to get started in some of the things I bought as they look like I could use them. The SDrive look great to copy all my old 5.25 disk to to save the programs and see if they still work.

OK enough feeling bad for myself... If Atari is for the ones who already know the answers then I guess I will go back to W-10 and stay there...SAD...

 

Peter

Share this post


Link to post
Share on other sites

I think that's a bit unfair, an hour after you asked for help someone tried to offer some help, that and you are asking in a pre-order thread. Maybe start a new one?

Have you got a basic cart? Can you type print fre(0) and let us know the result?

I'm not sure if the 400 and the type of sdrive you have works the same as mine, but when you have selected a disc image try pressing the Atari key to reset the computer

Edited by mimo
  • Like 1

Share this post


Link to post
Share on other sites

Definitely too soon to start whining.  I've found the people on Atariage to be extremely helpful.  Here are a few links that might have some answers for you.  You can also try asking in the SDrive2 issues/questions thread which I found with minimal searching.

 

https://www.youtube.com/watch?v=0oI0ZOdIpWw
https://github.com/fintros/SDrive-ARM/blob/master/docs/Orig_SDrive_en.pdf
https://atariage.com/forums/topic/266882-sdrive-arm-sdrive2-issuesquestions/

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Hope that the Moderator does not catch me but as I am "whining" I would like to find out if what I have read is true...

Does the sdrive have away to copy files from the sd card to a floppy disk drive.... I have been trying to do so for a few hours.

I set the file I want to copy in drive 3 (the floppy is dr2:) boot from d1: then try to copy file from d3: to d2: No go...

So is it correct that you can not copy from or to the  sdrive from/to a external floppy drive??

 

Peter

 

 

 

 

 

Edited by Peter Rabitt
add data

Share this post


Link to post
Share on other sites
59 minutes ago, Peter Rabitt said:

So is it correct that you can not copy from or to the  sdrive from/to a external floppy drive??

 

Peter

Hello Peter, 

 

some DOS need to be configured to be able to have more than 2 drives.

  • Like 1

Share this post


Link to post
Share on other sites
On 8/1/2021 at 2:21 PM, pps said:

Hello Peter, 

 

some DOS need to be configured to be able to have more than 2 drives.

You can copy files to the SDrive but once you have done it I'm not sure how to access them.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...