Jump to content
MrGonker

New harmony cartridge not working

Recommended Posts

Hello, I wonder if anyone could please help me. I just received a new harmony cartridge the deluxe one with a SD card with software on it which i purchased from the harmony site about 2 weeks ago. I have a Pal 2600 junior which works fine with my Atari cartridges but when i try the harmony cartridge all I get is a black screen and no menu.I read on here that some say to reload the cartridge firmware so i tried to do that. When i connect to it to my pc it shows that the device is unknown and has malfunctioned. I loaded the drivers from the memory card and it still says device unknown so i am not able to change the firmware on the cartridge to pal50. I have plugged the cartridge in all 4 usb ports and only got it once to say it was connected on the harmony update programming but when i then tried to update all i got was the updater has stopped responding. I have tried 4 different usb cables I have and it still says device unknown. I sent Batari a message but have not yet had a reply. Will it be the cartridge that's failed? Or is there a problem with the 2600 junior?

My pc also is on Windows XP so is that the reason it won't see the cartridge plugged into the USB? I'm in the UK so is there an option to return the cartridge for a replacement?

Any help would be much appreciated.

Thanks,

Share this post


Link to post
Share on other sites

XP (which you really should get rid of ASAP) has numerous problems with USB, especially when your computer has a lot of USB ports. Please try on a different computer.

 

BTW: I sure hope you were not posting this from a Windows XP with Internet access.

  • Like 1

Share this post


Link to post
Share on other sites

Mine works I have the Encore all the menu keeps scrolling no way to stop why?

Share this post


Link to post
Share on other sites

But I don't want to unplug it just to turn it on and have to replug that is nuts too is there a fix

Share this post


Link to post
Share on other sites

This suggests an issue with your joysticks - what kind are you using?

Share this post


Link to post
Share on other sites

This suggests an issue with your joysticks - what kind are you using?

Juts an Atari 2600 Standard?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...