Jump to content
atari2600land

Ants (WIP)

Recommended Posts

OK, I think I have done everything correctly when I converted the game's code to use Zeroplayer instead of U-235. The title screen is supposed to be silent for now because I haven't made a song for it yet.

You can download the latest ROM here: http://www.atari2600land.com/antsjag/

  • Like 2

Share this post


Link to post
Share on other sites

Added title screen music. Is there a way though to lessen the about 5-second black screen pause before the title screen comes on? Would it do that on a real Jaguar or just Virtual Jaguar? What is causing it?

Share this post


Link to post
Share on other sites

Put almost everything into ROM. Now game works almost automatically, but game size is now 2MB as opposed to 1. I hope this is okay.

  • Like 2

Share this post


Link to post
Share on other sites

Added a fire ant. If you squish it, it kills you. I want feedback on this game and want to know if what I am doing isn't okay. Like for instance, why do I have a 2MB ROM if I put almost everything into ROM instead of ABS? Why would it make it go faster?

Share this post


Link to post
Share on other sites

Added a fire ant. If you squish it, it kills you. I want feedback on this game and want to know if what I am doing isn't okay. Like for instance, why do I have a 2MB ROM if I put almost everything into ROM instead of ABS? Why would it make it go faster?

If you put anything into ROM, it will build a ROM file. The file will be sized according to the typical ROM sizes of 2,4,6 MB. You typically want it to be 2 or 4 MB, then it is most compatible.

 

If you specify ABS for all your assets then providing it's less than 2MB (after build) you will get an ABS file. These are normally faster to load that a ROM and can be burnt to CD too.

 

I cannot think of any reason your ROM would be faster than the ABS.

 

I can't test it at the moment for you as I'm away from my computer but if I get chance tomorrow, I will.

 

EDIT: Also, the 5 second delay is where it's decompressing the game from the ROM, so that is normal.

Edited by Sporadic

Share this post


Link to post
Share on other sites

Hi,

 

I just tested this on a real jaguar and there is something you need to change; The ROM width setting. At least for it to work on the Skunkboard.

 

Open the rapapp.s file and look for this section (about half way down)

 

;; get something on the screen
jsr RAPTOR_start_video ; start video processing
move.l #LIST_display,d0 ; set RAPTOR to display initial RAPTOR list
jsr RAPTOR_setlist ; tell RAPTOR which list to process
jsr RAPTOR_UPDATE_ALL ; and update the object list with initial values
jmp __Z9basicmainv
if player=0
include "zero_audio.s"
endif
Paste in this code between those two sections;
move.w MEMCON1,d0
bset #1,d0
bclr #2,d0
bset #3,d0
bset #4,d0
bclr #7,d0
move.w d0,MEMCON1
It should end up looking like this;
;; get something on the screen
jsr RAPTOR_start_video ; start video processing
move.l #LIST_display,d0 ; set RAPTOR to display initial RAPTOR list
jsr RAPTOR_setlist ; tell RAPTOR which list to process
jsr RAPTOR_UPDATE_ALL ; and update the object list with initial values
move.w MEMCON1,d0
bset #1,d0
bclr #2,d0
bset #3,d0
bset #4,d0
bclr #7,d0
move.w d0,MEMCON1
jmp __Z9basicmainv
if player=0
include "zero_audio.s"
endif

Make the above changes and post a new ROM and i'll test it again. This wont effect Virtual Jaguar from working.

 

For more background info on this - see this post;

http://atariage.com/forums/topic/256149-rom-asset-management-accessing-assets-from-rom-directly/?p=3575885

Edited by Sporadic

Share this post


Link to post
Share on other sites

Are you using an older version of rB+? I thought ggn updated it to make that problem go away.

I don't think anything was added. It might of course depend on a version, but it's not in the newer ones.

Share this post


Link to post
Share on other sites

In that case, I think it would be better to ask ggn to include the fix in rB+, so that every user would get it and not have to worry.

 

Also, beware of the code in post #106: it works on the Skunkboard, but will crash on a standard EPROM cart (not good if you want to release your game as a cart later). Try the code in this post instead:

http://atariage.com/forums/topic/256149-rom-asset-management-accessing-assets-from-rom-directly/?do=findComment&comment=3576722

Share this post


Link to post
Share on other sites

In that case, I think it would be better to ask ggn to include the fix in rB+, so that every user would get it and not have to worry.

 

Also, beware of the code in post #106: it works on the Skunkboard, but will crash on a standard EPROM cart (not good if you want to release your game as a cart later). Try the code in this post instead:

http://atariage.com/forums/topic/256149-rom-asset-management-accessing-assets-from-rom-directly/?do=findComment&comment=3576722

Pretty sure I tried that on Skunk and it didn't work. So possibly for now it's up to the coder to include the relevant snippet depending on target platform.

 

I agree that it should be included in RB+, even if it's a build option.

Share this post


Link to post
Share on other sites

OK, I have tried everything to stop it from doing the following problem, but I can't get it to.

The problem is the fire ant (the red one) seems like it's off-centered for some reason but I don't know why. See picture:

post-9475-0-40824000-1508370118.png

Why is this happening? (In case you need it, the whole project can be found here: http://www.atari2600land.com/antsjag/ants20171018.zip

Share this post


Link to post
Share on other sites

I would say to check the object definition in the rapinit.s . Make sure all the variables are correct for the red ant.

Share this post


Link to post
Share on other sites

Yes, it's all correct. The thing is, if I uncheck the box in GIMP that says "do not write color space information," it shows up fine but in black only.

Share this post


Link to post
Share on other sites

I right click file, then properties, then details and it says it saved it as a color depth as 4, like I want it to be.

Share this post


Link to post
Share on other sites

I right click file, then properties, then details and it says it saved it as a color depth as 4, like I want it to be.

I'm not sure what Gimp was doing to the image but I opened your red ant file in PaintShop Pro 7 and then saved it as a BMP.

 

Then it displayed fine in the game on the titlescreen without the corruption.

 

Attached is the new version I used.

 

I have renamed it, remember to either rename the BMP back or change your assets.txt to point to the new image.

fireant4h2new.bmp

  • Like 1

Share this post


Link to post
Share on other sites

Hello!


Last weekend i downloaded the most recent ROM-versions from there, dated Octobre 20 and Octobre 21, but both worked somehow strange.
I have put them on the second bank of my Sillyventure Skunkboard, on a Jaguar K-PAL-model with 50/60 Hz-switch and CD-Player.

 

As seen in the attached screenshots, all the background images are displayed in a funny way ("vertical interlaced") while the foreground sprites seem to be ok.

The music is just a hissing sound, but reacts on the switch in the OPTION-screen.

Any ideas?

Kind regards
Matthias

post-2054-0-63368900-1508774476.jpg

post-2054-0-15375600-1508774488.jpg

post-2054-0-56202000-1508774496.jpg

Share this post


Link to post
Share on other sites

That looks like a ROM width issue. The backgrounds are stored in ROM rather than ram (looking at the code the other day).

Share this post


Link to post
Share on other sites

I have to store the in-game and title screen images in ROM because they're bigger than 4 bit.

 

No you shouldn't. If you want to make it a ROM file only 1 asset needs to be set to ROM. Also it doesnt matter that the graphics for those are higher than 4 bit.

 

If they are 16 bit it should work just fine. If they are 8 bit you may have some trouble

Which one are they?

Share this post


Link to post
Share on other sites

I really want waffles right now. And... I want to eat them while playing Sim Ant by Maxis.

Edited by 82-T/A
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...