Jump to content
Trebor

A7800 - the Atari 7800 Emulator

Recommended Posts

Interesting. I think we'll have to do some investigation for the next release, playing with target and compilers and such, but I'm pretty tied up with projects, so it probably won't be soon.

Share this post


Link to post
Share on other sites
3 minutes ago, RevEng said:

Interesting. I think we'll have to do some investigation for the next release, playing with target and compilers and such, but I'm pretty tied up with projects, so it probably won't be soon.

No problem.  Thank you for looking into it.

Share this post


Link to post
Share on other sites

Random question.  How accurate is the a7800 emulator?  Specifically, if a game has too many DL's in its graphics that real hardware wouldn't be able to display them all, would the emulator follow suit, or would it display those extra graphics?  Just checking expectations since I haven't played with newer emulator versions in a while.  I figure I should read up a bit. :)

 

 

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Propane13 said:

Random question.  How accurate is the a7800 emulator?  Specifically, if a game has too many DL's in its graphics that real hardware wouldn't be able to display them all, would the emulator follow suit, or would it display those extra graphics?  Just checking expectations since I haven't played with newer emulator versions in a while.  I figure I should read up a bit. :)

 

 

Mike can probably answer more scientifically!! than me but whilst developing I've found that side of it very accurate showing even partial images as it would. It's definitely very helpful when you get very close to the DL limits.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites

Yep, it's implements DMA limits, and it's pretty faithful compared to real hardware.

  • Like 2

Share this post


Link to post
Share on other sites

Regarding CPU usage, I find A7800 to be very resource-heavy as well. Part of my personal problem is that Win10 always seems to want to try to run it with the integrated Intel motherboard graphics chip rather than my 1070 GTX (my system is 5 years old). I had to go into the Nvidia Control Panel and force it to use the discrete card, but even so, it seems to use more processor and GPU than it ought to. 

Share this post


Link to post
Share on other sites

Trying to launch the macOS version of a7800 with arguments:

 

a7800 a7800 -cart1 xm -cart2 filename.a78 

 

results in:

 

unknown option: -cart2

 

Launching it with just a cart works as expected.

 

I'm using what should be the latest version a7800-osx-v4.0. Am I missing anything?

Share this post


Link to post
Share on other sites

Make sure your .a7800/a7800.ini file has a "hashpath" entry that's pointing at the provided hash directory from the a7800 package.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...