Jump to content
Asmusr

Flying Shark

Recommended Posts

Hi friends!

 

I have tried to load the game in Classic99 (as a cartridge). But it does not appear in the title menu. What did I do wrong?

 

How are you trying to load it? Selecting from the Cartridge menu, adding to Classic99.ini or some other way?

 

...lee

Share this post


Link to post
Share on other sites

How are you trying to load it? Selecting from the Cartridge menu, adding to Classic99.ini or some other way?

 

To set up “Flying Shark” to appear on the TI-99/4A title menu from Classic99’s menu , choose “Cartridge”-->“User”-->“Open...”, find the directory/folder in which you saved flying-shark-v1.2.1-8.bin and open it. This setup is only temporary. You will need to do it every time you start Classic99 and there must be an ‘8’ just before “.bin”.
To set it up to appear on Classic99’s “User” menu, you should put a copy of flying-shark-v1.2.1-8.bin in the “MODS” folder and then set up a user-cartridge section in classic99.ini. If you do not have any user cartridges listed in classic99.ini, the following should work:
[UserCart0]
name="Flying Shark"
rom0=8|0000|80000|MODS\flying-shark-v1.2.1-8.bin

See Chapter 10 in the Classic99 manual for more information.

...lee
  • Like 1

Share this post


Link to post
Share on other sites

Hi, I have tried the first way you describe, as usual. I did exactly what you describe, with the file downloaded from this thread. I also tried with the file taken from the Game Shelf, and get the same behavior: the emulated TI resets, but the title menu has only the TI basic option.

I have to say that I use Classic 99 v. QI368 on OS X via wine (I know, it's not a supported way to use Classic 99, but works fine, up to now). Maybe a need a newer version?

 

 

 

To set up “Flying Shark” to appear on the TI-99/4A title menu from Classic99’s menu , choose “Cartridge”-->“User”-->“Open...”, find the directory/folder in which you saved flying-shark-v1.2.1-8.bin and open it. This setup is only temporary. You will need to do it every time you start Classic99 and there must be an ‘8’ just before “.bin”.
To set it up to appear on Classic99’s “User” menu, you should put a copy of flying-shark-v1.2.1-8.bin in the “MODS” folder and then set up a user-cartridge section in classic99.ini. If you do not have any user cartridges listed in classic99.ini, the following should work:
[UserCart0]
name="Flying Shark"
rom0=8|0000|80000|MODS\flying-shark-v1.2.1-8.bin

See Chapter 10 in the Classic99 manual for more information.

...lee

 

Share this post


Link to post
Share on other sites

Append 8 to the filename

 

filename is (as in the thread):

 

flying-shark-v1.2.1-8.bin

 

Moreover, filename of the Game Shelf version is: flying-shark-8.bin

 

:-(

Share this post


Link to post
Share on other sites

Hi, I have tried the first way you describe, as usual. I did exactly what you describe, with the file downloaded from this thread. I also tried with the file taken from the Game Shelf, and get the same behavior: the emulated TI resets, but the title menu has only the TI basic option.

I have to say that I use Classic 99 v. QI368 on OS X via wine (I know, it's not a supported way to use Classic 99, but works fine, up to now). Maybe a need a newer version?

 

It is possible that version is before non-inverted ROMs were supported. The latest version of Classic99 is v399.003. Download it from @Tursi’s site, HarmlessLion.com.

 

...lee

 

[Edit: Answer is still the same, but I responded to the wrong post. :ponder: ]

  • Like 1

Share this post


Link to post
Share on other sites

 

filename is (as in the thread):

 

flying-shark-v1.2.1-8.bin

 

Moreover, filename of the Game Shelf version is: flying-shark-8.bin

 

:-(

 

I tried both version and working for me on Classic99 too

I also published the same version v1.2.1-8.bin on the ti99iuc website

and it works.

 

I am last version of the Classic99, be sure you are using one updated version.

Share this post


Link to post
Share on other sites

Hi, I have tried the first way you describe, as usual. I did exactly what you describe, with the file downloaded from this thread. I also tried with the file taken from the Game Shelf, and get the same behavior: the emulated TI resets, but the title menu has only the TI basic option.

I have to say that I use Classic 99 v. QI368 on OS X via wine (I know, it's not a supported way to use Classic 99, but works fine, up to now). Maybe a need a newer version?

 

I use classic99 on OSX via wine, so that should be okay. One other thing to try: what version of the console do you have selected on the System menu? The option "TI-99/4A V2.2" will result in exactly the symptoms you describe, so please be sure select "TI-99/4A" instead. (The V2.2 console has protection that only allows TI-made cartridges to appear in the menu.)

Share this post


Link to post
Share on other sites

Also try opening the Debugger and read what it has to say about the ROM loads. Maybe it's as simple as it's not finding the file for some reason. When you get into emulation annoying things like spaces, slashes and quotes start becoming really important.

Share this post


Link to post
Share on other sites

Hi all,

 

following your suggestions I have found that the problem it's not only with Flying Shark, but also with other cart, as Don't mess with Texas. It seems that the carts whose name has an '8' just before the ".bin" extension are the problem. I don't know the technical details, but I do know that these are a specific type of carts.

In the debugger window, the "Loading file C: ... " line for the carts that don't work is *not* displayed. As if the files are not recognized.

 

The problem is not the console version, I have selected "TI 99/4A" in the System menu

Share this post


Link to post
Share on other sites

Hi all,

 

following your suggestions I have found that the problem it's not only with Flying Shark, but also with other cart, as Don't mess with Texas. It seems that the carts whose name has an '8' just before the ".bin" extension are the problem. I don't know the technical details, but I do know that these are a specific type of carts.

In the debugger window, the "Loading file C: ... " line for the carts that don't work is *not* displayed. As if the files are not recognized.

 

The problem is not the console version, I have selected "TI 99/4A" in the System menu

 

Did you try to update Classic99? QI368 is 35 updates old.

  • Like 2

Share this post


Link to post
Share on other sites

Hi all,

 

following your suggestions I have found that the problem it's not only with Flying Shark, but also with other cart, as Don't mess with Texas. It seems that the carts whose name has an '8' just before the ".bin" extension are the problem. I don't know the technical details, but I do know that these are a specific type of carts.

In the debugger window, the "Loading file C: ... " line for the carts that don't work is *not* displayed. As if the files are not recognized.

 

The problem is not the console version, I have selected "TI 99/4A" in the System menu

 

Well, one note is that Don't Mess With Texas is not a "C" type cart, which is non-banked CPU memory (cartridge or otherwise).

 

The convention of <name><type>.bin is only used when you use Cartridge->User->open -- ie: you are forcing Classic99 to guess what you're loading. 8.bin means a non-inverted bank-switched ROM, which is probably correct.

 

You can post your Classic99.ini (to the Classic99 thread rather than here, maybe) so we can take a look at your setting, or if you're using cartridge->user->open, copy and paste the log in the debugger window right after the open so we can see all the messages (again, better to the Classic99 thread than here). Classic99 has been able to open type 8 ROMs for a pretty long time, but I guess it's possible that 35 updates ago was before we introduced them. So.. update too. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...