Jump to content
dj_sudo

IIc Keyboard Woes

Recommended Posts

I got a very dirty IIc locally. The initial memory test showed a bad RAM chip, which I've replaced. The self-test now reports "System OK," which is great! The only problem is that after replacing the chip, the keyboard (which worked before) now does nothing. No keys register, and the cursor sometimes either blinks VERY fast or shows an "alternate" character, a cross in reverse color, which isn't even supposed to be in the IIc's character set. Any thoughts? I've piggy-backed a keyboard encoder chip with no change. Maybe a bad character generator rom?

Share this post


Link to post
Share on other sites

Check for solder shorts in the area. Check the Keyboard ribbon-cable connector. Rock and reseat socketed chips. Is the replacement RAM chip the same speed and type?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...