Jump to content
RockyRaccoon

Can't get Casette Programs to load via Smartphone or Computer.

Recommended Posts

Hello! I recently got a CoCo 1 and have been trying to get it load programs via a Cassette cable I bought off Ebay.

 

Here's how it goes:

 

I load the .wav file onto the device. I get the wav files from here: http://www.colorcomputerarchive.com/coco/Cassettes/Games/

 

I connect the device via the cable to the device.

 

I type 'CLOAD' (or CLOADM, as applicable) and then that little prompt in the corner comes up. I press play. It blinks. It gets the correct name of the program. It appears to be loading. The recording stops. The little light blinks: 'OK' it says.

 

Now when I type 'Run', nothing happens.

 

I type 'List' and there's no program loaded.

 

It's like it wasn't loading anything at all. :-/.

 

What's going on? How can I potentially fix it?

 

I've tried various volume levels but that doesn't seem to matter. I KNOW it's loading /something/ because it's detecting the name of the program while it loads. :-/.

Share this post


Link to post
Share on other sites

I can't edit this, whoops but I will add:

 

I have typed 'AUDIO ON' and confirmed that the devices will play through the TV great, so the cable is ostensibly fine.

Share this post


Link to post
Share on other sites

I used a cassette-based Coco for many years (I never upgraded to disk), and I have never encountered this problem. Weird.

 

I would suggest increasing the volume, but since it is reading the header information/file title, that is probably not the problem.

 

It shows S in the top-left corner of the screen while searching the tape, followed by an F when it eventually finds your title.

 

There is also the SKIPF command that will check that a file is written to tape correctly, but will not load it into memory. (The EDASM+ cartridge thoughtfully renames this command VERIFY.)

 

You have probably tried this, but for a machine language program, uses EXEC to start it.

  • Like 1

Share this post


Link to post
Share on other sites

Hey jhd.

 

Basically, I'm the ultra noob. X3. I thought it was 'RUN' for both types. I loaded a program and typed 'EXEC' and that worked. Go Munchman and Color Invaders working, which were my two test programs.

 

Thank you for your patience. X3 Whoops!

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...