Jump to content
Bill246

Loading OSS Basic XE on to Flash Cart

Recommended Posts

I'm trying to load OSS Basic XE onto my Flash cart, but keep getting an error. I run the .atr image from my computer, which is connected to my XE GS via the SIO2PC cable. It starts the loading process, but once it gets to bank 10, I get a Disk Error on the XEGS. This happens every time. Does anyone have any suggestions?

 

Share this post


Link to post
Share on other sites

basic xe is a banking cartridge, you need to re arrange the bank scheme of the rom image to fit the flash cart banking layout, then you have to make changes in the Basic XE code to use the new banking scheme... the better news would be if you are trying to use an Atarimax 1 meg it might have been done for you already, search their forums...

Edited by _The Doctor__
  • Like 2

Share this post


Link to post
Share on other sites

basic xe is a banking cartridge, you need to re arrange the bank scheme of the rom image to fit the flash cart banking layout, then you have to make changes in the Basic XE code to use the new banking scheme... the better news would be if you are trying to use an Atarimax 1 meg it might have been done for you already, search their forums...

And ditto if you’re using an Ultimate or UNO Cart.

Share this post


Link to post
Share on other sites

I'm trying to load OSS Basic XE onto my Flash cart, but keep getting an error. I run the .atr image from my computer, which is connected to my XE GS via the SIO2PC cable. It starts the loading process, but once it gets to bank 10, I get a Disk Error on the XEGS. This happens every time. Does anyone have any suggestions?

 

Goto this web site for a basic xe but you need to have the MyIDE 2 cartridge and put it in the FAT32 area and load with the fatload that comes with the cartridge. Drive D1 should have you dos disk with extentions..

 

https://www.atarimax.com/flashcart/forum/viewtopic.php?p=8349#p8349

Share this post


Link to post
Share on other sites

BXE works on an Ultimate Cart, but NOT on Incognito until Candle releases an update for the CPLD code. I believe this is related to the memory protection bug that Jon found.

Share this post


Link to post
Share on other sites

Every time I mention that I am told there is a workaround on the bug, can you explain this to Jon for me, I've never managed to work around it. I can't get it to happen BXE just won't run in Incognitos world... fricken frack sussen frussen frusser fratz...

  • Like 3

Share this post


Link to post
Share on other sites

Will BXE work on an Uno Cart or Ultimate Cart?

 

Yep. I've got most of the usual OSS languages and tools on my UNO Cart - BASIC XL, BASIC XE, Action!, and MAC/65 all work great. The Writer's Toolbox (or whatever it's called) works too, so long as you boot with the associated disk or disk image that goes with it.

Share this post


Link to post
Share on other sites

For you folks that do have BXE working on alternative multi-carts, can you get the extensions to work correctly? (I've seen some patches that will boot the BASICXE.OSS file, but crash when you use some of the extended commands/functions.)

 

That was always the stumbling block that I found using the files for the Atarimax 1-Mb and 8-Mb carts. It was also the same issue for the BXL extensions.

 

A modified set of BXE extensions from Mr-Atari does work properly with the MyIDE-II.

 

-Larry

Share this post


Link to post
Share on other sites

For you folks that do have BXE working on alternative multi-carts, can you get the extensions to work correctly? (I've seen some patches that will boot the BASICXE.OSS file, but crash when you use some of the extended commands/functions.)

 

That was always the stumbling block that I found using the files for the Atarimax 1-Mb and 8-Mb carts. It was also the same issue for the BXL extensions.

 

A modified set of BXE extensions from Mr-Atari does work properly with the MyIDE-II.

 

-Larry

 

I admit to mostly just fooling around with non-Atari BASIC versions (since Atari BASIC was what I grew up with, it's just like a pair of comfy, worn out slippers :) ). But I have the BASIC XE Extensions Disk that luckybuck has up on his AtariWiki page (linked above).

 

​Is there some issue using it with the .car and .bin versions posted there? Do you have an easy test program that will access an extension from disk that people can try?

Share this post


Link to post
Share on other sites

some extensions look for the original banking schema in some cases... so you need to either fix/modify those also or you need an

Ultimate cart, Uno, or another device that follows the correct banking scheme for them to work correctly.

Edited by _The Doctor__
  • Like 1

Share this post


Link to post
Share on other sites

@DrVenkman: No, but I'll try them. I have an Ultimate and Uno, so we'll see how they do. Gives me something to do today before football... ;-)

 

-Larry

  • Like 1

Share this post


Link to post
Share on other sites

Will the MyIDE II flash cart available on Atarimax.com run OSS Basic XE? I'm not as familiar with Atari technology as most other who replied to this topic. What I'm looking for is a multi-cart onto which I can load Basic XE and run it on my XE GS. If the MyIDE II cart won't work, are there any other carts currently for sale which will run it?

Share this post


Link to post
Share on other sites

Will the MyIDE II flash cart available on Atarimax.com run OSS Basic XE? I'm not as familiar with Atari technology as most other who replied to this topic. What I'm looking for is a multi-cart onto which I can load Basic XE and run it on my XE GS. If the MyIDE II cart won't work, are there any other carts currently for sale which will run it?

 

I don't know diddlysquat about the MyIDE II, but I can say with certainty that the UNO Cart and Ultimate Cart will do so, and in its original screwy OSS bankswitched format, as well as in more recently hacked/rewritten "linear" format. See the AtariWiki page linked several posts above for downloads of whatever version you want. You can buy UNO and Ultimate Carts from AtariAge user "MacRorie." He's got a general "for sale" post for these in this forum (the thread has probably dropped down a bit). You can also reach him through his business website:

 

www.thebrewingacademy.com/pricelist.pdf

Share this post


Link to post
Share on other sites

MyIDE II?

Based on the available information YES and you must use the Modified extensions disk from Mr Atari. Not sure how this will affect the use of programs and code across all these flavors of the language though. It would suck if it doesn't all work, and even more so if not with the original cartridge and extensions.

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...