Jump to content
Sign in to follow this  
Osxster

Troubleshooting sio2pc Serial (Mac but could apply elsewhere)

Recommended Posts

More progress... With DTR and RTS cut, I am now able to get RespeQt for the Mac to boot my Atari up. However I was only able to get it to work with no flow control. If I enable any of the flow control options such as RI, CTS, or DSR, I get the same failures as before. Flow Control set to NONE seems to work. I guess the next question is why is flow control not working with RespeQt on the Mac? Also why is it turning on DTR and RTS when it seems that they should not be on.

 

It seems to boot pretty quick, like my Happy in non-Warp speed mode. I only tried the game Tapper so far, but I am sure others will work. I might be able to use it like this, but I would think I could run into problems without flow control.

 

The only other thing I wonder about is why did APE for Windows not work. I'm not too concerned about it, but I'd love to know why.

 

Osxster

Share this post


Link to post
Share on other sites

flow control works with some MAC installations, provided the driver and usb to rs232 adapter implement hardware flow control properly. It sound like the usb to rs232 converter doesn't control them quickly enough independently for them to be valid or ties them together to make a pseudo strict flow control on the cable level.

 

RI will not work unless the edge tick box is set.

 

It is possible flow control of you adapter cable is expecting complimentary flow control signal from the attached device... I have seen that when a cable ties them together requiring all flow signals to say it's okay to send or not , receive or not , then most connected devices can fail , since they can accept individual signals based on how you set them up but the converter does not. This sort of thing used to mess up serial eprom burners back in the day, it's probably part of your issue....

 

none flow control should be just fine as sio has methods of control and error checking to some degree within itself as part of it's protocol

 

does ape work now that you disconnected the lines in the cable?

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

Flow control works fine with RespeQt on a Mac if your device is compliant and wired up properly. I used an FTDI-based device for years on a MacBook Pro with DSR flow control.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for everyone's help so far in this. I will give APE a try with RTS and DTR disconnected to see if it makes a difference. In regards to my Adapter, as it seems to work without disconnecting the DTR / RTS using RespeQt 4X for Windows, I am wondering if the drivers on the Mac are treating this adapter differently especially as when I open RespeQt on the Mac, DTR and RTS illuminate when the COM port is opened where as they do not with RespeQt 4X for Windows using the same computer, same cable, and same USB adapter (just using a Virtual Box VM). What OS are you guys running on your Mac's? I am using the built in FTDI drivers that come with High Sierra, are you using custom FTDI drivers?

 

Osxster

Share this post


Link to post
Share on other sites

I have tried APE for windows with my Prolific and FTDI USB Serial Adapter on the mac using a Virtual Box VM, I cannot get it to successfully boot the Atari. The closest I can get is if I setup RI flow control, the Atari tries to boot when using the FTDI interface. But I end up with some beeps and pauses with BOOT ERROR's. I can only get this when I set the SIO to slow speed. Otherwise I get nothing. None of the other flow control options work. I also don't see an option in there to disable flow control. I can get RespeQt 4X for Windows to work properly on an XP VM using DSR flow control, using my adapter which has RTS and DTR lines removed. This is with the FTDI adapter. The Prolific Adapter partially works with NONE flow control, I can get programs to boot, but I get BOOT ERROR's though.

 

Using the Mac directly with RespeQt 4, using the FTDI Adapter with my custom DTR/RTS cut cable, I can get RespQt to work pretty reliably, but only with flow control set to NONE. No other option works. Using the Prolific Adapter with my customer DTR/RTS cut cable, RI and DSR flow control seems to work, although there are some SMALL pauses when booting. During the pauses you hear that 'farting' noise, but I am thinking that the Atari may be sending flow control because the MAC might be sending too quick. (It would be nice to know what the technical term is for that 'farting' sound). Looking at the logs on both the Windows and Mac version of RespeQt, when the pauses occur, you see messages such as "Serial port set to 19200" each time in-between the Read sector messages. With Flow Control set to NONE, you do not get any pauses, but I don't know if there are read errors occurring that I don't know about but I have timed booting and it is quicker with flow control set to NONE. Tapper for example takes 21 seconds to boot with RI flow control where as it takes 17 seconds to boot with flow control set to NONE.

 

I guess I am getting some successes, but overall this isn't working completely as expected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...