Jump to content
Farb

SDrive-MAX ATX support

Recommended Posts

1 hour ago, MADRAFi said:

I would suggest redesigning the interface so it could present long filenames on the file list.

It does on the SDrive ATR that auto boots

Share this post


Link to post
Share on other sites

I know it kind of do on atr. but I am used to the screen in the sdrive-max.

I am talking about whole list with long name.

This doesn't look like it:

SDRIVE.jpg

Share this post


Link to post
Share on other sites
7 hours ago, Umberto said:

It does on the SDrive ATR that auto boots

with control-L you can display long file names but the option doesn't stay like that. after a reboot it is gone. is it possible to set it permanent?

 

Edited by tajvdz

Share this post


Link to post
Share on other sites
1 hour ago, tajvdz said:

with control-L you can display long file names but the option doesn't stay like that. after a reboot it is gone. is it possible to set it permanent?

 

If you press Control-W, the change is written into the config file and it is permanent. 
 

I suggest @Mr Robot’s excellent website on everything to do with Sdrive Max. I consider it my online manual. 
 

https://atari8bit.net/everything-sdrive-max

 

I believe I am crediting the correct person. If I am not, my sincere apologies. 
 

Bob C

  • Like 2

Share this post


Link to post
Share on other sites
On 1/29/2020 at 2:04 PM, Mclaneinc said:

My question is this, the SD-Max is a drive emulator but has anyone thought of expanding on the principle and making it a multi drive type emulator, as in emulating a Happy, an Archiver etc as optional drive types. Now I accept there may be pitfalls about the happy code ownership but by the way there's other happy stuff about it can't be a huge problem.

 

Excuse my lack of knowledge but is this even viable, is there enough storage to flash the chip with?

 

Obviously it needs the coding as well but Altirra has pretty much fully emulated the hardware and is the source is free to use (I think).

This would be difficult, because the 32K flash is nearly full, and the intention of SDrive-MAX is KISS(keep it small and simple).

 

16 hours ago, MADRAFi said:

Is there any one who is actively working on the firmware development?

I would suggest redesigning the interface so it could present long filenames on the file list.

Without it usability is very poor. I know that this device is not very fast but is there a possibility to implement screen scrolling when previewing list of itmes?

Especially when you do have a sd card with all the games or demos that was made :)

This is not possible, because we have no screen buffer, and must draw each pixel manually. Otherwise this would be very slow on this interface with 16MHz, and we cannot make the font too small, because one should be able to select filenames with fingers.

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, kbr said:

This is not possible, because we have no screen buffer, and must draw each pixel manually. Otherwise this would be very slow on this interface with 16MHz, and we cannot make the font too small, because one should be able to select filenames with fingers.

What about redesign of buttons layout?

put them on the bottom? and make more space horizontally so longer filenames are present?

Use icons instead of words, reduce number of buttons? I would say Last and Top are not required.

Share this post


Link to post
Share on other sites

Do you really think, this 5 or 6 chars more, makes the Kraut fett?

 

Icons are no option, because icons needs much more memory, that we don't have, than simple chars.

Edited by kbr

Share this post


Link to post
Share on other sites

Redefine Character set make an icon from a letter.

Anyway the way it works now makes is much worse option comparing with sio2sd when it comes to browsing large archives of games with long name especially when the directory have multiple file versions.

Share this post


Link to post
Share on other sites

Good idea, may need only 5 bytes/icon, but poor b/w and 5x8 resolution.

I will keep it in mind...

 

Share this post


Link to post
Share on other sites
On 11/15/2019 at 11:02 PM, Mr Robot said:

923414021_Screenshot2019-11-15at14_17_23.jpg.3568fa22c5d0e8acccf568f6f4e3530a.jpg

 

$5.55 for 3 from OSHpark, cheaper for 100 from China :) 

Mr Robot will you post link to OSH? Thank for continuous refinements:-)

Share this post


Link to post
Share on other sites

When I have something to post, I'll post it. Other priorities (mostly personal) are keeping me from getting to finish some of the projects I'm currently involved in.

 

I did make one of these and test it, it didn't work but I haven had time to look at what I screwed up and fix it

 

Share this post


Link to post
Share on other sites

Hey Team,

I have made a few of these and had a bunch of 2.4" screens that came in a lot.  I managed to find the right firmware to use to get them working.

What i have found is that on a cold boot the Atari does not see the drive and i have to do a quick power cycle of the machine to get it to recognize.

i suspect it is something to do with the sdcard not initializing fast enough on boot up.

My system is a Pal 130XE and I am getting power from the SIO port.  Wondering if there is any hack that can be done to the uno to get it to initialize faster is that is what the problem is.

Thanks

 

Share this post


Link to post
Share on other sites
1 hour ago, mamejay said:

and I am getting power from the SIO port.

That’s the problem - the Atari boots up faster than the Arduino gets up and running. You either need to alter your device for external power and have it running before the Atari boots, or do some kind of mod to your Atari that lets you cold boot without a power cycle. 

Share this post


Link to post
Share on other sites
14 hours ago, DrVenkman said:

That’s the problem - the Atari boots up faster than the Arduino gets up and running. You either need to alter your device for external power and have it running before the Atari boots, or do some kind of mod to your Atari that lets you cold boot without a power cycle. 

I was advised here to move away from powering externally.  Strange that I have one 2.8" screen and that works perfectly.  just seems to be the 2.4" screen.  Could it be something to do with the LCD and SDcard hardware on it?  i might just reformat the sdcard and see if that makes any difference.  Could be the sdcard being a ms too slow

Share this post


Link to post
Share on other sites

Maybe it depends on the display type, some needs more code and time for initialization, than others.

Hold down the reset key during power on until sdrive-max is ready!

 

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...