Jump to content
amstrudy

Just got my first TI 99/4A!

Recommended Posts

Someone gave me 5-6 boxes full of ataris, intellivisions, colecovisions, and two TI 99/4As (one still in its original box). Ive never played with these before since I didnt grow up with them, but I was eager to try it! One TI works beautifully, and the other has jumbled letters. Ill attach some photos, but does anyone know what may cause this issue? Thanks again! This seems like a cool forum.

post-63964-0-40346600-1520788909_thumb.jpeg

post-63964-0-90282200-1520788928_thumb.jpg

post-63964-0-48414500-1520788944_thumb.jpeg

post-63964-0-52893800-1520788962_thumb.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the link! From my searches on the internet I figured it was a RAM problem. In that wiki article, none of he pictured examples match my symptoms exactly. I think I’ll open up the machine and check for damage or corrosion.

Share this post


Link to post
Share on other sites

Thanks for the link! From my searches on the internet I figured it was a RAM problem. In that wiki article, none of he pictured examples match my symptoms exactly. I think I’ll open up the machine and check for damage or corrosion.

 

yeah this the notorious bad 4116 dram problem, they are the most prone to failure if it were me i'd replace them all with 4164's (there's a thread here on how to do that, requires some modifications of the 4164 chips but works great, less power and less heat) and or installing a f18a VDP replacement gets you new ram and vga out :) they are currently being manufactured for another run not sure what the eta is..

 

Greg

  • Like 3

Share this post


Link to post
Share on other sites

I've done the DRAM replacement before and it's pretty straightforward, if you are interested in messing with the hardware.

 

However, I would recommend the F18A instead as it is a very useful upgrade. As mentioned though, they aren't available right now, but I would recommend getting on the waiting list. See: http://codehackcreate.com/store#!/F18A-V1-5-Video-Board/p/14022176/category=0

 

(I'm waiting on a couple myself.)

  • Like 2

Share this post


Link to post
Share on other sites

https://www.ninerpedia.org/wiki/Troubleshooting

 

Edit: Not contained in that list ... but maybe another combination of failed VRAM

 

Hmmm. How do you get from

TEXAS INSTRUMENTS

HOME COMPUTER

to

TGXAQ ILQTPWOELTQ

HOUE ADMPWTGP

 

Bit 1 flipping. Not an error I have ever seen as usually I deal with stuck bits. Even better, it is inconsistent as "E" does not always change to "G", but look at the bottom line: that bad console is a v2.2 ("T0,0").

 

01000101 E

01000111 G

 

01000011 S

01000001 Q

 

01001100 L

01001110 N

  • Like 3

Share this post


Link to post
Share on other sites

One note on the machine with the garbled text. As that is most likely a V2.2 console, it won't run most 3rd party cartridges (ROM only stuff). It will run cartridges sold by Texas Instruments and Parker Brothers. This is a "feature" introduced by the 2.2 ROMs. Some folks want those consoles, others despise them. There are ways around the problem, but most of those are no longer readily available (GROM Busters from CorComp or Navarone).

 

Welcome to the community!

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...