Jump to content

Recommended Posts

21 minutes ago, sramirez2008 said:

Loving it. Hope the voice synthesis is included (AtariVox?) too.👍

Carlos hopes to have voice synthesis in the game eventually as it was a feature in the arcade version. It's not included in the WIP version I have at the moment.

 

- James

  • Like 1

Share this post


Link to post
Share on other sites

It's very confusing playing H.E.R.O. in the foreground, while they're playing H.E.R.O. in the background. ;)

 

A little less distracted (start of level 12):

 

hero-patch.thumb.gif.c25542b561e43cad0f55cba94360ed80.gif

  • Haha 4

Share this post


Link to post
Share on other sites
21 hours ago, Nathan Strum said:

It's very confusing playing H.E.R.O. in the foreground, while they're playing H.E.R.O. in the background. ;)

 

A little less distracted (start of level 12):

Damn, I need some offline practice on this game I think! ;-)  Great score!

 

- James

Share this post


Link to post
Share on other sites

Join us LIVE tomorrow (Tue Sep 08) on the ZeroPage Homebrew Twitch livestream at 6PM PT | 9PM ET | 1AM GMT!


Twitch Stream: https://www.twitch.tv/zeropagehomebrew/

 

Tomorrow we'll be taking the 2600 somewhere it's never been before, into the 21st century and onto Internet! The new PlusCart from @Al_Nafuur not only allows the VCS to not only go online, download games remotely but also enables MULTIPLAYER ONLINE GAMING as well as automatically registering your high scores!!


We will be doing a full length special on the PlusCart going through the hardware, software, setup, high score registering, downloading & playing binaries as well as online gaming! We will also have a Q&A with the creator of the PlusCart! You don't want to miss it!

 


473087158_20200908-LetsPlay.thumb.jpg.91c86cdb525b499630c10f4babf716a5.jpg

 

 

Edited by ZeroPage Homebrew
  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Andrew Davie said:

I'm preparing a DDOS attack to your PlusCart, James.

You'd better hope I get my timezones wrong.

Hahahah. I better install some anti-DDOS software on my 2600!!

 

- James

  • Like 1

Share this post


Link to post
Share on other sites

Tonight's PlusCart show revealed another glitch on James' console. On a normal console, the menu characters are perfectly spaced, on James' there seems to be a sprite positioning problem which shifts 3rd and 4th 1st, 2nd and 5th, 6th characters one pixel to the left right. And the top line of the very first character is affected too.

Edited by Thomas Jentzsch

Share this post


Link to post
Share on other sites
3 minutes ago, Thomas Jentzsch said:

Tonight's PlusCart show revealed another glitch on James' console. On a normal console, the menu characters are perfectly spaced, on James' there seems to be a sprite positioning problem which shifts 3rd and 4th characters one pixel to the left. And the top line of the very first character is affected too.

 

Yes, I mentioned that during the show but was fobbed off -- they reckoned the spacing was there.

I still think it was definitely wrong.

 

Share this post


Link to post
Share on other sites

Also I noticed that the selected line's color is not centered correctly anymore.

 

Bugs reported in the club.

Edited by Thomas Jentzsch

Share this post


Link to post
Share on other sites

Something that I don't quite understand with ZPH twitch stream...

@ZeroPage Homebrew always says something like "make sure you're watching at 60FPS"

Well, I do, and I still always get the shimmering that makes it very clear that it's NOT at 60FPS.

For example, the latest show with the PlusCart display. I got a lot of up/down movement of the font lines - rather than blending smootly (two frames at 30Hz each), we seemed to be getting some sort of weird subsampling of that.  I rewatched again just now, selected 1080p 60Hz and still that frame shimmer is there. I'd really like to know where this loss of quality is coming from - my side of the pond or yours.


I tried the popup player. No change.

I tried a different browser. No change.

I tried with and without my VPN. No change.


I'm using MacOS. I am beginning to wonder if the Atari screen(s) being shown is truly 60fps.  
Basically, that up/down wobble should be much much less discernable than it is.

 

Is anyone else having this issue, or is it just me?

 

 

Edit: Tried Safari and it works properly.

Mmmh.... interesting.

Edit: OK, mostly fixed - turned on hardware acceleration in Chrome.  Some sites need it on, some off. Annoying, but at least I can now watch ZPH without being annoyed at the technical stuff.

 

Edited by Andrew Davie
  • Like 3

Share this post


Link to post
Share on other sites

I always get the shimmering too, and I saw the frame shimmer and jumping text on last night's show too.  It is usually worse on my Galaxy Tablet (using the Twitch App)  than in Chrome on my laptop.  "60fps-like".    I didn't realize it could be fixed. I thought it was a consequence of losing frames because of the streaming. 

Share this post


Link to post
Share on other sites
On 9/9/2020 at 12:05 AM, Andrew Davie said:

Yes, I mentioned that during the show but was fobbed off -- they reckoned the spacing was there.

I still think it was definitely wrong.

It was definitely more like a thin half pixel line on the stream and less of a space.  EDIT: Now that I know what I'm looking for, it's really obvious that there's an issue. See below...

 

On 9/9/2020 at 12:06 AM, Andrew Davie said:

@ZeroPage Homebrew run the attached binary on Stella. The letters should look nicely and evenly spaced.

Next, put it on your PlusCart. Does it look ***exactly the same***?
plus.bin.zip

Just got a chance to run the binary in Stella and through the console. Here they are side by side:

 

plus_bin.thumb.png.1593c14eaeb4df871d7562bf607b353a.png

 

There's definitely some pixel aspect differences, which  but everything else looks pretty good. Oh wait.... now that the system's been on a while.. here's another screenshot comparison:

 

plus_bin2.thumb.png.ea8f3315f4ed239f19b42b96e429f6ad.png

 

Seems to be a similar issue I've seen with Pesco and Omegamatrix's menu on my system where things start to change once the system is warmed up. Ugh! 😞 Time to throw the system out the window? What I can do to fix this?

 

On 9/9/2020 at 6:12 AM, Andrew Davie said:

Edit: OK, mostly fixed - turned on hardware acceleration in Chrome.  Some sites need it on, some off. Annoying, but at least I can now watch ZPH without being annoyed at the technical stuff.

This is excellent information, thanks for figuring this out Andrew! I'll definitely give out this suggestion to try if someone else is having similar issues. I know I've had to turn off browser acceleration in the past on my own computer if I have to capture video from it.

 

- James

Share this post


Link to post
Share on other sites
25 minutes ago, ZeroPage Homebrew said:

Oh wait.... now that the system's been on a while.. here's another screenshot comparison:

 

plus_bin2.thumb.png.ea8f3315f4ed239f19b42b96e429f6ad.png

 

Seems to be a similar issue I've seen with Pesco and Omegamatrix's menu on my system where things start to change once the system is warmed up. Ugh! 😞 Time to throw the system out the window? What I can do to fix this?

 

It shows how "close to the metal" these bits of code are.  You see how much more beautiful the display is when the fonts are spaced properly :)

 

Personally I wouldn't be using this system for a show and demonstrating games. You want something rock solid and "fair" to the developers.  I wouldn't throw the system away - it's valuable for finding such bugs. But as I said, I wouldn't have it as my main system for broadcasting.

 

 

 

 

Share this post


Link to post
Share on other sites
2 hours ago, ZeroPage Homebrew said:

Seems to be a similar issue I've seen with Pesco and Omegamatrix's menu on my system where things start to change once the system is warmed up. Ugh! 😞 Time to throw the system out the window? What I can do to fix this?

I would first try to replace the TIA.

  • Like 2

Share this post


Link to post
Share on other sites
3 hours ago, Andrew Davie said:

...it's valuable for finding such bugs

True. It helped implementing some glitches in Stella. Which should help developers to stay on the safe side (if possible).

Share this post


Link to post
Share on other sites

But then, in this thread Alex_79 writes:

Quote

I swapped the TIA between the Vader and the Sixer, but it made no difference, so the different behaviour is caused by the console itself, not the TIA revision.

So exchanging the TIA might not help. Which would leave the question if the RGB mod is causing the problem or the console.

Share this post


Link to post
Share on other sites

Hi James, i missed the HSC games on the stream however went back and rewatched later. Great effort and score with City Defence considering it's basically your first time playing in it's current state. The game is definitely an acquired taste much like Missile Command. Takes alot of practice and timing is everything (much like Bass Fishing). Thanks for giving CD a run and yeah Expert difficulty is no joke, so without a fluent feel for the game, it's intense. Cheers mate 👍

Share this post


Link to post
Share on other sites
On 9/11/2020 at 12:29 AM, Thomas Jentzsch said:

But then, in this thread Alex_79 writes:

So exchanging the TIA might not help. Which would leave the question if the RGB mod is causing the problem or the console.

I'm going to try to find some people who have also done the RGB mod and see if they experience any of the same glitches. That way I might be able to narrow down what part the RGB mod might play a role in.

 

- James

Share this post


Link to post
Share on other sites
4 hours ago, TwentySixHundred said:

Expert difficulty is no joke, so without a fluent feel for the game, it's intense. Cheers mate 👍

That's for sure, man that was certainly a challenge! It makes sense to crank up the difficulty to max for a high score contest. 🙂

 

- James

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...