Jump to content
tmp

AVGCart

Recommended Posts

I tried several ones and none worked for me. Maybe I did something wrong. I'll upload a video of what I got. But it is basically corrupted images and sound with a band (pm?) moving slowly from top to bottom.

list of things that could be causing problems

 

- using pal encoded videos on ntsc machines and vice versa

- files (avf) not contiguous (defragmented) on the sd card (use contig.exe on windows/filefrag on linux to check)

- there could be sd cards that don't work well for this purpose - TBD

- i might have broken some timings in player for ntsc (i can't test that) - TBD, i think rdea6 said ntsc videos worked for him, need more confirmations

 

also there could be a bug that is not obvious but could lead to video/audio quality issues, a/b testing with side2 would be needed but i don't own one so i can't tell whether it's working as it's supposed to (i especially didn't like that high pitched noise in philsan's video but can't tell if it's the same with side2)

Edited by tmp
  • Like 2

Share this post


Link to post
Share on other sites

also there could be a bug that is not obvious but could lead to video/audio quality issues, a/b testing with side2 would be needed but i don't own one so i can't tell whether it's working as it's supposed to (i especially didn't like that high pitched noise in philsan's video but can't tell if it's the same with side2)

Yes, there's a similar noise with SIDE2 too.

Hear near the end.

 

In the other thread Phaeron just explained:

 

It is the 15KHz carrier from the PWM technique used to generate the audio. Standard 4-bit volume encoding can be used instead, but the sound would be muffled at the high end instead.

PDM would have better quality, but there are currently not enough cycles in horizontal blank. Volume-only is LDA + STA, PWM is LDA + STA x 2, PDM requires LDA x 2 + STA x 2.

  • Like 4

Share this post


Link to post
Share on other sites

Hi everyone,

Would this configuration of stick controls with the TAB rotation drive slots joystick assignable be more intuitive? or?

 

stick up/down move up/down one entry on the list

 

stick held up/down then button move a page of the list at a time up/down

 

stick right/forward go in a directory

 

stick left/back go out/back a directory

 

button selects the image

 

stick right/forward and button assigns a rotate slot like tab does for atr's.

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

AVG CART-WHERE CAN I ORDER ONE CART

 

 

Er, this was in the post 2 before yours?

Send a personal message to the AVG Cart's creator, username 'tmp'

Share this post


Link to post
Share on other sites

So I've been having lots of fun with the cart, but I have an issue which I'm assuming won't be able to be resolved, just looking for confirmation really.

 

The machine I'm using it in is a Frankenstein 65XE I picked up on eBay almost a decade ago, and all still works fine. It has 1mb RAM (unknown type), inbuilt SpartaDOS X (4.42 I believe), stereo Pokey, Aki keyboard interface, and a 4 in 1 OS which has two versions of QMEG installed, and the 400/800 OS as well as regular XE.

 

The issue with AVGcart is when XL/XE OS is active and intSDX is also active, the machine boots to blue screen and cursor and nothing further. With intSDX inactive AVGcart boots fine. Clearly there's a conflict but I've no clue what it is! AVGCart has the latest firmware on it (r15?)

 

I've never had this machine to bits so at the moment can't provide any further detail on the hardware mods; but has anyone come across this previously?

 

IIRC my Mac65 cart exhibits the same behaviour.

 

ta

 

PS. I should add that all the hardware mods have hardware toggle switches to switch them in or out - no software toggles. I do have one switch that I have no clue what it does but that's for another thread :)

Edited by NuY

Share this post


Link to post
Share on other sites

hard to tell, never seen intsdx, i can't even tell what should be the expected behavior when you basically have 2 carts (sdx and avg) trying to start at once

 

anyone, is intsdx + cart technically the same thing as having sdx cart with that another cart plugged into its passthrough slot? does avgcart work in this configuration?

Share this post


Link to post
Share on other sites

if you are using the avg as your ide drive and want to use it with other cart, with computer set in a mode that works with the avg, set the ide mode and such and leave then switch on the other stuff that conflicts... do you have storage device now? I used that method for a few things...

 

I have posted pictures of the AVG working with about 5 carts at a time... You do also realize you can put sparta on the avg...

 

I further tested the concept by carefully hot swapping a problem cart in and that also worked....   the only caveat being no cart can trample the control method of the other.... even that can be mitigated slightly if using a controlled pass thru type cart to filter a problem line out of the equation. If this sound like an concept from MARS or some distant planet, it might be... but worked. Might even be part of the old mars8 conceptually

Edited by _The Doctor__

Share this post


Link to post
Share on other sites
23 minutes ago, _The Doctor__ said:

if you are using the avg as your ide drive and want to use it with other cart, with computer set in a mode that works with the avg, set the ide mode and such and leave then switch on the other stuff that conflicts... do you have storage device now? I used that method for a few things...

 

I have posted pictures of the AVG working with about 5 carts at a time... You do also realize you can put sparta on the avg...

 

I further tested the concept by carefully hot swapping a problem cart in and that also worked....   the only caveat being no cart can trample the control method of the other.... even that can be mitigated slightly if using a controlled pass thru type cart to filter a problem line out of the equation. If this sound like an concept from MARS or some distant planet, it might be... but worked. Might even be part of the old mars8 conceptually

No IDE configured at all. As mentioned, this is not a physical SDX cart, it is intSDX inside the case and when it's activated by the toggle switch and the AVGcart is plugged in the regular cart port, on switching the XE on I get the regular blue display with cursor at top left and nothing else. If intSDX is toggled off, then AVGCart boots to its regular grey screen with the contents of the SD card displayed.

Share this post


Link to post
Share on other sites

internal SDX is more than likely seizing the cartridge control lines.... if you are using it for spartados, the AVG will happily run the larger SD X images and provide IDE storage at the same time....

 

Try this, turn off intsdx select a cartridge you want to use ie Express! etc... flip the switch... exit the express cart using the exit function... if you still don't have sparta try sparta on or xon.exe etc.... you could even try typing bye then reset or just press reset..

 

remember also depending on the version of sparta turning using basic off or car off can affect a particular cartridge. Be aware of what you have in your startup, autoexec, config.sys etc...   I had an issue where basic off and key off was killing a cartridges access... I had to remove them from the rom image and keep it on disk instead. expecting the disk to take over for a cart that polls for dos first can allow the rom to assert it's copy of those files.

sometimes the default are at fault...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...