Jump to content
tmp

AVGCART

Recommended Posts

59 minutes ago, Mr Robot said:

Yeah I just disabled PBI on my XEL

I don't know why you would disable the PBI BIOS. Leave it on, disable cart ROMs, and when the AVG is in SIDE emulation mode, everything should just work. You don't need the SDX ROM or the SIDE driver on the AVG cart - just the emulated IDE interface.

1 hour ago, Mr Robot said:

Should I be able to do it with a stock 130XE?

Yes: no problem at all.

Share this post


Link to post
Share on other sites
2 hours ago, tmp said:

let me know whether that works and also don't use it for anything else but running fdisk (on stock machines)

 

I'll test it tomorrow

 

Share this post


Link to post
Share on other sites
1 hour ago, flashjazzcat said:

I don't know why you would disable the PBI BIOS.

I didn't want to use any of the XEL functionality. I'm writing some AVGCART documentation and I need to check everything I'm writing as I go to make sure what I write matches what actually happens.

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, Mr Robot said:

I didn't want to use any of the XEL functionality. I'm writing some AVGCART documentation and I need to check everything I'm writing as I go to make sure what I write matches what actually happens.

Excellent. I hope you document operation with the U1MB PBI BIOS as well.

Share this post


Link to post
Share on other sites
2 hours ago, flashjazzcat said:

Excellent. I hope you document operation with the U1MB PBI BIOS as well.

It'll get included in a "If you have a U1MB, you can also do it this way" note. If I ever write a user guide for the U1MB I'll be more in depth but your firmware documentation is already incredibly thorough so I don't think there's any real need.

 

  • Like 1

Share this post


Link to post
Share on other sites
6 minutes ago, Mr Robot said:

If I ever write a user guide for the U1MB I'll be more in depth.

You needn't go overboard, since detailed documentation already exists:

 

https://atari8.co.uk/wp-content/uploads/Ultimate-1MB-Incognito-and-1088XEL-U1MB-Firmware-Manual.pdf

 

https://atari8.co.uk/wp-content/uploads/Loader-Quick-Reference.pdf

 

AVG isn't specifically covered, though.

Edited by flashjazzcat

Share this post


Link to post
Share on other sites
12 hours ago, tmp said:

i hexedited the s2dx3.car to change config.sys (in my usual "i have no idea what i'm doing but let's try and see" fashion), it now seems to load fdisk on stock 64kb but i haven't tried to go through the whole partitioning procedure

 

let me know whether that works and also don't use it for anything else but running fdisk (on stock machines)

 

s2sdx3_fdisk.zip

 

Worked perfectly on a stock 800XL :)

Initialized the disk, split 64GB into a 1GB APT and the rest for FAT, split the APT into 15*65535 partitions, wrote to disk. It all went without a hitch.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

There is a problem in macOS when the disk is prepped that stops you formatting the fat partition.

 

By default Disk Utility only shows Volumes, but there is an option to show all Devices. If the device is not a valid device, it does not appear in the device list, it does show it in the volume bar but it's not selectable there. As an example, here is my AVGCART SD.

 

1670103377_Screenshot2020-06-22at07_42_57.thumb.png.5191e0f01b370f4ca5167b7d0d3809ca.png

 

In the sidebar you can see The SD card and under it the volume AVG, you can't see disk2s2, which is my 1gb APT.

 

The problem is that after being FDISK'd the SD card has an APT and a RAW partition, neither of these are valid so neither of them appear in the sidebar, the only option you are given is the entire device and if you select erase there it will delete your partitions.

 

I got around the problem using windows 10. Disk manager allowed me to format the raw partition as exFAT which was then visible to the mac so I could selectively erase that to FAT32, I suppose I could have used fdisk but I think that's beyond most mac users and documenting how to do it is fraught with opportunities to trash something important.

 

 

Share this post


Link to post
Share on other sites
43 minutes ago, Mr Robot said:

There is a problem in macOS when the disk is prepped that stops you formatting the fat partition.

Already known.

43 minutes ago, Mr Robot said:

suppose I could have used fdisk but I think that's beyond most mac users and documenting how to do it is fraught with opportunities to trash something important.

I heartily recommend users read the APT manual before prepping a card:

 

https://atari8.co.uk/wp-content/uploads/APT-Software-Manual-7th-Edition.pdf

 

Capture.thumb.PNG.3d4efc25aa92172ccfe8693e8e47897c.PNG

Share this post


Link to post
Share on other sites

So you're saying I should have read past page 15? I thought I was doing well reading pages 3-15 and not just watching the video :D 

 

I didn't bother with a FAT16 partition, the AVGCART only sees the first FAT partition so I left it out.

  • Haha 1

Share this post


Link to post
Share on other sites
On 6/20/2020 at 2:47 PM, Mclaneinc said:

Hope it drops soon..

Found it in my mailbox today , my gratitude once more Paul for this !

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, Mr Robot said:

I didn't bother with a FAT16 partition, the AVGCART only sees the first FAT partition so I left it out.

Bear in mind the SIDE loader (which is highly pertinent to U1MB users with AVG and to some non-U1MB users) supports up to fourteen FAT partitions.

Share this post


Link to post
Share on other sites

Crimping and soldering all done. Ran out of SIO plugs so I'm printing a few more.

 

IMG_3592.jpeg

  • Like 6

Share this post


Link to post
Share on other sites
1 hour ago, Mr Robot said:

Crimping and soldering all done. Ran out of SIO plugs so I'm printing a few more.

 

IMG_3592.jpeg

Very professional 

Share this post


Link to post
Share on other sites

First seven SIO cables went in the mail today, I still have a bunch waiting for people to pay the postage, hopefully next Friday will clear those off the list. Once these are gone I won't be making any more.

  • Like 4

Share this post


Link to post
Share on other sites

Just remade my cable today, stopped working BUT it was too short now I'm using an XL, all fine now, not up to your super standard but works...Nice to see the generosity there...

Share this post


Link to post
Share on other sites

Hello Everyone,

 

New to the forum and this thread. 

 

I'm working on getting my 130xe running again and instead of trying to get the real PBI hard-drive interface working (has a Seagate ST-225 MFM drive), I started researching newer options.  From what I can tell via watching 10 of hrs various YouTube videos (great ones from FlashJazzCat, "The Modern Atari 8bit computer", "8-bit and more", etc, reading all 43 pages of this thread, etc... the AVG cart is the best way to go for those not quite ready to mod their motherboards with option boards.  I've already PM'ed TMP to see if he has any cards AVG left (fingers crossed) and I was lucky enough to get the last AVG to SIO cable from Mr Robot!

 

Now I need to make some orders to Best Electronics to get a replacement keyboard, maybe give his improved 130xe keyboard a try, replace my dead power supply, etc.  I might even try getting one of the new ESP32/Internet adapters to try connecting to some Atari BBSes.  I used to run a Carina BBS on this system back in the early 80s.  I wonder if I should try again!  We'll see.  🙂

 

--David

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...