Jump to content
tmp

AVGCART

Recommended Posts

Power on, wait for menu, press G to go to the PDM directory, Press A to launch first file

 

now I have to press return or space to get the ui. Space space, return return, space return and return space all work. 
 

it’s completely repeatable

 

either a single return or space exits the ui fine


once it’s been entered once pressing space or return once works

 

tried it on my 800xl as well. Same result. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks @Xuel for the Stereo PDM default :D

 

If I can work out how to crowbar a Covox into my XEL I'll give that a try too :)


 

Share this post


Link to post
Share on other sites
2 minutes ago, Mr Robot said:

Thanks @Xuel for the Stereo PDM default :D

 

If I can work out how to crowbar a Covox into my XEL I'll give that a try too :)


 

Search out Lotkarek PIA Covox :)

Share this post


Link to post
Share on other sites
29 minutes ago, Stephen said:

Search out Lotkarek PIA Covox :)

I believe this is too big to fit under the U1MB on the XEL, I've thought about mounting one under the XEL pcb but not done it

 

Share this post


Link to post
Share on other sites

E020 (0020 beta) is available

 

notable changes

 

- support for SIO cable (allows much better ATR support (including HSIO), adds support for ATX/CAS)

- shortcuts/bookmarks

- support for AUTORUN.* file in _AVGCART was removed, replaced by setting autorun dynamically via key shortcuts

- template dir (_AVGTMPL) for easy creating empty disks, ...

- support for file copy (ctrl-c) and delete (ctrl-d)

- INV or Z will scroll filename that's too long to fit the screen

 

OSXEX file was renamed to OSXEX2 (due to incompatible change), included in the zip with update

 

and some more changes that i don't even remember, read the fine manual by @Mr Robot that is up to date with the latest changes

 

as always, report any bugs encountered with as many details as possible to allow me to reproduce them, thanks

 

Edited by tmp
  • Like 5
  • Thanks 4

Share this post


Link to post
Share on other sites

Found an odd but rare item, read only files won't boot off the cart..Was playing around with a File manager and it ran on Altirra up to a point (think the image is messed up) but refused to start on the cart, decided as it wasn't working properly on either environment to delete it off the SD on the PC, it said it was protected as read only. Sure enough, it was read only and once set to normal it booted off the cart but failed at the same place as Altirra..

 

Matters about 0.0000001% but someone may find a file that's the same in their collection..

 

As always, thanks for the update tmp

 

Edit: The file was an ATR, I've not tried any other file types or even another ATR that is set to read only (yet)

Edited by Mclaneinc

Share this post


Link to post
Share on other sites

nice, that's a pretty nasty bug

 

should be fixed in ea20, thanks for reporting

 

EDIT: of course i messed up the fix, i'll redo

Edited by tmp

Share this post


Link to post
Share on other sites

Yup, fixed...Thank you...

 

See, throwing just about anything at it constantly does help :)

 

I have the time on my hands to do it...

Share this post


Link to post
Share on other sites

What was wrong?

 

I like to know so I can throw more stuff at it...

 

 

Share this post


Link to post
Share on other sites
32 minutes ago, Mclaneinc said:

What was wrong?

originally? apparently trying to open a file with rw access doesn't quite work with read-only files (quelle surprise)

shame on me for such a stupid bug

Share this post


Link to post
Share on other sites

I more meant the fix of the fix, it's not important, I'm just being nosey :)

 

As for bugs, yeah, annoying but it happens, and that's what us users are there for, we can't expect you to keep track of every little oddity...It's fixed now so job well done.

Share this post


Link to post
Share on other sites

I'm almost there. Need to add SIO connector and reflash the "fixed fix" firmware. 😜

IMG_20200727_105641803.jpg

IMG_20200727_105702188.jpg

  • Like 2

Share this post


Link to post
Share on other sites

BTW, what is the current of state regarding mailing AvgCarts to the world? I would like to know if it can be sent to USA and how much$$$?

I already have one and I am thinking in another one for a friend which isn't convinced (yet) to get back to this hobby.

 

 

Share this post


Link to post
Share on other sites
1 minute ago, manterola said:

BTW, what is the current of state regarding mailing AvgCarts to the world? I would like to know if it can be sent to USA and how much$$$?

I already have one and I am thinking in another one for a friend which isn't convinced (yet) to get back to this hobby.

it can be shipped and i'm 99% sure it will eventually arrive

how much time it will take to arrive, i have no idea, i don't have current data (i've shipped one last monday so it's too soon to judge, those sent months ago took almost 2 months to arrive)

europe seems to be mostly back to normal (although hiccups can probably occur)

price is in the first post

Share this post


Link to post
Share on other sites
11 minutes ago, Mclaneinc said:

I hope that is going on an XL, that lead length will just about make it..

Ha! Never know what you are getting from China and I do not believe I paid any attention to the length, just the connector type when I ordered 😣

 

It will NOT be long enough for the XL. Maybe an XE, but does not matter. I am mating it up to a longer cable for XL/XE and P:R:Connection. That will give me all the options and flexibility.

Share this post


Link to post
Share on other sites

Actually I meant an XE, oops...XL needs even longer...I just bastardised another cable to make it longer..Ugly but it worked, Mr Robot's cable then arrived and apart from a small mishap in the post it was great...

 

As for the Chinese order, I don't think I gave it any thought about length as well...Mind you, it rarely completely matches the picture :)

Share this post


Link to post
Share on other sites
On 4/27/2020 at 8:14 AM, tmp said:

those 2 wires are ground and a signal line that is not 5v tolerant (unlike the other 4), i had no use for them so i thought about using it as a cable detect and that's why they're joined

 

of course you can join them on the board but i'd probably suggest doing so via 10k resistor just to be safe, i'll test the value later and will let you know

Did you ever confirm if the resistor is required?

 

I was thinking of just connecting the two wires at the connector (maybe 1/4" from connector) end and not running them all the way to the SIO connector end. Two less wires to worry about. Would that be OK or would I still require a resistor?

Share this post


Link to post
Share on other sites

@tmp -- can/do you ship FedEx?  Any idea of the cost?  Just thinking out loud, but I wonder if there are a couple of other potential purchasers here in the U.S. so that we could get a combined shipment and redistribute.  (?)

Share this post


Link to post
Share on other sites
18 minutes ago, Larry said:

@tmp -- can/do you ship FedEx?  Any idea of the cost?  Just thinking out loud, but I wonder if there are a couple of other potential purchasers here in the U.S. so that we could get a combined shipment and redistribute.  (?)

That would be great

 

Share this post


Link to post
Share on other sites

last time i checked i haven't found any alternative means of transportation that would cost less than the cart itself

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...