Jump to content
tmp

AVGCART

Recommended Posts

Yep, that's what I thought, I'll swap around the other XEX's, just incase one was wrongly named..

 

EDIT

 

Yep, the Covox pdm mono is actually, the PDM Mono..

 

Thanks again tmp..At least Xuel can fix the zip..

Edited by Mclaneinc

Share this post


Link to post
Share on other sites

Back here it was mentioned that there was a discussion about storing defaults. I'm assuming that never happened and @Mclaneinc doesn't have an errant settings file somewhere?

 

 

Share this post


Link to post
Share on other sites

I hope this is an appropriate place to pass along that I've noticed the AVGCart has a problem with Ultima IV, when using the game's ATR images via the SIO functionality.

 

When you enter a location like a town, changes to the world map aren't saved. For instance, if you have a ship on the map or a chest or whatever and you enter a town, normally all that stuff would still be there when you exit the town. I'm pretty sure the game is supposed to re-load the world map from your last saved game and then update it with recent changes, but I could be wrong. With the AVGCart you get a pristine world map, devoid of recent items, each time you exit a town. Tested with the same images on Altirra, Atari800, and the Atari 800 MiSTer core, and on those the game works as it should. Also works as it should running the game from an SDDrive Max on real hardware. Put the AVGCart into my 130XE (my main machine is an 800XL), loaded the game there, and the problem is back once again. An example of the behavior would be to take a ship to an island with a town, exit your ship and enter the town. When you leave the town back to the world map, your ship will be gone and you will be stuck on the island.

 

Bonus: one weird side effect of my testing and copying these images back and forth is that one time while playing on the MiSTer, I acquired a ship and subsequently saved the game. Upon copying that image back onto the AVGCart SDCard and playing around a bit, I noticed I now have a permanent ship on the world map. I can take my ship somewhere and lose it and it will always return back to the position where I saved the game while testing on the MiSTer as soon as I enter then leave a location. I sorta chuckled over that one.

 

Anyhow, all in all, still loving the cartridge, beyond this one little sniggle that I've noticed. :)

Edited by eristocratic

Share this post


Link to post
Share on other sites

i think the worst part of fixing this will be figuring out how to play the game ;-)

(i believe i've never played any ultima game on any platform however sad that may sound)

 

if you have any atr with some save state that makes it quick to reproduce the issue, please share that, thanks

 

EDIT: ok, i tried the game in emulator, if i understand it correctly, you create a character and it saves it to disk 2, does this part work and just some later saving is broken or even the character isn't saved?

 

Edited by tmp

Share this post


Link to post
Share on other sites

It's not too hard of a game to pick up LOL... I've been playing it since waiting months for the original Apple release back in the mid '80s. If you need pointers, I'm your guy :) I have to say, though, that U4 nerfs itself pretty well for new characters, giving you a chance to figure out what's going on without dying constantly.

 

Character creation works fine, as does 99% of the game. In fact I played it for a day or two doing all sorts of things before I noticed the world map issue. I'll attach my Britannia disk and some instructions on how to reproduce the problem. BTW the Britannia disk is the only disk that gets written to. Any other game would probably call it the save disk.

 

Start up the game by pressing "J" at the main menu and load up my Britannia disk when it asks for it. You'll be near a town, right next to a chest and a ship. Board the ship by moving on top of it and pressing "B" then use the arrows to move it somewhere else adjacent to land then press "X" to exit the ship. Move on top of the town then press "E" to enter it, then immediately move left to exit the town. The chest will disappear and the ship will have moved back to where it was when you loaded the game.

 

I purposefully saved it that way for demonstration, but probably the easiest way to reproduce it fully for yourself is to move a few spaces away then tap the spacebar to pass a few turns and soon you'll get attacked. Attack the monsters using the "A" and directional keys. When you've killed them all you'll be back at the world map and a chest will be left behind. If you keep getting attacked by subsequent monsters, just move the characters off the edge of the screen to run away. When the coast is clear, enter the town then exit again and poof the chest will be gone. It should have stayed.

 

You'll notice when you hit "E" to enter the town there is a little bit of disk activity before it asks for the next disk. My guess is that this is when the game saves the state of the world map, and then does a disk check to see if it needs to ask for the next disk. Two flashes.

 

If I can help in any way, don't hesitate to hit me up. This is my favorite old RPG and it would be awesome if it worked 100%.

 

eristocratics Britannia Disk.ATR

Edited by eristocratic

Share this post


Link to post
Share on other sites
On 7/17/2021 at 9:31 PM, Mr Robot said:

Back here it was mentioned that there was a discussion about storing defaults. I'm assuming that never happened and @Mclaneinc doesn't have an errant settings file somewhere?

 

 

As far as I know there was never a setting file or the like and it stayed with individual players for each sound system. In the end, for me, it was simply player files wrongly named in the released versions. All fine now after I used the named Covox player which was actually the PDM mono..For once, not my fault, rare I know :)

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, tmp said:

i think the worst part of fixing this will be figuring out how to play the game ;-)

(i believe i've never played any ultima game on any platform however sad that may sound)

Ha ha... It's not sad at all, a lot of people love games like the above, but not everyone, I can't see the fuss over them yet I know it was a massive market back then.

 

I find anything turn based a chore with the exception of one game on the PSX, Vagrant Story.. Very stylish..

Share this post


Link to post
Share on other sites
5 hours ago, Mclaneinc said:

Ha ha... It's not sad at all, a lot of people love games like the above, but not everyone, I can't see the fuss over them yet I know it was a massive market back then.

 

I find anything turn based a chore with the exception of one game on the PSX, Vagrant Story.. Very stylish..

 

Quite true - gotta admit I'm one of those folks. Cut my teeth on paper games like D&D and Paranoia back in the day and moved on to what we now call CRPGs shortly after, mostly Origin Systems titles. Turn based all the way, baby! hehe

 

Thankfully, there's enough gaming in all genres and mechanics to keep us all happy :)

 

Heck, thinking about it, I find myself fixing the old 8 and 16 bit machines more than playing them these days. But repair is sort of a game in itself, I suppose.

 

Share this post


Link to post
Share on other sites
46 minutes ago, eristocratic said:

 

Heck, thinking about it, I find myself fixing the old 8 and 16 bit machines more than playing them these days. But repair is sort of a game in itself, I suppose.

 

Yes, indeed, I don't fix many, but the playing with the hardware is just as much fun as the gaming..

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, eristocratic said:

Start up the game by pressing "J" at the main menu and load up my Britannia disk when it asks for it. You'll be near a town, right next to a chest and a ship. Board the ship by moving on top of it and pressing "B" then use the arrows to move it somewhere else adjacent to land then press "X" to exit the ship. Move on top of the town then press "E" to enter it, then immediately move left to exit the town. The chest will disappear and the ship will have moved back to where it was when you loaded the game.

can you please try this beta to see whether it fixes your issue?

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, tmp said:

can you please try this beta to see whether it fixes your issue?

Awesome :) That seems to have got it. I'll do a bit of playing tonight and let you know if I find any hiccups, but I just messed around with it for 10 minutes or so, and world-mappy-things seem to be staying put now. Big thanks!

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, eristocratic said:

So true.

 

And excuse my manners, welcome to the old site, many people 'lurk' and don't post, but we love it when folks join in.. Lurking is of course also welcome, however you enjoy is most welcome..

 

Paul..

Share this post


Link to post
Share on other sites
18 hours ago, eristocratic said:

Awesome :) That seems to have got it. I'll do a bit of playing tonight and let you know if I find any hiccups, but I just messed around with it for 10 minutes or so, and world-mappy-things seem to be staying put now. Big thanks!

great, thanks for reporting the issue!

Share this post


Link to post
Share on other sites
18 hours ago, Mclaneinc said:

 

And excuse my manners, welcome to the old site, many people 'lurk' and don't post, but we love it when folks join in.. Lurking is of course also welcome, however you enjoy is most welcome..

 

Paul..

Good to be here :) I typically lurk until I've got something to say then jump in there and put everyone to sleep with extreme verbosity hehe

Share this post


Link to post
Share on other sites
7 hours ago, tmp said:

great, thanks for reporting the issue!

Followup: I've played the heck out of it for the past day or so and no issues to report. I did have one problem with a corrupt disk, but I'm pretty sure I did that one all by myself. Whoopsies.

 

And you're very welcome - glad to be using a product I like enough to actually get off my butt and report a problem :)

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...