Jump to content
dabone

Vectrex Break / Fix Guide? Does one exist?

Recommended Posts

I have been working on a unit, and have asked help in this forum about 2 distinct errors, but no one here had answers.

 

I did eventually find enough information to fix one on a old newsgroup post, and took a guess at the second and got it repaired also.

 

Is there a break/fix guide to the console, listing symptoms and common fixes?

 

I'd like to read one if there is, and add my own repair issue to it.

 

 

Later,

dabone

 

Share this post


Link to post
Share on other sites

It had a single horizontal line, with moving graphics and sounds for the game,

 

I found this old old post.

 

http://rec.games.vectrex.narkive.com/JCFdNpMA/replacment-for-ic401

 

"You can also get a slightly different display if only the Y-axis side of the LM379 has failed. In this case you still get normal sound. The display will show a single raster line centered vertically on the screen. In other words you will only see a single line reaching from the right to left side of the screen. Typically this line will have 'dancing dots' on it as objects are being drawn to the screen. You get this display instead of the blank picture as before due to the deflection detection circuits that enable J-FET's 401 and 402 are only taking their sense signal from the horizontal deflection. "

So, I ordered a nos lm379s from ebay along with a cap kit, and got a different scrambled display on half the screen.
The cap kit did NOT come with the Integrator Cap Kit, and I just decided what the hell and gave it a try, and it brought back full screen decent video.
So from single flat line, and the spot killer not working. (If that's what it's called on the vectrex, I'm an old arcade monitor guy) to working by replacing the LM379S (The actual chip driving the gun) , and all the caps.
Still waiting for a multi cart to arrive, so I can fine tune in the unit with my scope, But I was surprised with the lack of response for the issues.

Here's original thread.

  • Like 1

Share this post


Link to post
Share on other sites

Well both KylJoy and myself did respond in that thread, and I stated it was likely an IC that was the issue. But honestly, I've not had to do much repairs to my Veccy so I wasn't sure which IC to blame. Then your last post with the scrambled picture is something that I kinda get with my other Vectrex but the integrator caps did NOT resolve it and so I've never found an answer to that issue. Luckily I have another Vectrex and it so far works just fine.

Share this post


Link to post
Share on other sites

Yeah, I'm not complaining about the support offered, but the hint of "I would guess an IC somewhere in the Veccy is responsible" isn't exactly a troubleshooting guide.

 

I was wondering if anyone had done a list/fix for issues. I've been spoiled working on commodore computers with great lists like the following.

 

http://personalpages.tds.net/~rcarlsen/cbm/c64/c64-ic.txt

 

And it would help the next person to come along. I actually don't own a vectrex, I'm repairing one for an old friend.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...