Jump to content
Thomas Jentzsch

Stella sound issues and fix

Recommended Posts

Since yesterday I suddenly have a very weird issue where all versions of Stella (except 6.0) are becoming mostly completely silent. E.g. in E.T you cannot hear the title music, but some cracking sound when the ship is landing.


After some research, it turns out that there seems to be a Stella incompatibility with SDL2 2.0.6 and newer on Windows (10). Reverting to SDL2 2.0.5 (or older) fixes the problem. Now we wonder why this issue did not occur earlier to me and why no one else has reported it.


Has anyone ever experienced the same issue?

Share this post

Link to post
Share on other sites

My setup contains SDL2 v2.0.9.0 with Stella 6.0.2 x64 under Windows 10 x64 and no sound issues are experienced. 


I can't recall the last time (if ever) having sound issues with Stella.


Checking the zip archive obtained from the homepage, the same version of SDL2 ( is packaged under the 32-bit and 64-bit folders.






Share this post

Link to post
Share on other sites

Can this maybe has the reason, that someting new was installed on this computer in the meanwhile? Something, which also had installed any kind of new Audio-codecs or something similar to that?


I just ask, because i can remember a very strange bug, some years ago on my older PC (Pentium3, 800MHz, Win98SE). On this PC, i had alot of different emulators for alot of different retro systems installed and everything worked fine for years.


Then, from one day to the other, i had no sound anymore in some emulators (for example in "KEGA FUSION") and i could not explain the problem to myself for some days. But then i had a hunch, cause i installed two new PC games days before. From former times, i still had a screenshot from the order of all the Audio-Codecs on this PC and i had a look at it:





And then i had a look again at these Audio-codes, after the two PC-games was installed days ago and i saw this:




One of these two installed games must have mixed up the whole order of using the Audio-codecs. When you look at the screenshots, now for example "Creative MP3 Codec" is somewhere in the middle, while it was on rank-1 before.


And all these mixing up of those codecs, then must have lead to the soundproblem on my PC and that i strangly had problems for example in "KEGA Fusion" emulator now, especially when running CD-Iso's with it, then i had no sound at all anymore. But at that time in Win98SE it was possible, to change the order of those Audio-codecs by hand and after i had changed it like it was before, everything worked fine again and also in those new installed PC games, the sound worked normally. Maybe it was a similar problem to yours?



But perhaps the problem here in STELLA is something totally different? If it technically can not be, that the STELLA sound can be influenced by any kind of Audio-codec, then okay, i am not a programer, just thought i express my suspicion.   :)


Edited by AW127

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...