Jump to content
GDMike

HRD (Horizon Ramdisk) 2018

Recommended Posts

I do not believe there are any clearer schematics for the Horizons released into the wild. The ones for my 198+ model and the 3000 and 4000 models are pretty much what Bud released to the hands of those who chose to build their own. I built three of them using the included construction guide and they worked (at least the two I got complete,d before I stored everything away 20 years ago. Yep, just looking at them last night as I was going to try to find you something, till I found that Whtech had the same, brought back a lot of memories, good and bad). If the wires are not shown or talked about, maybe it was one of the various hacks for the Horizon, and I know nothing about those. Sorry if I didn't give you anything concrete to work with.

IT does say Horizon and date of 1986 also there is a stamp saying all mods ok '93. the Schematics on WTECH show 3 138s STACKED BUT they are not wired as this one was previously, ALSO when I did wire them as the schematic I could not even see the card and the LED would not light (data). BUT I went back to the original wiring of those 74LS138 stack and I am able to turn the card off \ on with >1000 using explorer. so im baffled, cause I use explorer and look into >4000 or so and all i see are Zeros. I plug in a number and it quickly erases and returns with zeros....somehow the card isn't firing up the ram? BUT im guessing the multiplexer is working??

Edited by GDMike

Share this post


Link to post
Share on other sites

what extension can i use to upload photos? I used bmp I used jpg.. and i get errors..

Edited by GDMike

Share this post


Link to post
Share on other sites

I'm getting, "that extension is not allowed" why me!!!! I really really hate this site...it's getting even with me now!! I just wanna upload a photo, i can't find an upload button, so I pasted it in..and im sure there's another way. U can't login with my PC, so I have to use my phone each time and only thru Facebook, else I get a message saying, Atariage.com is not secure, through Firefox.

Edited by GDMike

Share this post


Link to post
Share on other sites

Sometimes taking an image directly from a camera will do this with a JPG. After processing and sometimes removing the data from the file it can sometimes eliminate this.

 

If you are still having trouble after the above work around, just use the snipping tool in Windows to take a screen shot and upload that image and it it'll eliminate the problem.

 

You can also upload PNG format as well, but they can get rather large.

Share this post


Link to post
Share on other sites

I already convinced myself that and proceeded.. thanks l you for taking the time to explain.. in actually sick rt now, and thus the attitude... lol... sorry bout that...

Share this post


Link to post
Share on other sites

Where is the pic upload icon?

 

Click on "More Reply Options" before you type your message and you will see the option in the lower left hand corner...

post-35324-0-37701600-1540422166_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Haha..of course, way past add Twitter info and font handling. Rt where it shouldn't be.. well thank you so much for that...I've done web design and i haven't seen this kinda form in a long time. But once I find reply, edit, upload..then im ok. Again, thanks so much - I'm just having a rotten day. But I hope to bounce out of it soon. It's hard to describe my ramdisk problem without photos and I've been reluctant, and now sick literally just doesn't help. I'll approach things better next time. Just need to get an idea of what happens next after the card address is active. as in, how and what component is responsible for sending data to ram chip #1 etc..

Share this post


Link to post
Share on other sites

How do you delete a photo I didnt mean to send the 1st...thats a DVD drive with the PLAY function....sorry guys....

post-63012-0-08626100-1540481508_thumb.jpg

post-63012-0-73321800-1540481531_thumb.jpg

post-63012-0-94917700-1540481547_thumb.jpg

Edited by GDMike

Share this post


Link to post
Share on other sites

Being made in 1986, I believe it is a 2000 series. It's definitely not a 3000, 3000B, or 4000 HRD. I am not familiar with the stacking as I have not ever tried that on any of my RDs. Ksarul is probably the one who can shed more light on this, but I would suggest testing all the logic chips or replacing the ones you haven't already, using a device like a Minipro programmer.

It may have had a Rambo mod or something too, that might account for the different wiring,and I don't have any experience there either. If you are using the same construction guide, that would have been distributed with this Ramdisk, I don't see why the wiring would be different, other than routing, unless it was a experimental mod on the card.

The color is different than any of mine(all green) which may mean a slightly different version, though it looks like my two 2000's. Check your transistors too, as well as the tantalum capacitors, as I had one blow up on me as I was testing one of my 2000 boards a couple of weeks ago, hadn't been plugged in for about 20 years.

Share this post


Link to post
Share on other sites

Thanks.. it was sold as a 3000.. it did work but started giving errors, I was working with Gary Opa and getting his thoughts, as I am getting closer to making it work, he was saying something to the point that now we can see the card we now need to determine why the logic isn't turning write on.?? I did find a schematic on Wtech showing 3 ea 138 stacked. But again, it's not entirely the same layout as what I have. I'm now trying to just see or rule out which logic is working and who is not at this point. If I can see the card does this mean that the 2 ea 259s stack ARE working? Or is my problem coming out of those 259s? Or is this past that? Are my 3 stacked 138s all working since I can turn the card on/off? Cause of course it changes my direction. It's hard to put a logic probe in there and prob an unsafe thing, but it may be my next attempt.. IF I Know who to test..

Share this post


Link to post
Share on other sites

That board is an HRD+. Probably the easiest way to be sure is to read the whole serial number under the heat sink fins. I can see part of it next to the mod sticker, but not enough to be absolutely sure. It looks like it is 001753, which would be one of the later runs of that board. Note on HRD Boards: ALL 2000, 3000, and 4000 series board serial numbers start with those numbers and climb from there (2000, 2001, 2002, etc.). Any serial number that is LESS than 2000 is an HRD or an HRD+. Most start with at least one "0" that can be ignored when determining the serial number (this goes for all series), and there will never be more than four significant digits agter the zeroes (very early boards may only have between one and three significant digits here, as Horizon started counting with very low numbers. I have seen at least one board with a two-digit serial number.

  • Like 1

Share this post


Link to post
Share on other sites

OK, then it is definitely an HRD+ (also sometimes called an HRD 1000). It is not a 2000, 3000, or 4000 series board, so stay away from the schematics for those.

  • Like 1

Share this post


Link to post
Share on other sites

Now we have a starting point..I'll also forward to Gary Opa. If anyone has schematics for an HRD+, please let me know. Wow, thanks so much for your chiming in on This. Does anyone make blank boards?? It sounds like a better path...

  • Like 1

Share this post


Link to post
Share on other sites

I have a similar or identical HRD, and *somewhere* have the assembly instructions. A friend picked it up for me in 1987 (I think) at Dallas, TX at a TI Fair. I built it and it probably has the same number of 62256 chips (16 on mine for sure, that's what I see in the pictures)

Share this post


Link to post
Share on other sites

I should probably point out that there's an error or two in that schematic in/around the wired-OR diodes, and the document doesn't include page three of the important anti-data-corruption errata which I have lying around here somewhere.

 

Edit: found it, attached.

Horizon Change Notice.pdf

Edited by wileyc

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...