Jump to content
Flojomojo

Atari Flashback 9 FIRMWARE for adding games to SD card

Recommended Posts

 

 

 

...

 

Ok...Bill just explained to me how.  With a Y usb cable and some PC command lines.  Not easy but doable.  Thanks Bill!

 

If FB X was a running a higher version of Stella it would change everything for me but outside someone really working on that the FB9 suffices for now.

 

 

 

Sent from my Pixel XL using Tapatalk

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Went to update my firmware (noting else) and it bricked my console.  I cannot get it to interface with my TV.  It gives me a "no signal" message on my screen.  Used the links from the thread.  Not sure what to do now.  Any help would be appreciated.

  • Sad 1

Share this post


Link to post
Share on other sites
9 minutes ago, Britt Adams said:

Went to update my firmware (noting else) and it bricked my console.  I cannot get it to interface with my TV.  It gives me a "no signal" message on my screen.  Used the links from the thread.  Not sure what to do now.  Any help would be appreciated.

While I'm sure others here can help, make sure to send an email to support@atgames.net as well.

Share this post


Link to post
Share on other sites
17 minutes ago, Bill Loguidice said:

While I'm sure others here can help, make sure to send an email to support@atgames.net as well.

I did.  Just thought I would try here as well. 

Share this post


Link to post
Share on other sites

For what it's worth, nothing has happened to corrupt the file in the first post. I just successfully upgraded a regular Flashback 9 moments ago.

  • Like 2

Share this post


Link to post
Share on other sites

I installed the cfw, then updated to the latest ofw, my machine plays the music and sounds in the UI just fine, but theres no sound whatsoever in game. SD roms or stock roms, no games play with sound. Anyone got any idea whats going on?

Share this post


Link to post
Share on other sites

Hi,

 

I´m a new user and I just download the games update to an SD card, but system does not let me to used SD Card option, it is there but it is not available to use.

Can you help me?

Thanks

Share this post


Link to post
Share on other sites

I have tried updating my FB9 Gold... I even went out of my way to get an 8 GB card, and format it with the SD Association formatting tool - then followed update instructions.  My problem is that the console never gives me the option to update - it just boots as normal.  I'm not sure that the console is even seeing/reading the SD card.  Any thoughts?

Share this post


Link to post
Share on other sites
On 10/19/2019 at 8:37 AM, Bill Loguidice said:

Yeah, that's why I said HDMI and not composite. The FB 2 (not made by AtGames) is a composite system and completely different from any other Flashback in terms of internal hardware.

 

On 10/17/2019 at 4:51 PM, awace said:

When I say repair I went to AXEMAN and found some old coleco brand paddles witch were for old pong games w no button so I bought five or so then I took the pot apart removing the metal bottom case w wire snippets no soldering needed but don’t bend the wipers wrong or it’s TOAST but if you can wipe the circle off the replace bent wiper to connect better then put case back w out breaking the tabs off! Then the 1 Meg ohm pot is gitter free windex works good for wipe ing the carbon off the pot and the wiper from grease witch I stole from the coleco paddles and made the Atari paddle almost jitter free . On Atari 800 basic you print:”paddle(0)” I forgot basic lol anyway the cleaned and regressed paddle are better than factory new. Enjoy 1972 for fbII it’s the paddle code

PS. I ereased all my Sd card Atari Games. Ill Just use the built In ones.

Share this post


Link to post
Share on other sites
16 hours ago, ContrastBand said:

Will this overwrite what the Flashback 9 comes with originally or will it load the ROMs separately? Thank you for guiding us through this, it is a great resource!

The original ROMs will still be available.

Share this post


Link to post
Share on other sites
On 11/29/2018 at 7:29 PM, atxari said:

 

 

I have a small problem with my SD card that I have not seen mentioned on this thread, maybe someone can help?

 

 

 

I am not at all familar with SD cards but the Game file saved on the card has all the titles alphabetically. I formatted my 16gb Sandic Ultra with SDcardformatter5 for mac.

 

the magic word here is Mac. i have the same issue. i tried everything from "clean up by" and "arrange by" and no luck. i even tried loading the games one at a time (in alphabetic order) from finder onto the sd card. still nothing. when i plug the card into my iMac, everything shows up in order. but when i plug it back into the fb9 they are in random order. my solution was to go through all the games and write down what page the games i'm most interested. it's a pain but at least i don't have to look at 100 pages each time i want to play an sd card game

Share this post


Link to post
Share on other sites

I'm having problem with the firmware. I actually got from a friend an SD card for the Flashback 9 that worked for him, but when I load up and hold the joystick left...nothing happens. It just stays on the ATGames screen. I put the card in with contacts up, I hear the SD card lock in when I insert it, but I can't get it to do anything. Any thoughts? It's an Atari Flashback 9, HDMI. Thanks in advance.

Share this post


Link to post
Share on other sites
On 2/12/2020 at 8:31 PM, wishlish said:

I'm having problem with the firmware. I actually got from a friend an SD card for the Flashback 9 that worked for him, but when I load up and hold the joystick left...nothing happens. It just stays on the ATGames screen. I put the card in with contacts up, I hear the SD card lock in when I insert it, but I can't get it to do anything. Any thoughts? It's an Atari Flashback 9, HDMI. Thanks in advance.

power on first. wait until prompted before pushing left on joystick.

Share this post


Link to post
Share on other sites
On 2/15/2020 at 11:35 AM, frosted froggie said:

power on first. wait until prompted before pushing left on joystick.

When I power on, I see the AtGames logo, hear a brief high chip sound, then get the normal main menu.

 

Is it possible my unit's SD card drive isn't working properly?

Share this post


Link to post
Share on other sites
On 12/4/2019 at 10:02 AM, CocoOlaechea said:

Hi,

 

I´m a new user and I just download the games update to an SD card, but system does not let me to used SD Card option, it is there but it is not available to use.

Can you help me?

Thanks

atari_update.img is just the firmware to activate the sd card option. you still need to download game roms. the following youtube should help.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 2/16/2020 at 6:56 PM, wishlish said:

 

Is it possible my unit's SD card drive isn't working properly?

possible, but not likely. try loading the update on page 1 of this post onto a fresh card formatted to FAT32. make sure it's capacity is LESS THAN 16gb. if that doesn't work, then i'd suspect the machine itself is malfunctioning. good luck.

Share this post


Link to post
Share on other sites

if the official update file isn't renamed to "atari_update.img" the system won't see it, or prompt for joystick left, when you turn the console on. If it IS named properly, and it doesn't prompt for joystick left, I would guess either broken/incompatible SD Card or broken SD Card reader/console.

Not sure how you can brick these from firmware/custom firmware, as the system will always recognize properly named updates and you can flash it back. That's the beauty of these atgames systems. I'm not super knowledgeable, but I'm pretty sure there is a partition that doesn't get flashed over, ever. And that is where the program is at that looks for properly named updates when the console gets powered on. so if you "brick" it, you just re-flash an update to fix it.

The sound issue (games not playing with sound) is a known hardware issue. I've experienced it seldom. Launching a game and exiting back to main menu brings the sound back for me. I have heard others will unplug the HDMI and plug it back in while system is powered on and that fixes it, but i've never tried that myself.

I can tell you I have flashed dozens of systems multiple times, all the official and custom firmware works. I have "bricked" a system once. (powering on would load the atgames logo and make the chirp on the legends flashback 2018, but never go to the built in games list.) But I just re-flashed it and everything was fine. I can also tell you that the custom firmware to add games and artwork to the main UI is what you need to be using. You can flash the Atari FB9 Gold over the standard unit and make it a gold.

 

 https://atariage.com/forums/topic/296676-flashback-9-gold-cfw-to-load-roms-and-boxart-from-sd/#comments

Edited by Draxxon
  • Like 1

Share this post


Link to post
Share on other sites

Hi @all,

I am an absolute newbie and have one question:

Is it possible to add games on SD - card with the FB9 - boom! (with HDMI output) ?
I will buy it in the next few days and don't wanne do a mistake ... ☺️

Thank you very much !!!
912795926_AtariFlashback9BoommHDMIOutput.thumb.jpg.4adc6a020cb2b5e25c6f4a4488d5fcaf.jpg

Share this post


Link to post
Share on other sites

Make shure not to have the difficulty switches on or you cant get to sd card and have to power on again 

Edited by awace

Share this post


Link to post
Share on other sites
12 hours ago, awace said:

Make shure not to have the difficulty switches on or you cant get to sd card and have to power on again 

you may have a separate issue. i play the most on sd card games, not built in roms. i have never experienced the problem you are having. depending on the game, i use the difficulty on for some and off for others. for me, it makes no difference which position they are set to upon startup. the sd card is always accessible.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...