Jump to content
JDog514

Ultimate PC Interface and JZintv using LTO software

Recommended Posts

Hello,

 

I have the emulator set up through the LTO software and it works. Also, I have the Ultimate PC interface. I never upgraded the firmware on my device, however, I have two flashback controllers connected to the interface using the Flashback to INTY 2 adapter cables. However, JZINTV does not recognize the controllers. On the interface the left switch is up and the right switch is down. I have 2 hackfiles to try from the intellivision.us website, however, none of them work with my current configuration. It worked before using INTY 2 controllers. Any help would be greatly appreciated. Thank you very much. I appreciate it.

 

Jeffrey

Share this post


Link to post
Share on other sites

If the disc and side buttons don't work then no jzintv hackfile will help. Does it still work with Intellivision II controllers? If you bought it in the last couple years it should support flashback controllers without adapters.

 

Use this website to test your controllers

http://html5gamepad.com

Share this post


Link to post
Share on other sites

Just tried using Intellivision 2 Controllers with no luck. The controllers do not function on the website either. I tried to change the USB port with no luck as well as trying the interface in the UP UP position (supposdely Autosense.) Any ideas would be greatly appreciated. Thank you very much.

Share this post


Link to post
Share on other sites

Could you show a screen shot of the settings for jzIntv that you're using in the LTO Flash! UI Software? IIRC the hackfile type settings are on the 'Input' page.

 

I wonder if it's this issue (Mac-specific) you've run into? In which case, I may need to be sending you an updated build...

 

EDIT:​ You can probably work around the issue if you customize the command line (in the 'Advanced' settings, IIRC) and pass the argument directly instead of using the 'Input' page.

Share this post


Link to post
Share on other sites

I am running Windows 10. It's not letting me copy my screenshot into the thread.

 

I have the hackfile listed and the joystick boxes are blank.

Edited by JDog514

Share this post


Link to post
Share on other sites

I am running Windows 10. It's not letting me copy my screenshot into the thread.

 

 

Guess you need to save as a file (I use mspaint.exe), then upload as a file.

 

I'll see if I can give it a whirl tonight. I've been using Ultimate Flashback or console primarily for the past few years.

  • Like 1

Share this post


Link to post
Share on other sites

OK, I just tried things out and don't have any problems. Here are my notes:

 

  • I tested two different Ultimate Flashback adapters - one with the "old" firmware, one with the "new"
  • Both are configured for standard controllers via switches
  • For the "old" one, I used "hackfile12.cfg" and for the new one, I used "hackfile.cfg"

For reference, here are pictures.

 

OLD - uses hackfile12.cfg

\/\/\/\/

post-35516-0-36544400-1541033089_thumb.jpg

/\/\/\/\

 

 

NEW - uses hackfile.cfg

\/\/\/\/

post-35516-0-41144200-1541033277_thumb.jpg

/\/\/\/\

 

Now, I'm not running with the downloaded version of "LUI" - I've got a dev version with who-knows-what changes in it.

 

So, just in case the hackfile bug that was on Mac is also present in Windows, you can work around it. Here's how....

 

You probably have your hackfile configured something like this:

post-35516-0-66591700-1541033934.png

 

Delete that setting. Hop on over to the "advanced" tab and put it there, something like this. Note that you cannot have spaces in your file path!!! I can't recall if quoted paths are supported for kbdhackfile or not, so I suppose you could try it. To err on the side of caution, use a path without spaces.

post-35516-0-94777800-1541034073.png

 

For my tests, I used original Intellivision "inline" controllers, so the DB-9 to Molex style adapter was set up, too. IIRC those are "keyed" so you can't hook them up backwards.

Share this post


Link to post
Share on other sites

I also hooked up Flashback controllers just for giggles to see what would happen. Not much. I didn't use any adpaters, so it must have looked like cats on the keyboard to jzintv.

 

I was running the MTE-201 test ROM's controller tests to see if things worked.

Share this post


Link to post
Share on other sites

I followed your instructions and hooked up my flashback controllers to the device using the adapters. I also put this in the advanced section --kbdhackfile=C:\JZINTV\hackfile12.cfg. Unfortunately, I still have had no luck right now. I will try again later. Do you think that Windows 10 might be to blame? Also, in Device Manager, what does the interface show up as? I'm not sure that it is being recognized. Thank you very much.

Share this post


Link to post
Share on other sites

I ran my test in Windows 10... Not sure how the Ultimate PC interface looks in Device Manager... You may see devices in USB and HID trees, or maybe under game controllers.... They make the little "booop ditty boop" noise when plugged into a USB port. Are you using a hub, or ports on a monitor, or ones directly on the main system case?

 

Which ROM are you running to check controller behavior?

 

Also ... You can run jzintv directly from the command line, too.... If you look in Program Files, you should be able to find where jzintv is and open a command prompt or power shell prompt there. Perhaps there would be some additional information printed to the command window.

 

You can right click on a ROM in the UI and get a preview of the full command line that will be used to start jzintv. That will help. You can copy that and paste it into a post too.

Share this post


Link to post
Share on other sites

It has to work as a system game controller before it will work in jzintv. If this computer doesn't recognise it, test it on another.

Share this post


Link to post
Share on other sites

If it works on another computer but not this one, perhaps something has gone wrong in the usb registry. There's a utility called USBDeview that can help with usb device problems.

 

If it works in windows but not jzintv, it could be that that other game controllers plugged in means this one is no longer the first or second joystick to jzintv.

Share this post


Link to post
Share on other sites

So... no reaction at all in the MTE-201? That is odd. If you "button mash" on the keyboard, does anything happen?

 

If we had the complete command line that's being used, we could possibly "debug" a little more -- or at least be able to ask more specific questions and discard some possibilities.

 

Does your "Ultimate" have a 2012 or 2013 sticker on it? To be honest, I'm not sure how to tell if the firmware has been upgraded aside from that -- which is peculiar to when I ordered mine, most likely. :P

Share this post


Link to post
Share on other sites

OK, I unpluged all of my USB devices that I could and changed USB ports for the interface. Sadly, still no luck. I tried it on an old windows 7 laptop and same issue. It doesnt seem to be installing the USB software. If I button mash on the keyboard, yes the rom lights up. By the way, my device has a 2012 date. Thank you for all of the help.

Edited by JDog514

Share this post


Link to post
Share on other sites

Tonight I'll try to figure out the places it shows up in Device Manager and post screen shots. I know when I connected the second newer Win10 "toastered" up an "Installing Ultimate 2" notification. Don't recall seeing one for the first unit, but I may have plugged it in awhile back....

 

Still, if you're not hearing even the little "boop diddly boop" sound when you plug in a USB device, that seems strange.

 

If I button mash on the keyboard, yes the rom lights up.

Good to know... I'm not positive if jzintv monitors keyboard all the time, or only if it reverts to that if it can't find the Ultimate PC interface. That's another thing I will try to look into tonight.

 

At this point, it certainly seems to be an issue more with how the PC may be failing to identify the device, though. :(

Share this post


Link to post
Share on other sites

In regards to trying a new USB cable, I cannot as it is hardwired into the unit. At least on the newer unit based on the picture that was posted you can change the USB cable.

Share this post


Link to post
Share on other sites

I just uninstalled all of the USB devices on the computer and restarted it. This allowed Windows to reinstall all of my devices, which worked for everything except the interface. Guess I might be buying a new one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...