Jump to content
ebiguy

RespeQt 4.3 beta

Recommended Posts

Interesting discussion about the PDB files, thanks. :)

 

Has anyone managed to write a bootable floppy copy of The Goonies? Side B of the Happy Warp Backup disk has a PDB for it (#5, in case anyone wants to try themselves), but it won't successfully write a disk from either of the two ATX versions I have - both fail with a disk error on track 26. Trying a straight, no-PDB copy produces a complete disk but it fails during the boot at the credits screen but before the title screen and music appear.

Share this post


Link to post
Share on other sites

So, I made binaries for Win32 and Mac.

 

attachicon.gifRespeQt_mac.zip

attachicon.gifRespeQt_win32.zip

 

@DrVenkman: I have to get out my RaspberryPi and try to build it. Stay tuned.

 

fail, says I don't have the qt core... all the others revisions I have on my computer work just fine although I am using a win64 computer...

so I renamed the binary to respeqt32.exe and put it in one of my other versions folders and launched it, worked just fine.

Edited by _The Doctor__

Share this post


Link to post
Share on other sites

fail, says I don't have the qt core... all the others revisions I have on my computer work just fine although I am using a win64 computer...

so I renamed the binary to respeqt32.exe and put it in one of my other versions folders and launched it, worked just fine.

Ok. Assuming you are unsing the Windows version, I will try to make a complete package of the binaries.

  • Like 1

Share this post


Link to post
Share on other sites

I have rebuild the binary packages for macOS and Win32 with my latest changes.

Beware that these are only binary packages, you also need the complete package, you find here http://atariage.com/forums/topic/284707-respeqt-42-beta/?p=4150092.

Replace the binary in the complete package with the binaries found in the new ones.

 

If there are problems, please PM me or ebiguy.

 

RespeQt_mac.zip

RespeQt_win32.zip

  • Like 3

Share this post


Link to post
Share on other sites

I have found the bug in the last several versions of RespeQt. It crashes to an Error Report. This prevented me from doing a backup of my BBS until I found out the problem.

 

I un-ARCd (IIRC, or possibly copied) some files to the drive and didn't notice their datestamp was 9 Feb 47. EVERY one of these files crashed RespeQt.

After I did CHTD on the offending files I was able to do a full [Error Free] backup at divisor zero.

 

Error message pic:

post-13040-0-02996900-1552880127_thumb.jpg

 

Edit: Here's a pic of what it choked on:

 

post-13040-0-74936500-1552881499_thumb.jpg

Edited by Kyle22
  • Like 2

Share this post


Link to post
Share on other sites

I'd say that's an issue to be addressed for sure..... the fun part begins....

Yes, it does. :)

Share this post


Link to post
Share on other sites

Yep: dozens of users with files from the late Forties are going to be tripped up with this one. Critical! :)

 

Perhaps RespeQt is attempting to create a file with a date stamp of 1947 or 2047, which I guess will create issues.

  • Confused 1

Share this post


Link to post
Share on other sites

consider a time traveling DeLorean, or time traveling retrogamers... or any number or Real time clock scenarios, plus the fact it happened to people backing up their BBS... yeah it is a big enough problem. The time date of files from within an extracted zip or a real time clock in need of setting or bad batteries of the RTC... I fully expect 8 bit users will still be using their Atari's in 2047!! And of course we may be traveling back to the future at any time...

 

No one likes hitting a brick wall at 87 mph or doing so at 88 mph but not having the wattage to make the jump.... in any event it happened to more than one sysop so I say good detective work KYLE22, glad we could run this one down. Y2047K !! ) probably other years will do this as well.... time to make a directories full of ascending date stamp files to see where it starts going kabloohy! (

Edited by _The Doctor__
  • Like 2

Share this post


Link to post
Share on other sites

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

 

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

 

Be nice to know if anyone else has run into these issues.

Share this post


Link to post
Share on other sites

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

 

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

 

Be nice to know if anyone else has run into these issues.

Is this on a specific platform, or on all?

Share this post


Link to post
Share on other sites

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

 

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

 

Be nice to know if anyone else has run into these issues.

 

Hi, thank you for using and testing and reporting issues on RespeQt.

I found the bug (my fault !).

It is fixed.

But before rebuilding, I am going to look at the issue about last modified date.

  • Like 4

Share this post


Link to post
Share on other sites

I have found the bug in the last several versions of RespeQt. It crashes to an Error Report. This prevented me from doing a backup of my BBS until I found out the problem.

 

I un-ARCd (IIRC, or possibly copied) some files to the drive and didn't notice their datestamp was 9 Feb 47. EVERY one of these files crashed RespeQt.

After I did CHTD on the offending files I was able to do a full [Error Free] backup at divisor zero.

Hi Kyle22,

I am not sure to understand how to reproduce the problem.

I understand that you have a file with date 47 but where is it (what is C: on your screenshot ?). Is it an ATR image in RespeQt or a folder image or a real hardisk plugged in the Atari (SIDE2 + CF card).

You say you make a backup. From which device to which device ? Which SpartaDos command ? (is it SpartaDos - it looks like but not sure)

Could you provide a very detailed explanation of the configuration and the procedure to follow so I can reproduce (what do you configure in respeQt, which commands are run under DOS...) ?

 

Share this post


Link to post
Share on other sites

I doesn't matter what device it copies from, it only matters that it is copied to the PCLx: drive that lives on the windows machine

  • Like 1

Share this post


Link to post
Share on other sites

But before rebuilding, I am going to look at the issue about last modified date.

AFAIK Unix can only address years until 2038.

 

Perhaps it is failing due to the fact that the files are tried to be timestamped with the year 2047.

Share this post


Link to post
Share on other sites

Normally, the tinestamp should wrap around. My guess would be, that a Date object is supposed to be created, but couldnt be. So the program crashes.

Share this post


Link to post
Share on other sites

It is SDX 4.47.

Copying from hard drive partition D3: (C: drive) to RespeQt using PCLINK protocol.

 

Edit: punctuation.

Edited by Kyle22

Share this post


Link to post
Share on other sites

It's not problem on the Atari side.

 

Temporary work around, make an error directory in the RespeqQT folder or the active pclink folder, copy the out of bounds date material with today's date (Atari none the wiser) ... when done copying all files let RespeQT bring up the error directory and ask to rename or re-date the offending files, when doing so RespeQT just uses move the on the files with the corrections...

 

best to do a real fix though.... in 19 short years this shouldn't be another y2k'ish frenzy... after all 1978 to 2001 was 23 years give or take, we have from 2019 to 2038... yeah we don't need this to keep happening every 15 to 20 years that's for sure... :)

  • Like 1

Share this post


Link to post
Share on other sites

Or, for purposes of speed, just re-date them on the fly to today's date. :)

 

Edit: The current date as of time of file transfer. Obviously, not Today's (this day's) date.

 

Edit: Clarity

Edited by Kyle22

Share this post


Link to post
Share on other sites

Or, for purposes of speed, just re-date them on the fly to today's date. :)

 

I pushed the 2 fixes on Git repo:

- avoid the crash and ignore the bad date.

- fix the communication issue with folder image.

 

Could you please test this version and tell me if it is OK.

RespeQt-r4.3-fix.zip

  • Like 1

Share this post


Link to post
Share on other sites

I pushed the 2 fixes on Git repo:

- avoid the crash and ignore the bad date.

- fix the communication issue with folder image.

 

Could you please test this version and tell me if it is OK.

Sure, when I get home. I'm on my phone now.

Share this post


Link to post
Share on other sites

Well, it seems as if SDX 4.47 doesn't allow me to change the year to 47.

 

I'll work on this.

 

Doing another full backup now.

 

Will report.

 

Edit: I'll RTF the SDX M.

 

CHTD will not do this. I must sector-edit or find the original source of he offending files.

 

No prob. I'll get this. Hold on.

 

I'll do this tomorrow. Backup still running nice at divisor zero.

:)

It's getting late. Board will beck up in the morning.

Edited by Kyle22

Share this post


Link to post
Share on other sites

Sorry, brain fart. I guess if I set the date first, then do CHTD, then set it back should do the job.

Share this post


Link to post
Share on other sites

Sorry, I guess I forgot to report that it works perfectly now. Thanks.

The bad dates are on the files contained in an ARC. Un-ARCing them to hard disk is what triggered the bug.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...