Jump to content
atarimac

New Version of Atari800MacX Released

Recommended Posts


Hi All,

I wanted to make sure people saw this, as it was mentioned in the old thread about sound not working.

I know I've been for the most part silent for the past 4+ years. I've had my head down completing my PhD, and then this fall teaching my first semester of classes as a Computer Science professor.

I finally managed to get enough time over the holidays to make the changes to integrate the new version of libSDL 2.0 into Atari800MacX. The 2.0 version makes wholesale changes to many things, including rendering, sound, and keypresses, so it took me about 2 weeks of effort to make the changes. The good news is that moving to 2.0 should enable the emulator to with stand changes to Mac OSX in future versions, assuming that the library authors keep up with them.

I want to thank Paulo (pedgarcia), as he fixed sound independently of me, and has been helping with changes to this new version.


The changes fix the sound and full screen issues, as well as printer emulation which wasn't working anymore either. Be aware though it is still Alpha quality software, as the amount of testing I have done is limited (although I'm sure all of you can help there :) ).


I'm still waiting to hear from Al on the website FTP, but for now, you can grab the new release from Github if you like:




Please use the issue system there on github to enter issues you find. I will update the main web page when I can, but I may move to using github.iio pages as well in the future.


The source has been moved there as well, at least for 4.6 and 5.0. Anyone who would like to get involved in future development, please let us know, or just fork the project.


Thanks,

Mark
  • Like 20

Share this post


Link to post
Share on other sites

I'm still waiting to hear from Al on the website FTP, but for now, you can grab the new release from Github if you like:

 

I've sent you an email with the information you need. Glad to see you're working on Atari800MacX again! :D

 

..Al

  • Like 1

Share this post


Link to post
Share on other sites

Welcome back and congratulations to all of the above - Awesome Mark!

  • Like 3

Share this post


Link to post
Share on other sites

Fantastic that the sound is working again - thanks!

 

Just opened an issue on github regarding controller support, though - can't get it to recognize a PS3 controller that works fine in Stella for Mac OS X.

Share this post


Link to post
Share on other sites

I don't have any machines running anything old enough to do PPC development, if that's what you are asking.

The source is still available, so if someone wanted to do volunteer to do changes they could, but I know from my time limitations, I will not have time to setup any sort of virtualization to support old Xcode development, and I have no test machines for PPC.

Share this post


Link to post
Share on other sites

Hey Wade,

Your welcome.

And the feature request makes great sense, so much so I just checked the source for it in :).

For future reference, you can add feature requests on Github as well, in fact I added one to track this one.

 

Thanks,
Mark

  • Like 2

Share this post


Link to post
Share on other sites

Hi Mr. Fish,

OK, you just want to be able to run on Snow Leopard.

I know I won't have the time to maintain two branches (including maintaining the development environment).

If someone is set up for that and wants to do that, I'd be glad to have them help through github.

 

Mark

  • Like 1

Share this post


Link to post
Share on other sites

I got Snow Leopard running, inside is Xcode 3 I guess. Is that the machine which makes Atari800MacX work with down to 10.3 PPC?

 

I made it to compile the .app in Leopard (PPC) using the latest Xcode there, but that had a size of 18MB (original download was 10.8MB). In Snow Leopard, it compiled to that 10.8MB big .app, while on SL the original download seemed to be displayed as 11MB. Idk what's going on there, but may be in SL they changed the divider from 1024 to 1000 to show the number of mega bytes.

 

All in all, I have 10.3, 10.4, 10.5, 10.6, 10.7 and 10.11 running on several machines. All run Atari800MacX 4.6.0 and all should be able to run a version of Xcode.

 

The downside is, I never really worked on big projects, so I do not know if I will make it to merge newer on older code. And I don't have any Mac running Sierra+ to compare a forked 4.6.x with the official 5.0.x.

Edited by atarixle

Share this post


Link to post
Share on other sites

Maybe no fork is required. C++ is flexible when it comes to compile time swiches / defines. I think Mark simply has not machine to do/try PPC etc.

Share this post


Link to post
Share on other sites

But: 4.6.0 compiles on SL, 5.0.0 does not. My personell guess is this has something to do with SDL2, which is not available on any of my Macs (10.3 - 10.11).

Share this post


Link to post
Share on other sites

OS X 10.6 is still supported in XCode 10.1 as a deployment target.

SDL 2.0 supported 10.5+ but I'm not sure about 2.0.9, theres some mojave specific stuff in there so an earlier version of SDL2 might be required.

Share this post


Link to post
Share on other sites

 

I know I've been for the most part silent for the past 4+ years. I've had my head down completing my PhD, and then this fall teaching my first semester of classes as a Computer Science professor.
I finally managed to get enough time over the holidays to make the changes to integrate the new version of libSDL 2.0 into Atari800MacX. The 2.0 version makes wholesale changes to many things, including rendering, sound, and keypresses, so it took me about 2 weeks of effort to make the changes. The good news is that moving to 2.0 should enable the emulator to with stand changes to Mac OSX in future versions, assuming that the library authors keep up with them.

 

 

Congratulations on your new tenure and thank you very much for updating the Emulator!

Share this post


Link to post
Share on other sites

Well, I got it up and running.

 

Xcode alerts: SDL is supporting 10.6 and higher (so not 10.5). May be this is an issue of version 2.0.9.

 

Anyway, I got the untouched source of Atari800MacX 5.0.0 up and running on El Capitan. 10.6 is the Deployment-Target.

 

I just get no 32 Bit version of that app (it does not run on my 32 Bit SL Mac)

 

But it runs on my 64 Bit MacBook3,1 on OS X Lion.

Edited by atarixle
  • Like 1

Share this post


Link to post
Share on other sites

Check to see if your controller shows up in Preferences-Controllers. I was successful with a Logitech F310 Gamepad (set to D) and a Gravis Gamepad Pro.

 

I didn't have any luck with a Legacy Engineer Atari USB joystick.

Share this post


Link to post
Share on other sites

Have you tried your Retrolink USB adapter in 4.6? I recall that my Retrolink stopped working in SDL 2.x. I bought a 2600daptorII to replace it.

 

4.6 is written using SDL 1.x. 5.0 was rewritten in SDL 2.

 

Bob C

Share this post


Link to post
Share on other sites

Thanks - the first time I tried the Retrolink with Atari800MacX was with this new version. I just ordered a 2600daptorII!

 

I bought the 2600daptorII a couple of years ago when the Atari ST emulator (Hatari) updated their code to SDL 2.x. At that point, the Retrolink stopped working. I'm assuming the Retrolink isn't seen correctly by SDL 2.x. I've had no problems with the 2600daptorII in Atari800MacX. I had it detect the controller and it just started working.

 

Bob C

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...