Jump to content
6BQ5

How to get started with RespeQt?

Recommended Posts

I wanted to download RespeQt so I Google'ed it to find the program's homepage. The first result is Github and i don't see any "install.exe" file.

 

So ... what am I suppose to do with all these files? They look like source code files.

Share this post


Link to post
Share on other sites

So, the Atari Age forum is the official (unofficial?) distribution point for executable binary files?

Share this post


Link to post
Share on other sites

So, the Atari Age forum is the official (unofficial?) distribution point for executable binary files?

Here’s the deal. RespeQt was forked from the earlier AspeQt by user JoeyZ. He made a bunch of improvements and released versions r1 through r4. Then life happened, JoeyZ got sidetracked and the project stalled.

 

Others forked the github repository and made their own changed and improvements. JoSch added better printer emulation and ebiguy added Happy and Archiver support plus ATX file support.

 

The current “unofficial” r4.3 builds combine both of those sets of additional code. Binaries are in this forum.

  • Like 1

Share this post


Link to post
Share on other sites

Wow, that’s a story fit for a TV drama series. :)

 

Thanks for the historical insight. I’ll give it a whirl later tonight after work. Then I still have to order some hardware to build a cable.

Share this post


Link to post
Share on other sites

Wow, that’s a story fit for a TV drama series. :)

 

Thanks for the historical insight. I’ll give it a whirl later tonight after work. Then I still have to order some hardware to build a cable.

 

I just noticed the forum post I linked to RespeQt 4.3 is just the executable binary. The complete set of windows files (docs, dll, etc) necessary to run can be downloaded with the previous release 4.2.1, courtesy of ebiguy, here: http://atariage.com/forums/topic/284707-respeqt-42-beta/?p=4150092

 

RespeQt.exe 4.3 binary can be copied over previous version. RespeQT is click and run under Windows with no package installer required.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Hello, i downloaded version 1,2,3 and 4 òf RespeQT and want to use them on my Panasonic Toughbook CF-M34 (with touchscreen).

 

My CF-M34 had Windows XP pro with sp1 installed. 192MB ram memory, Pentium III 400Mhz and has a RS232 port. I want to use the old Sio2PC serial kabel connection.

 

Anyhow, RespeQT doesnt start at all. It gaves an error beforre starting.

 

Trying to solve the problem, i upgraded my Win XP install from SP1 to SP2. tried RESpeQT again. still doesnt work

 

Then upgrade from SP2 to SP3. Same thing. RespeQT refuses to start at all.

 

I then tried all 4 versions of RespeQT on the CF-M34 and then at another Panasonic Toughbook model. the CF-28 (1Ghz Pentium III and 512MB memory)

still no go.

 

Am I doing something wrong ?

 

Update: I tried R4 on my old Compaq D230 Desktop with serial port and it works ! Strangly, the Toughbooks run the same Windows XP version as my Compaq desktop.

Edited by Stormtrooper of Death

Share this post


Link to post
Share on other sites

Have you tried installing more memory?

Share this post


Link to post
Share on other sites

The max memory of the CF-M34 is 192 MB and the max of the CF-28 is 512MB. So, more memory is not an option. Min specs for using RespeQT is a Pentium 233Mhz MMX, so my CF-M34 and CF-28 are faster.

Share this post


Link to post
Share on other sites

The max memory of the CF-M34 is 192 MB and the max of the CF-28 is 512MB. So, more memory is not an option. Min specs for using RespeQT is a Pentium 233Mhz MMX, so my CF-M34 and CF-28 are faster.

Don’t read too much into “minimum specs” for an open source project which itself was forked from an earlier open source project. Those specs are estimated at best.

 

As for specs, RespeQt r4 will run okay on a Raspberry Pi ZeroW, though the GUI is slow. An RPi2 or better is a much improved experience. The current forks implementing Happy and Archiver features are not reliable on the Pi Zero.

Share this post


Link to post
Share on other sites
Posted (edited)

I tried the old AspeQT 1.0.0.0 preview 7 and it worked good. 38400 High Speed mode works 20% of the time. 19200 works most of the time. 57600 doesnt work good. (i guess I have to fix my 130XE sioport to higherspeed)

Settings are now in AspeqT

COM1

Handshake method : RI (non also works)

 

Writing to a blank ATR spartados floppy of 720K and 360K also worked good.

 

Boot Atari executable (XEX) file also works good.

 

So, for now, i will work with the old AspeQT.

Edited by Stormtrooper of Death

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...