Jump to content
lamasutra

Atari Flashback 9 AR3050 Bricked, Help, Please

Recommended Posts

Hi,
I have somehow managed to brick this.
I have prepared SD card for update. Downloaded official firmware by registering serial number. I have prepared 4GB FAT32 partision on 32GB microsd with gparted on my ubuntu platform.
I have inserted flash card, booted, selected update by left triggering an option. Suddenly screen went off, restarted and system never came back. Maybe I was too eager to wait or something went off.

I have opened the box scrapping the warranty, but all I found is just flashback gold (ar3560) pcb without bluetooth circuit. The microusb has stripped data links, so no connections to SoC by USB. I have not found any uart RX/TX traces for debugging purpouses.
I'm curious, how are these bare pcbs are flashed or checked by manufacturer.
I don't want to trash that pcb. There must be a way how to make some checks and restore it using update image.

Maybe connecting those usb data traces will connect it to my pc and the "reset" button will prepare it for rkflashtool, but it's maybe. So far I'm playing myself "you are such an idiot"
Any advises ?

Share this post


Link to post
Share on other sites

I don't have any Atari Flashback, but I assume the board is similar to the Genesis Flashback HD 2018, so you can take a look at the screenshot in this thread from another forum.

 

If anyone has a backup from this device it would be easy to reflash/recover with Android Tool.

Share this post


Link to post
Share on other sites

Hi, I have managed to connect usb traces and now I'm able to flash, but lack working dumps.
Weird thing is, I don't need to press recovery button to be able to flash. Is it stuck in some mode (idVendor=2207, idProduct=301a)?
Can someone make full dump with rkflashtool ?
Thank you for help.

Share this post


Link to post
Share on other sites

I have made some progress.
I have found, that my rootfs and kernel partitions were corrupted. I tried some backup from sega system, which used same rk3036 cpu. It booted up to the menu, but only fire button on joystick is working.
Maybe kernel has special driver for atari joysticks. Can someone confirm that ?

Share this post


Link to post
Share on other sites
5 minutes ago, lamasutra said:

I have made some progress.
I have found, that my rootfs and kernel partitions were corrupted. I tried some backup from sega system, which used same rk3036 cpu. It booted up to the menu, but only fire button on joystick is working.
Maybe kernel has special driver for atari joysticks. Can someone confirm that ?

Well now that you did this can you flash the firmware for the atari fb 9 from sd card slot? The reason the fire button and joystick work is because they are the same pinout on a sega genesis. The other buttons on the atari fb p1 joystick are not common to anything else. 

Share this post


Link to post
Share on other sites

No, joysticks are not responding in upgrade menu too. Only firebutton is working in game menu. I have successfully launched first game.
It's obvious I need proper kernel.img and rootfs.img. It looks like there are some differences between sega and atari.

At least I know, that unit is not lost at all.
Please, can someone dump kernel and rootfs from Atari Flashback 9 HD ?

Share this post


Link to post
Share on other sites

I have repaired atari squashfs rootfs. Unsquashed it, copied missing files using mounted sega rootfs and resquashed. There was libMali.so, two oder libs and some .h files unreadable.
Now it boots with atari rootfs, but joysticks are still not functional. Kernel must have a special driver for atari ports builtin.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...