Jump to content
Sign in to follow this  
gainground

Vic-20 runs too fast?

Recommended Posts

Hi all

 

I'm new to AA and have a question for those more experienced in Commodore than myself. Just bought a Vic-20 and it seems to work fine, but when playing the game Avenger (aka Space Invaders) it consistently runs about 10x normal speed. The ram is factory standard (5k) so I doubt it has been upgraded. Any ideas how to solve this problem?

Share this post


Link to post
Share on other sites

Ten times as fast? Hm, perhaps a damaged 6522 VIA chip could cause this, in case the game utilizes the timers in the chip instead of waiting for the raster beam. How about the BASIC cursor, does it also blink very fast? I'm sure the functionality of the VIA chips could be tested.

 

If your chips are in sockets, you could carefully lift them with a dedicated chip lifter or gently prying with a screwdriver, then swap them around and test. There are two 6522 chips inside, same type of chip but depending on location they serve different purposes. Make sure you don't bend or break any legs on the chips.

Share this post


Link to post
Share on other sites

The cursor blinks about twice a second, which I assume is about normal. That would confirm your hypothesis about it being a chip timing issue. I'll look into swapping the chips to test when I get a chance.

 

Thanks Anders.

Share this post


Link to post
Share on other sites

PAL/NTSC might differ a few percent but not 10 times. If the game relies on raster line count (which I'm fairly certain that Avenger doesn't), it would blink and roll, not just run faster. I tried to look up some example on how to use the timers for testing but haven't come up with something good yet. However it strikes me that the tape recorder uses one of the timers, the floppy drive and other items use other timers. If that really turns out to be the issue, more faults would show up.

Share this post


Link to post
Share on other sites

Wow ... and all these decades we all have been upgrading our computers for faster speeds.

 

Could you post a video of Avengers at 10X. I've had that game for my VIC-20 since early 80's.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...