Jump to content
DirtyHairy

Stella 6 on the R77: the eagle is landing

Recommended Posts

If you set the cart type to "4k" in the PC version of Stella, the behaviour matches what @Charlie_ is describing: only the upper part of the screen is rendered, and the the music play faster (frame rate is over 70fps).
So maybe the r77 dumper is failing to detect the cart type correctly and provides a bad rom to Stella.

 

Is it possible to enable the "console info overlay" in the r77 port of Stella, to check what size is the rom from the dumper?

 

Edited by alex_79
  • Like 2

Share this post


Link to post
Share on other sites
7 hours ago, Thomas Jentzsch said:

Theoretically it should work. I suppose it is a physical problem. Try cleaning the connectors. 

Cleaned the cart really well.. Unfortunately it does not work in the R77

Share this post


Link to post
Share on other sites
On 5/20/2020 at 12:11 AM, Thomas Jentzsch said:
On 5/19/2020 at 10:50 PM, KevinMos3 said:

Some buttons aren't working for me in 6.1.2.  I can't exit a game and I can't access the settings.  Went back to 6.1.1 for now.  Anyone else have this issue?

In such cases, try to delete the sqlite files.

Thanks, but that still didn't work.  I still wasn't able to exit a game or access the menu from within a game.  However, I was able to access the options from the main interface.  I had to re-map the menu buttons.  Maybe these don't get default mapped properly in 6.1.2 on the R77?

 

Edited by KevinMos3

Share this post


Link to post
Share on other sites
1 hour ago, Thomas Jentzsch said:

Hm... Can anyone reproduce the problem? I can't.

I was shocked to find out, going through the hundreds of carts I have, I don't have another Smurf Rescue cart. I ordered a spare on ebay. 

 

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, Charlie_ said:

Is there a way to get the Coleco Smurf Rescue cart to work with this system? It only displays half a screen and the music is very fast.

I have two copies of Smurf: RIGC. They both exhibit the same problems described by Charlie. I noticed that the R77/Stella is auto detecting the cartridge as "F4 (4K) Atari". However, the ROM dump (which works perfectly) is auto detecting as "F8 (8K) Atari). The bank switching document by Kevin Horton also lists the game as being 8K (Smurf: RIGC 2465 U 8 F8 X SMURFRES). I tried manually switching the settings to match the ROM version (several times) and it does not seem to work. I randomly tried a few other related bank switching modes, but alas, they too do not work either. One thing I discovered while experimenting is that if you change the TV FORMAT setting from auto detect, and force NTSC mode, the game does not load at all. I also tried changing the START BANK setting with no luck. Not sure if the bank switch mapper is correct for this cartridge, or perhaps it need a specific starting address index to load correctly. Stella seems to only allow the user to select bank 0 or 1 and not an arbitrary address. 

20200522_070831.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

I guess until someone helps with a solution, just enjoy the ROM via SD card. Your cart seems to be working as both of mine behave the same way, and do work just fine in my original 4 switcher 2600. I'll try to investigate as much as I can, but I'm kinda at a loss at this point. Maybe try every possible combination of bank switching options and maybe/until one will work?

  • Thanks 1

Share this post


Link to post
Share on other sites
23 hours ago, KevinMos3 said:

Thanks, but that still didn't work.  I still wasn't able to exit a game or access the menu from within a game.  However, I was able to access the options from the main interface.  I had to re-map the menu buttons.  Maybe these don't get default mapped properly in 6.1.2 on the R77?

 

 

17 hours ago, Thomas Jentzsch said:

Hm... Can anyone reproduce the problem? I can't.

 

I was able to reproduce this by renaming my stella directory.  Stella created a new one, but the only back panel button that functioned in game was color/bw.  After a reboot, nothing had changed in this regard.

Share this post


Link to post
Share on other sites

Is there a difference between 6.1-beta 2 and v6.1.2? Is it the same thing or are they different?

 

 

Edited by fiudr

Share this post


Link to post
Share on other sites

6.1-beta2 is the second beta of the 6.1 release, 6.1.2 is the second fix of the 6.1 release.

Share this post


Link to post
Share on other sites
3 minutes ago, Thomas Jentzsch said:

6.1-beta2 is the second beta of the 6.1 release, 6.1.2 is the second fix of the 6.1 release.

So, 6.1.2 is the most recent then?

 

Share this post


Link to post
Share on other sites

Hi all, great work on bringing an updated Stella to the R77!

 

Can I ask: are there specific "versions" of the R77 that need to be used for this? I wouldn't want to order one and find I'd got a model that for some reason, can't be updated!

 

cheers

Share this post


Link to post
Share on other sites

@DirtyHairy do you have a timeline, when you do an upload of version 6.2?

 

I‘ve got the same problem as described several times with version 6.1.2, that the button layout is totally gone.

I went back to v 6.1.1 and all seems to be good again. The problem with the wrong detected cartridge size while plugin Smurf seems to be in both versions the same. When I tune this manually, the cartridge works.

 

...so please have a look at the button layout, before compiling v 6.2...
(I‘m sorry, but I don‘t be able to do this by my own...think my brain is not big enough...shame on me ;-)  )

...and thumbs up to everybody who is involved in this very good firmware...this one brings really the fun to the Retron 77. Without your work, it would be only another nice looking toy in the corner of my room.

 

Best regards from Germany

 

ForD68

  • Like 2

Share this post


Link to post
Share on other sites

So should I hold off on installing 6.1.2 and wait for 6.2 then? I don't want to install an update if some of the buttons will no longer function.

 

Edited by fiudr

Share this post


Link to post
Share on other sites
On 6/14/2020 at 5:20 PM, ForD68 said:

@DirtyHairy do you have a timeline, when you do an upload of version 6.2?

 

I‘ve got the same problem as described several times with version 6.1.2, that the button layout is totally gone.

I went back to v 6.1.1 and all seems to be good again. The problem with the wrong detected cartridge size while plugin Smurf seems to be in both versions the same. When I tune this manually, the cartridge works.

 

...so please have a look at the button layout, before compiling v 6.2...
(I‘m sorry, but I don‘t be able to do this by my own...think my brain is not big enough...shame on me ;-)  )

...and thumbs up to everybody who is involved in this very good firmware...this one brings really the fun to the Retron 77. Without your work, it would be only another nice looking toy in the corner of my room.

 

Best regards from Germany

 

ForD68

Sorry, missed your post. As @alex_79 says: 6.2.1 is out and fixes the mapping issue.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry if this was asked, but do regular atari paddles now work on the Retron 77 with the latest Stella upgrade?

Share this post


Link to post
Share on other sites

I'm currently looking at buying a Retron 77 and was wondering if I should bother using my atari cartridges or should I just play everything off the card slot? Also, does the firmware update put Stella on the SD card and run it from there? If so, what size card do you recommend assuming I will he putting ROMs on there as well?

Edited by atarifan88

Share this post


Link to post
Share on other sites
15 hours ago, atarifan88 said:

Sorry if this was asked, but do regular atari paddles now work on the Retron 77 with the latest Stella upgrade?

Yes.

  • Thanks 1

Share this post


Link to post
Share on other sites
14 hours ago, atarifan88 said:

I'm currently looking at buying a Retron 77 and was wondering if I should bother using my atari cartridges or should I just play everything off the card slot? Also, does the firmware update put Stella on the SD card and run it from there? If so, what size card do you recommend assuming I will he putting ROMs on there as well?

It comes with an SD cart, which has plenty of space for all the games you want to add. And of course the latest Stella.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks Thomas! I got my Retron 77, upgraded it to the latest Stella (6.1.2 I think) and all went well. I tried it out and the joysticks work, but not the paddles. Even when I go to the settings menu, it auto detects the correct controller. When I start a paddle game like circus atari, the player doesnt move. Any ideas how to troubleshoot this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...