Jump to content
DirtyHairy

Stella 6 on the R77: the eagle is landing

Recommended Posts

 

 

Did this work on beta 1? If I remember the code correctly, saving per-game preferences currently suffers from the same problem as savekey data: it only happens at certain points (maybe even only on shutdown), and chances are that you switch off the device before the data is saved (if it happens on shutdown, you'll never execute this code path unless you kill Stella via SSH). This will change in the next beta when we move per-game preferences to SQLite, too.

 

I don't know. I tried to check it for you, but I can't access the 'Controller Options' tab in beta 1. Shift-arrow keys no longer works in beta 1 so long as I can tell, and Thomas' controller mappings weren't available yet. It doesn't seem to be a keyboard issue as shift-tab still works to cycle backwards between options or buttons. I never came across this issue during testing, as I was just using the 'Input' section to temporarily change bindings.

 

How do you access another dialog tab in beta 1?

Share this post


Link to post
Share on other sites

How do you access another dialog tab in beta 1?

 

 

I have to admit that I don't know either ;) Never mind, it will definitely be fixed when more storage is moved to SQLite in the next beta.

Share this post


Link to post
Share on other sites

How do you access another dialog tab in beta 1?

Only via keyboard. The joystick support only came with beta 2.

Share this post


Link to post
Share on other sites

Are there perhaps different versions of the R77? I am trying to run this firmware on my recently purchased R77, and it doesn't work. By "it doesn't work," I mean that I get nothing on the display -- my TV doesn't see any HDMI output from the R77 when I'm running the community build firmware.

 

I'm not an idiot, but I'm very new to the R77 and this community build. I have used Etcher 3 times -- twice on my Mac (with a build dated 11/2018, and with the build at the top of this thread) and once on a Windows 10 system -- and in all cases it does the same thing: my TV sees no HDMI signal.

 

I did not overwrite my original R77 chip, I used a new 1GB chip. The original R77 chip boots right up, but the one I'm using for the community build does not.

 

I'm sure I'm doing something wrong here, but burning an image to an SD card really is not that difficult. Any ideas what I should look at?

Share this post


Link to post
Share on other sites

I am not aware of any varying revisions of the R77. Maybe try another SD card.

 

Thanks, yeah, I'll go buy another one tonight. I downloaded the R77 image directly from Hyperkin and flashed it to the 1GB chip I was using, and it didn't work either. I know the chip is good (I've used it for other things) but for some reason it doesn't work here.

Share this post


Link to post
Share on other sites

 

Per Dirty Harry's Wiki for the R77 firmware updates, this should work, assuming the listing is accurate.

 

 

 

The reviews seem to indicate that the above linked NIC is probably not actually RTL8152 based. There are many listings on ebay for rtl8152 chipset usb NICs though. It shouldn't be hard to find one that works.

 

 

I was curious, and wasn't adverse to having an extra USB NIC around, so I tried the above linked lan adapter.

 

The one that I received _does_ actually** have an RTL8152 chip, and it works with the R77. However, it didn't work for me when plugged directly into the OTG cable, only when plugged into an(unpowered, for what it's worth) hub. I've noticed this with a few devices, that the R77's USB doesn't seem to like to negotiate directly with some USB devices if they have been powered up before the R77, as they are when plugged directly into the OTG.

 

So, in other words- if you have a USB device that 'should' be working with the R77 but isn't, try plugging it in directly(if through a hub,) or through a hub if direct before giving up.

 

 

** note that I'm not guaranteeing that purchasing the linked adapter will get you one that is compatible with the R77, just that it worked for me.

Edited by fluxit
  • Like 1

Share this post


Link to post
Share on other sites

I am not aware of any varying revisions of the R77. Maybe try another SD card.

 

i bought a new micro SD tonight, and it works fine. Unfortunately my TV (a Sony Bravia LCD from ~2010) seems to be stuck in overscan mode with the R77, and I have yet to find a way out of it. Interestingly, my raspberry pi displays perfectly (no overscan) on the same HDMI input.

 

I thought I had previously found a way to disable overscan, but I couldn't find it tonight. Maybe it is settable on non-HDMI inputs only.

  • Like 1

Share this post


Link to post
Share on other sites

 

i bought a new micro SD tonight, and it works fine. Unfortunately my TV (a Sony Bravia LCD from ~2010) seems to be stuck in overscan mode with the R77, and I have yet to find a way out of it. Interestingly, my raspberry pi displays perfectly (no overscan) on the same HDMI input.

 

I thought I had previously found a way to disable overscan, but I couldn't find it tonight. Maybe it is settable on non-HDMI inputs only.

 

 

My Sony does the same thing - it's because the RetroN 77 is outputting 720p.

 

But the Stella team has an overscan option coming in the next update which will fix the issue.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you to everyone involved in making Stella a reality on the Retron 77!

I've been playing around with it and this is what it should have been out of the box!

 

Quick question:  Is it my TV or is there a little lag on games?  Not complaining... just asking :)

 

Again, AMAZING JOB YOU GUYS!!!

Share this post


Link to post
Share on other sites

I second the thanks to everyone who worked on this.  I'm really enjoying this latest community build.

 

I have noticed an issue with the latest community build, and wonder if anyone else has seen this.  My second paddle button doesn't work in this build.  Anybody else seeing that issue?  I used a multimeter to confirm that the button itself is working through the cable, and it works on my 2600.

 

The hyper-paddle fix really is awesome, and this build is near perfect.  Thanks!!

Edited by unixdude

Share this post


Link to post
Share on other sites
On 7/2/2019 at 1:09 PM, unixdude said:

I second the thanks to everyone who worked on this.  I'm really enjoying this latest community build.

 

I have noticed an issue with the latest community build, and wonder if anyone else has seen this.  My second paddle button doesn't work in this build.  Anybody else seeing that issue?  I used a multimeter to confirm that the button itself is working through the cable, and it works on my 2600.

 

The hyper-paddle fix really is awesome, and this build is near perfect.  Thanks!!

I had/have issues with controls as well. If your issue is the same I had, you'll have to MAP the controls for your second set of paddles. Should work fine after that(I had to do this a few times and still occasionally have to remap buttons).

Share this post


Link to post
Share on other sites

Also, on my Sony LCD, I still have the overscan issue... was hoping that this would be fixed.  Oh well, maybe in the next build. (Or maybe I installed the wrong one.)

Share this post


Link to post
Share on other sites

Overscan option is coming in the next build (already completed in current code).  Controller rework is being done for the next release (not finished yet).  This is not a good time of year for this stuff, as people are on vacations, etc.  We will get to it eventually ...

  • Like 4
  • Thanks 1

Share this post


Link to post
Share on other sites

I know I'm asking for the world here, but are there any plans to have Indy 500 and the driving controllers work with Stella 6 on the R77?

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, unixdude said:

I know I'm asking for the world here, but are there any plans to have Indy 500 and the driving controllers work with Stella 6 on the R77?

That would be incredible and perhaps bring tears to my eyes - seriously

Share this post


Link to post
Share on other sites

You can do this now - with a little extra hardware:

  1. One OTG USB cable
  2. Two 2600-daptors, each with an A-B USB cable
  3. One USB hub (bus-powered works fine)

I just tested this (I happened to have an extra 2600-daptor at the moment), and it works great!

 

Connect as follows:

  1. Plug the RetroN 77's power cord into the OTG cable.
  2. Plug the OTG cable into the RetroN 77.
  3. Plug the USB hub into the other connector on the OTG cable.
  4. Plug the two 2600-daptors into their USB cables, and plug those into the USB hub.
  5. Plug your driving controllers into the 2600-daptors.
  6. Fire it up, and play! I didn't need to configure anything. I just had to start a game and move each controller to figure out which was which.

I kept a joystick plugged into the front of the console to navigate the menus.

  • Like 3

Share this post


Link to post
Share on other sites
On 5/19/2019 at 7:06 PM, Striker667 said:

Right paddles buttons were not functioning in Basic settings. 2 sets of paddles had same results. Player 2 and 4 could not start the ball in Breakaway or hold the ball in Warlords.

 

Binding the buttons worked in Advanced settings, but activating that caused a small cascade of other issues. Had to re-bind all aspects of each paddle control after the first power down.

Could you point me to instructions on doing this for Stella on the R77?  I've tried to understand the user's guide on mapping controllers in Stella and I'm not there yet. I've tried googling and searching the forums and I haven't found them yet.  And, unfortunately I hosed my paddle configs trying it out, and removing the settings.sqlite3 file didn't restore the paddles... they're back to major jitter ... so I done something I shouldn't have. :(

 

Also, very awesome on the Indy 500!

Share this post


Link to post
Share on other sites

And now for something completely different: a shameless plug.  There is a Stella fundraiser (dubbed 'Stella-thon') happening tomorrow, July 12.  Info is available at 

Please consider a donation or making a bid on an item.

  • Like 5

Share this post


Link to post
Share on other sites
4 hours ago, stephena said:

And now for something completely different: a shameless plug.  There is a Stella fundraiser (dubbed 'Stella-thon') happening tomorrow, July 12.  Info is available at https://atariage.com/forums/topic/291293-stella-thon-12-hour-gaming-marathon-fundraiser/

Please consider a donation or making a bid on an item.

And relevant to this thread, one of the items is a RetroN 77, updated to Stella 6.1 and pre-loaded with homebrews, plus a few extra goodies.

 

Stella-RetroN77-auction.thumb.jpg.2e08e2a88a6612b8aecaa178db79b330.jpg

  • Like 2

Share this post


Link to post
Share on other sites
18 hours ago, Nathan Strum said:

You can do this now - with a little extra hardware:

  1. One OTG USB cable
  2. Two 2600-daptors, each with an A-B USB cable
  3. One USB hub (bus-powered works fine)

I just tested this (I happened to have an extra 2600-daptor at the moment), and it works great!

 

Connect as follows:

  1. Plug the RetroN 77's power cord into the OTG cable.
  2. Plug the OTG cable into the RetroN 77.
  3. Plug the USB hub into the other connector on the OTG cable.
  4. Plug the two 2600-daptors into their USB cables, and plug those into the USB hub.
  5. Plug your driving controllers into the 2600-daptors.
  6. Fire it up, and play! I didn't need to configure anything. I just had to start a game and move each controller to figure out which was which.

I kept a joystick plugged into the front of the console to navigate the menus.

Nice ,Thanks man! I believe I already have everything that is needed. Will give it a go soon.

Share this post


Link to post
Share on other sites
On 5/19/2019 at 6:27 AM, DirtyHairy said:

Did this work on beta 1? If I remember the code correctly, saving per-game preferences currently suffers from the same problem as savekey data: it only happens at certain points (maybe even only on shutdown), and chances are that you switch off the device before the data is saved (if it happens on shutdown, you'll never execute this code path unless you kill Stella via SSH). This will change in the next beta when we move per-game preferences to SQLite, too.

I'm running into this too (per-game prefs not sticking). I kept trying to change the default controllers to Joystick for Scramble, SuperCobra and Stay Frosty 2. It would work, until I power-cycled the RetroN 77, and it would revert them to Genesis controllers. Weird thing though, in the stella.pro file on the SD card, there are entries for each game that say "Controller.Left" "JOYSTICK". So the data was written - just not read.

Share this post


Link to post
Share on other sites
9 hours ago, Nathan Strum said:

I'm running into this too (per-game prefs not sticking). I kept trying to change the default controllers to Joystick for Scramble, SuperCobra and Stay Frosty 2. It would work, until I power-cycled the RetroN 77, and it would revert them to Genesis controllers. Weird thing though, in the stella.pro file on the SD card, there are entries for each game that say "Controller.Left" "JOYSTICK". So the data was written - just not read.

This is decidedly weird. Maybe the file was corrupted during writing, and Stella doesn't read it properly. The next beta will store per-game settings in sqlite and will save them immediately after they are changed.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...