Jump to content
suspicious_milk

Need advice/pics for 800XL video improvement

Recommended Posts

I picked up an 800XL in fantastic condition and added an Antonia CPU/RAM upgrade. Sold it to a friend of mine, and then ended up getting it back :-)

 

It has pretty fuzzy video though. According to this post:

 

https://atariage.com/forums/topic/198754-current-best-s-video-picture-improvement-mod-for-800xl/

 

I'm going to

 

 

  • REMOVE C56 capacitor (if present). This will dramatically improve sharpness and "edge"-definition.
  • Lift C54 right-hand side, preferably by inserting an on-off switch (if you want to preserve composite out). This will almost COMPLETELY remove vertical banding (present on Luminance-Y signal).
  • Solder Chroma-signal wire from R67/R68 junction, to chroma pin in video port. This will enable the missing chroma-signal on the 800XL (the majority DO NOT have it enabled). No need for pick-up resistor (of any kind).

 

 

 

I'm skipping step 2, as no banding is present; it's just REALLY fuzzy and currently s-video outputs black and white only.

 

My soldering skill are improving, and I've a shiny new solder station arriving on my day off. I guess I could easily do this with just schematics, but ...

It would be greatly appreciated if someone has pics of these simple finished steps (I like pictorial verification, because I'm pretty new at this stuff still). Any other advice on what to do while I'm in there? Besides the Antonia, all my other work has been on XE models. I put a UAV in my 130XE and if this doesn't work out, I'll probably buy another for the 800XL.

 

Thanks,

Thomas

Share this post


Link to post
Share on other sites

you should only fit a switch if you want to choose between both s-video and composite. if youre happy with s-video, just desolder and lift the right-hand side of C54 and leave it disconnected

a drawing is here for reference - to show the locations of the capacitors. NOTE: not all 800XLs have C56

 

hope this helps!

 

 

post-38211-0-63556700-1554801638.jpg

post-38211-0-62101200-1554801644_thumb.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the pics ...

 

I've done

 

  • REMOVE C56 capacitor (if present). This will dramatically improve sharpness and "edge"-definition.
  • Solder Chroma-signal wire from R67/R68 junction, to chroma pin in video port. This will enable the missing chroma-signal on the 800XL (the majority DO NOT have it enabled). No need for pick-up resistor (of any kind).

The composite video is still horrible, no improvement at all. The S-Video (now color!) Loookss spectacular. The color pallete is very wonky though (lots of magenta's)... grrr

This 800xl was/is my experiment machine, but still frustrating. I'll do some digging. Maybe I'll just pull out the Antonia and put it an XE if I can make it fit.

 

Edit: adjusted pot, the color palette is fine now

Edited by suspicious_milk
  • Like 2

Share this post


Link to post
Share on other sites

Thanks. Since the S-Video looks so good, and I don't use composite much, I think I'm going to leave well enough alone for now.

 

I had good results with a UAV board in my 130XE so may go that route with this 800XL later. As it stands, I'd say the 800XL's s-video is superior to the 130XE with UAV.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...