Jump to content
Albert

Forum Upgrade Today, June 15th! PLEASE READ!

Recommended Posts

7 minutes ago, _The Doctor__ said:

unfurtunately, it does not...

I wish it was brought back as it has decidedly different functionality to following...

They could have both really

Friends are not likely coming back, so I would not pin any hopes on that.  I'm certainly not going to modify the software to add that, either.  The more modifications I make to the base software, the more complex upgrades become, which is one (of many) reasons I wasn't able to easily update the old forum software and why it took me so long to do so.

 

 ..Al

  • Like 2

Share this post


Link to post
Share on other sites

Content I posted seems to be working correctly now.  I have some older posts that people replied in that are showing up in the list like they are supposed to. :D 👍👍

  • Like 2

Share this post


Link to post
Share on other sites

The background tasks are nearly complete.  Once they are finished, the search index will build (not sure how long that will take).  After that, I will setup Elasticsearch, which is a better third-party search engine than the one built into the database.  Hmm, actually looks like there's only a single task remaining:

 

Screen Shot 2019-06-24 at 9.01.41 PM.png

 

So, anything still not working correctly after this finishes I can start filing support tickets for, or find solutions on my own.

 

 ..Al

  • Like 5

Share this post


Link to post
Share on other sites
6 minutes ago, Shannon said:

Content I posted seems to be working correctly now.  I have some older posts that people replied in that are showing up in the list like they are supposed to. :D 👍👍

Excellent, glad to hear that.  :)

 

 ..Al

Share this post


Link to post
Share on other sites

Just wanted to mention the "Content I Posted In" activity stream is filling out nicely with older threads.  Everything's looking better and better!

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Albert said:

The Like, Thanks, and Haha reactions add one point to your reputation.  The other two are neutral.  I'm not going to add a reaction that subtracts points, so please nobody ask. 

I intentionally try to confuse people with my posts, so I always saw that as a positive thing. ;)

  • Confused 1

Share this post


Link to post
Share on other sites
31 minutes ago, FujiSkunk said:

Just wanted to mention the "Content I Posted In" activity stream is filling out nicely with older threads.  Everything's looking better and better!

Excellent, I haven't even been paying attention to that, but I will be playing around with search-related stuff tomorrow.

 

 ..Al

  • Like 1

Share this post


Link to post
Share on other sites
On 6/20/2019 at 1:34 PM, ZeroPage Homebrew said:

Looks like the Indefinite Post Editing plugin worked on one of mine but not another:

 

Worked (Can Edit): https://atariage.com/forums/topic/291293-stella-12-hour-gaming-marathon-fundraiser33/

 

Didn't work (Can't Edit): https://atariage.com/forums/topic/276956-zeropage-homebrew-twitch-stream/

 

@Albert: Unfortunately something in the past couple of days has locked down the first posts in both of the above threads so I can't edit either of them. 😞 If I had to put a timing to it, it was shortly after people were reporting errors codes (Error code: EX1054) when trying to save modified posts.

The good news is that I'm also seeing a full history under 'My Activity Streams'!! So good! 🙂

Share this post


Link to post
Share on other sites

One (possible) bug I noticed: All the multi-line code sections from my blog entries before the migration (pretty much all of them but the last one) lost their carriage returns.  I was hoping this would fix itself as the background tasks completed, but as the only task left is indexing I'm suspicious it was a migration issue and isn't going to change.

Share this post


Link to post
Share on other sites

I thought it was odd that Horizontal Rule [ hr ] created a blank line instead of making a horizontal line:

 

 

I wondered if it would bite us all in the backside after a future update, but I joined in anyway. Now I have a bunch of posts with horizontal lines in them instead of blank lines. Now that the main update is over and [ hr ] is doing what the name says instead of being a blank line, is it possible to run an automated thingamabob to convert multiple instances of [ hr ] in posts to a blank line?

 

Here's just one of the many posts that have horizontal lines now:

 

https://atariage.com/forums/topic/253089-gyvolver/

 

Share this post


Link to post
Share on other sites
10 hours ago, ZeroPage Homebrew said:

@Albert: Unfortunately something in the past couple of days has locked down the first posts in both of the above threads so I can't edit either of them. 😞 If I had to put a timing to it, it was shortly after people were reporting errors codes (Error code: EX1054) when trying to save modified posts.

This is a temporary issue, there were some problems with the plugins to enable this feature, so I had to disable them. I do have new versions, but I am going to wait to install them again until after the background tasks are finished.  There's just one last task running now, and once that's complete I'll be installing and testing the indefinite editing modifications.  Sorry for the inconvenience.

 

 ..Al

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Random Terrain said:

I wondered if it would bite us all in the backside after a future update, but I joined in anyway. Now I have a bunch of posts with horizontal lines in them instead of blank lines. Now that the main update is over and [ hr ] is doing what the name says instead of being a blank line, is it possible to run an automated thingamabob to convert multiple instances of [ hr ] in posts to a blank line?

 

Here's just one of the many posts that have horizontal lines now:

 

https://atariage.com/forums/topic/253089-gyvolver/

I might be able to fix these with queries in the database, but I will have to look at how the posts are stored to see if it's easy to find and replace those specific tags.  Probably won't be able to do that until next week.  I'd then need to know what specific blog posts to update, although I could easily enough do them for all of a particular user's blog posts.  Will add this to my list of things to look at, thanks for bringing it up. 

 

 ..Al

  • Thanks 1

Share this post


Link to post
Share on other sites

I just noticed something else missing.  It used to be that if a thread had attachments you could click on the little paperclip icon and it would give a list of all the attachments and then you could access the attachments that way.

 

Share this post


Link to post
Share on other sites

Interesting -- the "Content I Posted In" has gone from only showing things from the last couple weeks, to only showing things from October 1, 2018 through May 31, 2019, plus one blog comment from 12 years ago. :)

 

I'm sure it's a transient phenomenon that'll sort itself out, but I thought I'd mention it just in case, since the omission of the most recent activity seems odd.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, the search index is rebuilding again after I tried to change the search engine from MySQL to Elasticsearch earlier today.  Unfortunately, there's an issue with the Elasticsearch configuration so I had to immediately switch it back to MySQL, which started the rebuild again.  Now that I know that happens, I sure won't be doing that in the middle of the day again.  Lesson learned.  It'll take a full day to rebuild it again, but at least it rebuilds the posts index in reverse chronological order.

 

I'm going to work on some other stuff tonight instead (like making a list of all the theme changes to hand off to the theme designer so he can get those done--especially the mobile skin changes).

 

 ..Al

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
7 hours ago, Shannon said:

I just noticed something else missing.  It used to be that if a thread had attachments you could click on the little paperclip icon and it would give a list of all the attachments and then you could access the attachments that way.

Yes, not sure why they took that out but I'm pretty sure there's a third-party plugin that adds it back.  I've added that to my list!  :D

 

 ..Al

  • Like 3

Share this post


Link to post
Share on other sites
Posted (edited)

Content I posted is not showing anything for me anymore and before it stopped showing stuff it was showing some real old threads in the top three on the list.

 

Actually now it's showing a bunch of older topics but nothing recent.

 

Edited by Shannon

Share this post


Link to post
Share on other sites

I noticed that the "Who's Online" at the bottom of the main forum page is no longer alphabetized.

 

Mitch

Share this post


Link to post
Share on other sites

In the previous forum, in the quote box, there was an arrow that would direct you to the post.  Now, it just shows XXX posted some random time ago, and there is no link to get back to that post.  Can this be added back?

Share this post


Link to post
Share on other sites
4 minutes ago, Shannon said:

Content I posted is not showing anything for me anymore and before it stopped showing stuff it was showing some real old threads in the top three on the list.

 

Actually now it's showing a bunch of older topics but nothing recent.

Please read this post.

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, Stephen said:

In the previous forum, in the quote box, there was an arrow that would direct you to the post.  Now, it just shows XXX posted some random time ago, and there is no link to get back to that post.  Can this be added back?

It's still there:

 

 

image.png

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, Mitch said:

I noticed that the "Who's Online" at the bottom of the main forum page is no longer alphabetized.

Yes, that's something I modified in the old forum software.  Currently it displays the names in order of last activity, but that's not terribly useful so I'm not sure why they do that.  I'll see if there's a third-party plugin that fixes that.  If not, I can look at doing so myself.

 

 ..Al

Share this post


Link to post
Share on other sites

So, I just looked at Tapatalk, and they are charging $5/month if I want to use it without their annoying "Install our app now!" to anyone using the normal mobile forum skin, as well as disabling advertisements in general (not sure how many ads they show now, I don't remember seeing ads the last time I used Tapatalk some time ago).

 

image.png

 

That's $60 a year to add Tapatalk support without it being really annoying.  How badly do people want it?

 

 ..Al

Share this post


Link to post
Share on other sites
22 minutes ago, Albert said:

So, I just looked at Tapatalk, and they are charging $5/month if I want to use it without their annoying "Install our app now!" to anyone using the normal mobile forum skin, as well as disabling advertisements in general (not sure how many ads they show now, I don't remember seeing ads the last time I used Tapatalk some time ago).

 

image.png

 

That's $60 a year to add Tapatalk support without it being really annoying.  How badly do people want it?

 

 ..Al

Please don't, if it doesn't fix the "tons of threads" problem.

Share this post


Link to post
Share on other sites
1 hour ago, Albert said:

That's $60 a year to add Tapatalk support without it being really annoying.  How badly do people want it?

Not worth it, IMHO.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...