Jump to content
towmater

How to bring Apple ][+ to 64K

Recommended Posts

Posted (edited)

Wanting to use the "greatest HD image ever" recently posted here, I found that I need to run ProDos to use HD images with a CFFA3000.

 

No Problem, I thought, I'll add this Microsoft 16K "language card", however ProDos still complains that it wants 64K.

 

Is this the wrong way to upgrade an A2+?

 

 

2019-08-04 13.49.55.jpg

2019-08-04 13.48.41.jpg

Edited by towmater
Added Pix

Share this post


Link to post
Share on other sites
Posted (edited)

ProDOS should Just Work with a Microsoft 16K card properly installed in slot 0. :o

 

ETA: Doesn't that card require one of the chips on the mobo to be moved to the card or something like that like the Apple card?

Edited by The Usotsuki

Share this post


Link to post
Share on other sites
6 hours ago, The Usotsuki said:

ETA: Doesn't that card require one of the chips on the mobo to be moved to the card or something like that like the Apple card?

Yes, it cleverly accesses address and data lines by hijacking one of the mobo ram chips. I will search around for a diagnostic program. I used a mini-pro to verify that all of the 74 logic is working properly, but I don't know for certain that the eight 8118 chips are all OK. Is there a simple way to print the memory size in Basic?

 

Share this post


Link to post
Share on other sites

As far as the lower 48K, try resetting to BASIC so DOS isn't loaded, then type this:

 

? PEEK(115)+256*PEEK(116)

 

That shows the location of the top of memory (usually 49152).

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, The Usotsuki said:

 

That shows the location of the top of memory (usually 49152).

It's 49152. I guess this is moot now, because I ordered a "Saturn Rocket 128K" card out of frustration. The strange thing, though is that I had been using the CFFA3000 without issue before adding the language card, and now that I have removed the language card the CFFA will not boot anymore, flashing "Requires 64K".  UPDATE: all of the stored settings in the CFFA went away for some reason, it works now.

 

Edited by towmater

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...