Jump to content
Sign in to follow this  
str0m

FIXED: Saving games issues

Recommended Posts

Hi, sorry to log this, cart is great just seems to have a saving niggle. 

 

In Power Drive nothing was happening when I would click on save player after a race, it should bring up the 3 game slots. Also at the title screen hitting C should bring up the 3 slots so you can load one but it did nothing. 

 

I restarted the Jag and tried again, this time I could do the above and save, view save slots. Restarted the Jag, hit C at title screen, save game gone.....

 

Pinball Fantasies has saved some high scores I got earlier on 3 tables

 

Just tried Cannon Fodder and that has an issue, see the attached photo with error

 

Sorry! Time for more pinball. PM me if you want my files, dir listing etc. I have got some in a sub folder but power drive in root and fantasies in folder so dont think that's the issue 

20190827_212751.jpg

Edited by SainT
  • Like 1

Share this post


Link to post
Share on other sites

Hmm, odd. I’ve tested Cannon Fodder in the past with no issues (in fact all games have been tested!). I’ll have another test tomorrow and see if something got broken somewhere along the line when support for larger EEPROMs was added.

Edited by SainT

Share this post


Link to post
Share on other sites

One thing to try, out of interest, is to grab the mrq pack and use those with the games. This may solve the problem.

Share this post


Link to post
Share on other sites

Will grab it tomorrow and try although fantasies did save and power drive thought it had till I restarted. No card reader or PC at home so will look at the card at work to see if the save files give any clue. Might be a file name special character issue, they have brackets in them.

Edited by str0m
  • Like 1

Share this post


Link to post
Share on other sites

PDR definately saves as I've been playing it :)

As suggested above, try the .MRQ file.

  • Like 3

Share this post


Link to post
Share on other sites

Just checked the code, bug is as I thought, uninitialised EEPROM size without the MRQ. Firmware fix incoming tomorrow, but for now using the MRQ's will solve it.

  • Like 3

Share this post


Link to post
Share on other sites

Hi Saint.

 

Just been going through my SD cart. Oddly Power Drive and Cannon Fodder had created .e2p files

 

Just organised the cart with marquee files but I will make another dir with just roms only so I can test the new firmware and report back early evening

 

thanks

  • Like 1

Share this post


Link to post
Share on other sites
On 8/28/2019 at 10:34 AM, str0m said:

Hi Saint.

 

Just been going through my SD cart. Oddly Power Drive and Cannon Fodder had created .e2p files

 

Just organised the cart with marquee files but I will make another dir with just roms only so I can test the new firmware and report back early evening

 

thanks

Yeah, it will still create the e2p files even with the wrong size set. They may be larger than 128 bytes on the memory card in this case, or may just fail to load. Either way I repeated the save game not working, applied the fix, and now it's good.

Edited by SainT

Share this post


Link to post
Share on other sites

Yep all seems ok now without mrq file. I think power drive only actually saves once it starts loading the next track as first time I chose a save slot then turned off and not there on restart but tried it again waiting till next stage loaded and it's fine, used 2 slots testing

 

Pinball fantasies fine and cannon fodder. Saved and loaded couple of times. First time I ran CF I had a red jag screen of death, bit odd, its really fussy with carts but your menu was loaded etc so clearly reading ok. My jag isn't 100% though as sound crackles sometimes (real and rom) so probably related

 

Thanks for quick fix. Firmware updates so fast!

Share this post


Link to post
Share on other sites
12 hours ago, str0m said:

Yep all seems ok now without mrq file. I think power drive only actually saves once it starts loading the next track as first time I chose a save slot then turned off and not there on restart but tried it again waiting till next stage loaded and it's fine, used 2 slots testing

 

Pinball fantasies fine and cannon fodder. Saved and loaded couple of times. First time I ran CF I had a red jag screen of death, bit odd, its really fussy with carts but your menu was loaded etc so clearly reading ok. My jag isn't 100% though as sound crackles sometimes (real and rom) so probably related

 

Thanks for quick fix. Firmware updates so fast!

 

The menu is actually a 16bit rom, and only uses 128k, so it uses a very limited part of the address space and data bus. So it’s actually possible to have a dodgy cart connection and have the menu running fine! I’d forgotten how temperamental carts can be, lol.

 

Thanks for the confirmation of the fix, i’ll close this one now and mark as fixed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...