Jump to content
Sign in to follow this  
Shift838

910mp SCART stopped working

Recommended Posts

I have been using the GBS8200 along with my VGAGBS Genie unit to run my Geneve through the VGA port on my 910mp.  I decided to try something on the SCART, but using my Scart-Genie 9640 or a standard cable with only Pots on Csync, R, G, B like I have done before shows no picture.  On another SCART monitor it works.  So I am thinking there is something with the 910mp SCART interface.

 

does anyone know what to look for?  I have never cracked this thing open, so i'm not sure if there is a SCART controller board separate from the main board.

 

It does see the signal, as when I power the Geneve up the screen goes from blue to black immediately.

 

I have verified I am getting 2 volts on pin#16 to put the monitor into RGB mode as well.

 

 

 

 

Share this post


Link to post
Share on other sites

One of my 910MP shows only solid black on VGA input (I have not tested SCART yet). I opened it up and found a leaked cap on the main board. However, after replacing that, it's the same, and I don't know where to go from here.

 

I think it is just one main board, a power board, and tuner module.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

i'll probably be cracking mine open soon.  I have a 910mp cap replacement kit to recap.  maybe there is something blown in there...

Share this post


Link to post
Share on other sites
24 minutes ago, Shift838 said:

i'll probably be cracking mine open soon.  I have a 910mp cap replacement kit to recap.  maybe there is something blown in there...

I ordered a 910mp cap kit from eBay. It was a set of the big power caps, not the problem ones. The 910MP main board has surface mount caps. It uses lots of:

 

Aluminum electrolytic, SMD, mfg part number:

1.0uF 50V    EMVY500ADA1R0MD55G

3.3uF 50V    EMVY500ADA3R3MD55G

10uF 16V     EMVY160ADA100MD55G

100uF 16V   EMZR160ARA101ME61G

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Have you confirmed overall continuity?  My old adapter had a wire break free inside the plastic insulator so what looked good visually was not a complete circuit.  If the 2v is coming from the Geneve or scart genie, the monitor may simply be detecting the mode selection versus actually seeing the video signal.

(Nevermind - I just realized you said you tested the scart genie with another SCART monitor)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...