Jump to content
Bikerbob

BBS software for a test.

Recommended Posts

So, now we also have something called Celerity that may have been a FoReM derivative. Very interesting. :) 

Share this post


Link to post
Share on other sites

I think a lot derived from FoReM just as a lot of the earlier ones derived from AMIS.

 

I know I played with it as a base for a BBS program I wanted to work on (in gradeschool/high school so ... not much came of it).  But the window at the top was something I played with for awhile.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Tillek said:

I think a lot derived from FoReM just as a lot of the earlier ones derived from AMIS.

 

I know I played with it as a base for a BBS program I wanted to work on (in gradeschool/high school so ... not much came of it).  But the window at the top was something I played with for awhile.

 

 

 

The first version of FoReM was derived from AMIS. :) However, later versions, such as FoReM XL and FoReM XE were "rewrites". 

 

-JP

 

Edited by JohnPolka

Share this post


Link to post
Share on other sites

Yeah, I never had FoReM XL or XE, just the plain old one.

 

I never got a Basic XE or XL cart until much later in life.

Share this post


Link to post
Share on other sites

OK well since I started this thread I will continue here. I also posted in the SYSOPS section.

 

I am needing help to get my login working for ForeSight.. which is the software I think I am settling on for Bikerbob's Clubhosue - assuming we can get working.

 

Tillek I would still love the Michton manual scan if you can do it. - that scripting language might ultimately make it a better BBS since I can get people to login with that one no issue. I can at least have it up and then continue to work on it. with the scripts. 

 

Foresight allows me to modify it as well, but many more advanced features and the message base editor uses FDT - which is very advanced and cool.  

 

Above I posted about Transcendence bbs which is a mod of ForEM .. so I would say that has been done.. the cool thing I like about it is the Author was about 4 blocks from where I live now.. SO would be kind of cool to run a homegrown bbs. For now that one is on the backburner, unless the two above are not working out anytime soon. :)

 

Let me know guys.. I would like to try and do some realtime chat somehow - discord or facebook.. or something.

 

James

Share this post


Link to post
Share on other sites

I just haven't really had time to sit and scan with the new job... but that said, no scripting language is better than having actual source code. ;)

 

Like I said in the other thread, maybe we can just set up a time for a call/Zoom meeting and get it squared away.

 

Share this post


Link to post
Share on other sites

Ok, I am running the ForeSight.

 

I have it running ok.. I cannot get the BBS to answer the UDS-10

 

How do I know that the UDS 10 is sending a RING.. when I try to connect? what setting is required as ForeSight is looking for the RING.

 

James

Share this post


Link to post
Share on other sites

Does ForeSight use MDM (modem) files with string commands in them?

 

BBS Express does, and most SysOps will usually "fine tune' theirs for 

their specific needs. I've been told a couple of times by some SysOps

that they just left theirs blank altogether.

 

BOOTUP, ANSWER and RESETMDM can be used by Express.

 

For example, my RESETMDM file contains the following lines:

 

ATH
ATM
ATS2=128
ATS0=0

 

 

Share this post


Link to post
Share on other sites

For what it's worth, you said you can dial out, so I'm assuming you were using a term program.....?

 

I would just make sure you can get a connection out, then hang up, do an ATZ or whatever, and then try to connect through your PC and see what happens on the screen when it gets a connection.

 

 

Share this post


Link to post
Share on other sites

Well I am right there.. I can use syncterm on my laptop.. call.. I get the change in the screen.. showing me there is a connection.. so firewall forward is working.. The UDS-10 is picking up.. but it is not as far as i can tell sending anything to the software - a RING  a CONNECT .. etc.. so nothing happens.. but I can on the computer type logo /96  which is a command to do the login sequence @9600 baud.. which is what I have the UDS and the serial port on the megaSTE set to.

 

WORKS FINE.. I can log in.. go through the bbs all is good.  on a hangup it reinitializes the modem again.. 

 

I think the answer mode I have set is 56 on the UDS? 

 

ANyway. I am also chatting with the author.. he is going back and fourth with me on this.. SO that is also very cool.

 

This is very much like some of the early Mustang PC boards .. I think its pretty cool, once I get it running.. I need to convert a lot of menus and screens to something CLUBHOUSE like.. as this demo is very much from his own BBS back in 96.

 

There is also a command I can use to send to the modem from the CMD prompt while waiting for a call.. called  CRTN   it will send the text I write with a <cr>

 

SO.. if we can get this on Whats app? or discord? or google chat? or zoom.. I am up for getting this working.

 

James

 

Share this post


Link to post
Share on other sites

OK, EVERYTHING IS WORKING..... except I cannot get the UDS-10 to say to ForeSight.. CONNECT or RING.. and Foresight (unless I mod the source and recompile) needs it.

 

ANyone have any ideas???

 

James

modemmode.jpg

connect.jpg

UDS_AT.jpg

Share this post


Link to post
Share on other sites

Part of the problem for me here is that I'm "Express 'centric".

 

I've got zero experience with ForeSight, so I really, sincerely

honestly don't know where to start with it.  :(

 

Share this post


Link to post
Share on other sites

This really doesn't have anything to do with the BBS software.  If he can't get it to RING or CONNECT on a terminal screen that he knows he can call out on, the UDS isn't sending it.  If the UDS isn't sending anything... well... that's the problem that needs solved.

 

Share this post


Link to post
Share on other sites

I've offered to set up time with him too to try to work it out.

 

Share this post


Link to post
Share on other sites
2 hours ago, Tillek said:

I've offered to set up time with him too to try to work it out.

 

Good deal.

 

Share this post


Link to post
Share on other sites

James, save your config file from the UDS-10 and post it here.

 

I'd like to look it over, just for curiosity's sake (I'm sure Tillek

would too).

 

Thanks.

 

Share this post


Link to post
Share on other sites
2 hours ago, Tillek said:

This really doesn't have anything to do with the BBS software.  If he can't get it to RING or CONNECT on a terminal screen that he knows he can call out on, the UDS isn't sending it.  If the UDS isn't sending anything... well... that's the problem that needs solved.

 

 

Agreed. So normally when I'm using TAZ, or FLASH or STalker or (whatever, fill in the blank) and

I type in something like "ATZ" it responds with okay (or something appropriate).

 

Is his UDS-10 not doing that even?

 

Share this post


Link to post
Share on other sites

Well, I made that offer to work it out with him awhile back, so he hasn't taken me up on it... Sorry... I meant to basically say "I'm pretty much out".

Share this post


Link to post
Share on other sites

BikerBob,

 

Not sure if you looked at this already...

 

Under the "Connect Mode" section of the UDS-10 manual, table 5-6 page 28, there are some settings that pertain to modem messages. Make sure you don't have "Numeric modem result codes" enabled. Also, you probably need "Full Verbose" enabled.

 

-JP
 

Share this post


Link to post
Share on other sites

Tillek, I have replied to you I dont know how many times..

 

I have sent you a number of messenger messages on FB..

 

How do you want to set this up??

 

DISCORD? Whatsapp? ZOOM?? I am IN>.. let me know!!!!!!!!!!!

 

James

Share this post


Link to post
Share on other sites
14 hours ago, DarkLord said:

 

Agreed. So normally when I'm using TAZ, or FLASH or STalker or (whatever, fill in the blank) and

I type in something like "ATZ" it responds with okay (or something appropriate).

 

Is his UDS-10 not doing that even?

 

YES it is..   I have also posted a number of responses to this stuff on BBSs as well.. Tillek on STarfleet HQ as well :)

Anyway...

When I use a terminal to call out.. I do get CONNECT on the screen.. is that my UDS?? or is that the BBS software on the other end?

 

If I issue an AT commands I do get the OK.   A screen shot of the device installer screen is attached.

 

 

setup.jpg

Share this post


Link to post
Share on other sites
3 hours ago, Bikerbob said:

Tillek, I have replied to you I dont know how many times..

 

I have sent you a number of messenger messages on FB..

 

How do you want to set this up??

 

DISCORD? Whatsapp? ZOOM?? I am IN>.. let me know!!!!!!!!!!!

 

James

 

I'll try to join in on Discord - already have it set up on this Win7 box.

 

If we can arrange a suitable time good for all of us. 

Share this post


Link to post
Share on other sites

Sorry... thought you knew I wasn't on FB anymore.

 

If we can get a time set up this week or this weekend (I'm trying to get some stuff done here tonight)...  I'm usually free anytime after 6 eastern (that's usually when I sign off from work).

 

Share this post


Link to post
Share on other sites

Okay, there are a few differences between our config files, but I'm not sure that

it's anything that would make an impact or cause the problems you're having.

 

First thing, it looks like we're using the same software release, Software version V5.8.0.5 (060724) LTX,

so we're all up to date.

 

I'm going to highlight the differences below (bearing in mind that DarkForce is primarily to

receive calls, my Mega STe is for calling *out* as is, I would assume, your setup.

 

----------------------------------------------------------------------

DarkForce BBS           Mega STe                 James

 

Baudrate 19.2            Baudrate 19.2          Baudrate 9600

 

Flow 02                      Flow 02                   Flow 00

 

Connect Mode 56        Connect Mode 56      Connect Mode D6

 

Disconn Mode C2        Disconn Mode C0      Disconn Mode 81

----------------------------------------------------------------------

 

It's also imperative that the Control Panel settings be correct as well,

don't forget to double check those.

 

HTHs.

 

PS Way out there but I thought I'd mention it, there's no chance you've

got a strange serial port cable is there?

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...