Jump to content
Frankie

IDE+2.0F Upgrade to SDX 4.49x -- Help

Recommended Posts

When I run uflash and try to upgrade SDX to 4.49 I get the message -

"IDE Plus (SDX) :

unrecognized flash ROM or 

writes disabled. Set device

properties manually?"

 

It currently has SDX 4.48 installed. As far as I know writes are not disabled but I don't know how to check for sure.

 

Frank

Share this post


Link to post
Share on other sites

Uflash version 3 supports: 

 

  • SIDE/SIDE2 cartridge
  • MyIDE/Flash cartridge
  • MyIDE II cartridge
  • AtariMax 1Mbit cartridge
  • AtariMax 8Mbit cartridge
  • Sic! cartridge
  • IDE Plus (SDX ROM)

Share this post


Link to post
Share on other sites
Just now, Frankie said:

Uflash version 3 supports: 

 

  • SIDE/SIDE2 cartridge
  • MyIDE/Flash cartridge
  • MyIDE II cartridge
  • AtariMax 1Mbit cartridge
  • AtariMax 8Mbit cartridge
  • Sic! cartridge
  • IDE Plus (SDX ROM)

According to FJCs website support for these devices in V.3 is preliminary/experimental.

Share this post


Link to post
Share on other sites
19 minutes ago, Frankie said:

When I run uflash and try to upgrade SDX to 4.49 I get the message -

"IDE Plus (SDX) :

unrecognized flash ROM or 

writes disabled. Set device

properties manually?"

 

It currently has SDX 4.48 installed. As far as I know writes are not disabled but I don't know how to check for sure.

Do you have U1MB or anything else on the system? Things seem to work (at least they detect automatically) here as long as IDE+ SDX is ON and no other ROMs are present in the same area.

 

It could simply be that your IDE+ board has a flash ROM which UFLASH doesn't recognize, of course, which is what the error message seems to be telling us. This is the FPGA-based version, correct? What chip IDs does the standard DLT SDX flasher report?

Share this post


Link to post
Share on other sites
18 minutes ago, flashjazzcat said:

Do you have U1MB or anything else on the system? Things seem to work (at least they detect automatically) here as long as IDE+ SDX is ON and no other ROMs are present in the same area.

 

It could simply be that your IDE+ board has a flash ROM which UFLASH doesn't recognize, of course, which is what the error message seems to be telling us. This is the FPGA-based version, correct? What chip IDs does the standard DLT SDX flasher report?

 Am29F800B.   I just flashed it with the standard flasher instead. 

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Frankie said:

 Am29F800B

There you go. Unsupported 8Mbit chip, as per error message. I might see about supporting it in a future revision, but it's news to me that this configuration exists (prior IDE+ revisions had 3 x 4Mbit flash ROMs). Rev. F isn't emulated and I don't have an example of it here to test.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...