Jump to content
ParanoidLittleMan

TOS 2.06 in ST, Mega ST without 32 pin sockets

Recommended Posts

I was thinking after this thread: https://atariage.com/forums/topic/296830-bought-wrong-size-tos-chip/

It is possible to solve TOS 2.06 in ST, Mega ST with existing 28 pin sockets if using EPROMs 27C512 . Will need 4 of them to get needed 256 KB capacity.

Chips may go direct in sockets on mainboard, except pins 20 of 2 EPROMs in middle (FD-H and FD-L). Will need special soldering pad setting and simple additional circuit for new address space - 1 GAL chip for instance. EPROMs 27C512 are still available.

  • Like 2

Share this post


Link to post
Share on other sites

I would love to get TOS v2.06 into my Mega ST without

using a board that interferes with my AdSpeed accelerator.

 

Share this post


Link to post
Share on other sites

I made it in my Mega ST. Here is how looks:

MegaST206_4Epr.thumb.jpg.bac537523a3534652f0978482774e0a1.jpg

EPROMs go in original sockets, so not higher. I soldered GAL on top of 1 20 pin TTL chip - that's where flat cable from CPU goes.

But it can be placed anywhere (near) . Need to solder some 15 lines, most is between CPU and GAL . That's only way without some intermediate board, sockets.

I'm ready to ship this - 4 programmed EPROMs (US 2.06 TOS is what I used here) + programmed GAL for decoding new address space of 2.06 for ST, Mega ST.

 

Share this post


Link to post
Share on other sites

Do you have any idea whether or not it will clash with existing accelerator

boards like the AdSpeed?

 

Thanks.

 

Share this post


Link to post
Share on other sites

According to what I read about AdSpeed it is 16 MHz CPU with some cache, so basically very similar to what is in Mega STE .

What means that should work with any TOS version.  Couldn't find some photo of installed ST version, so can not say how will be good to connect to CPU lines (mostly address) with GAL for address decoding. In any case, those lines - A17-A23, /AS, /RW, /DTACK are accessible at other locations too.

Share this post


Link to post
Share on other sites

Just to give an example, it won't work with the the MonSTer board - some kind of conflict.

 

Share this post


Link to post
Share on other sites
15 hours ago, DarkLord said:

Just to give an example, it won't work with the the MonSTer board - some kind of conflict.

 

That's pretty bad formulation. Since MonsTer self has TOS 2.06 support, you don't need this solution described here.

Share this post


Link to post
Share on other sites

Umm, that's why I'm *not* using the MonSTer board...and

thus, no TOS v2.06, because it conflicts with the AdSpeed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...