Jump to content
Bmack36

CollectorVision Phoenix Release Thread

Recommended Posts

Just starting a new thread now that the Phoenix has started shipping. I will be updating this post with more information.

 

-Up to date cores attached (Uploaded older stable CV version)

(Make sure when you download and copy onto the sd card that the file name doesn't change and that it doesn't append any (1) or anything like that.)

Atari 2600 Core

 CORE02.PHX

 

Updated CV Core(11/13/19)

CORE01.PHX

Changes:

-Changes to the audio mixing

-Added menu on boot or reset for scanlines/flicker. Also works on sd loader

If you hold * or # on reset or power on, it will take you to a menu where you can adjust scanlines and flicker. This should fix the issue with 55AA games. 

 

-Put in M1 wait to fix ntsc/pal detection on QBIQS

-Changed Front LED to Yellow for CV core. This should help with power backfeed detection as the red LED should stay on after power is turned off if the issue is present.

 

 

Github pages for the Colecovision and 2600 cores have been setup below. You should now be able to report bugs in the corresponding repositories.

https://github.com/CollectorVision

 

Check the know issues here:

https://github.com/CollectorVision/Phoenix-Colecovision/issues

 

The 2600 Source has been published and we are working on getting the cv source ready.

Edited by Bmack36
  • Like 4
  • Thanks 8

Share this post


Link to post
Share on other sites
1 hour ago, Antoine said:

Got mine yesterday ! Color and sound are very Nice ! Sydney Hunter amazing!

Nice job!

Glad to hear they started shipping!  I assume they are shipped at or near the order they were preordered?  I'm probably around the middle of the batch.  How long are we expecting batch #1 to complete shipment?

Share this post


Link to post
Share on other sites
50 minutes ago, mingus said:

Glad to hear they started shipping!  I assume they are shipped at or near the order they were preordered?  I'm probably around the middle of the batch.  How long are we expecting batch #1 to complete shipment?

Hopefully they are shipping in order. I think I should be fairly low on the list. They announced the sale around 10:30pm my time via Kickstarter backer email, and I ordered shortly after 5:30am the next morning.

 

Edit: It appears mine is on the way, and due to be delivered Saturday. Looks like it shipped 10/27. I never got a tracking number or any notification it shipped (unless it landed in the junk folder). 

 

But USPS has a service you can enroll in to track mail and packages. As soon as a package is scanned in to their network, they auto add it to my dashboard. Which is how I found it this morning. 

Edited by nick3092
  • Like 1

Share this post


Link to post
Share on other sites
Just now, nick3092 said:

Hopefully they are shipping in order. I think I should be fairly low on the list. They announced the sale around 10:30pm my time via Kickstarter backer email, and I ordered shortly after 5:30am the next morning.

I waited a few months.  I sat there watching the kickstarter run out (I was a backer) and probably should have ordered right then. 

Share this post


Link to post
Share on other sites

Do we get a shipping notice or will it just show up?


Sent from my iPhone using Tapatalk Pro

Share this post


Link to post
Share on other sites

Mine showed up yesterday thanks very much. I'm hoping to try it out tonight. For those asking, I did not get a shipping notice 

Share this post


Link to post
Share on other sites

Got machine gun sound like in AtariLeaf’s video in other thread. Tried different HDMI so it isn’t the cable. Will have to try another tv but hopefully it can work on that tv

 

 

 

Edited by zaphro72
Removed videos as I can’t get size small enough

Share this post


Link to post
Share on other sites

First post updated with updated core. The changes for Telebunny have been taken out as it was causing an issue with the sound.

Share this post


Link to post
Share on other sites
6 hours ago, Bmack36 said:

First post updated with updated core. The changes for Telebunny have been taken out as it was causing an issue with the sound.

Brian, I do think you should include a changelog with each core release.  This way people will then know (i) if the update is one that will benefit or is of interest to them, and (ii) where fixes are included in the update, users then know what they are and so can verify they work with their specific setup.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Brian,

Does the CV core offer in game pause for games that did not originally have this feature?  If not, would this be a feature offered in a future core update?

Thanks,

Tom

Share this post


Link to post
Share on other sites

So as of now with the new update, Telebunny cartridge does not work now? If not, is it something that can get fixed?

Share this post


Link to post
Share on other sites

I think I have a bad unit. I can't run any cartridges. Every cartridge including Syndey Hunter brings up a white screen. If I start without a cartridge, I get the startup and then a list of colecovision roms. I've updated both cores found a the top of this page. I'm going to try a different tv.

Share this post


Link to post
Share on other sites
3 minutes ago, Master Phruby said:

I think I have a bad unit. I can't run any cartridges. Every cartridge including Syndey Hunter brings up a white screen. If I start without a cartridge, I get the startup and then a list of colecovision roms. I've updated both cores found a the top of this page. I'm going to try a different tv.

There are 2 known issues at the moment.

The white screen on boot is one of them. Some TVs backfeed power to the system which keeps the system from powering all the way off. The best way to fix it is to use a HDMI switch inbetween the tv and Phoenix. Inserting some original games, like DK Jr., into the system when the power is off can actually power the system down and allow it to come back up. The other temporary option is to unplug the HDMI cable and put it back in.

  • Like 1

Share this post


Link to post
Share on other sites

Other TV returns a white screen with any cartridge. Without cartridge, I get white wavie lines. No picture. 

So far not impressed.

Share this post


Link to post
Share on other sites

Try unplugging the HDMI and power then turn on the system with no cartridge. Does it boot up the first time? Is it only powering off the system and then turning it back on that generates the white screen?

Share this post


Link to post
Share on other sites

So SFC controllers don’t work for 2600 core correct? 
 

Right now the machine gun sound like atarileaf posted isn’t happening on the 2600 core but haven’t been able to start a 2600 game yet, just load them

Share this post


Link to post
Share on other sites
6 minutes ago, Bmack36 said:

There are 2 known issues at the moment.

The white screen on boot is one of them. Some TVs backfeed power to the system which keeps the system from powering all the way off. The best way to fix it is to use a HDMI switch inbetween the tv and Phoenix. Inserting some original games, like DK Jr., into the system when the power is off can actually power the system down and allow it to come back up. The other temporary option is to unplug the HDMI cable and put it back in.

I do have a switch between the second tv and the Phoenix. Turned it back on with no cart and it's in black and white. 

Share this post


Link to post
Share on other sites

Yes you can use a SFC controller on Atari core. To start games on the core you have to select load rom.

 

Share this post


Link to post
Share on other sites
6 minutes ago, Bmack36 said:

Try unplugging the HDMI and power then turn on the system with no cartridge. Does it boot up the first time? Is it only powering off the system and then turning it back on that generates the white screen?

A cartridge will always generate a white screen. Without a cartridge, it is in black and white with the switch. I've even restarted the switch. I'll try it directly now.

Edited by Master Phruby

Share this post


Link to post
Share on other sites
1 minute ago, Master Phruby said:

I do have a switch between the second tv and the Phoenix. Turned it back on with no cart and it's in black and white. 

Is the 2600 core in black and white as well or just the cv core?

Share this post


Link to post
Share on other sites
1 minute ago, Bmack36 said:

Yes you can use a SFC controller on Atari core. To start games on the core you have to select load rom.

 

So I selected load rom and its up on the screen but I can’t start playing the game

Share this post


Link to post
Share on other sites

Press either Left fire on cv controller or select start on the menu. You can close the menu with 1 on the cv controller. Which game are you trying?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...