Jump to content
BeeryMiller

Eprom for Geneve SCSI Booting

Recommended Posts

Tony Knerr released a SCSI Boot Eprom years ago.  I do not see the eprom image on WHT and I have not found it on YahooGroups.

 

Does anyone have the image I can burn?  I looked at Arcadeshopper thinking I may be able to order an eprom, however, all the eproms for ordering have seemed to disappeared, or I am not looking in the right location.


Preferably, if someone has the image or can point me to where it is, it would be appreciated as I can burn my own eproms.

 

Beery

 

Share this post


Link to post
Share on other sites
Tony Knerr released a SCSI Boot Eprom years ago.  I do not see the eprom image on WHT and I have not found it on YahooGroups.

 

Does anyone have the image I can burn?  I looked at Arcadeshopper thinking I may be able to order an eprom, however, all the eproms for ordering have seemed to disappeared, or I am not looking in the right location.

 

Preferably, if someone has the image or can point me to where it is, it would be appreciated as I can burn my own eproms.

 

Beery

 

You aren't looking in the right location

 

https://www.arcadeshopper.com/wp/?page_id=11#!/Hummingbird-Eeprom/p/33994194/category=12497082

 

Also unless it's the same as the v1 eprom it's not in the list.

 

Sent from my LM-G820 using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites

OK, I have that Eprom that I ordered long time ago from you.  Your response gave me a clue, I need to do some file renaming and find the appropriate LOAD/SYS utility.

 

Need to go and read some docs...……..

  • Like 1

Share this post


Link to post
Share on other sites

Once you get it booting with Tony's version of SCSI/SYS I'll email you an updated file that allows you to turn CRC on/off; it also employs a table-driven CRC routine I added to the Geneve OS CRC check utility. Thus bootup is a but faster as Shift838 can attest.  (I thought I posted v2.5 in the forums but the search engine isn't finding it).

 

Anyway, my platter and SCSI2SD device that contain the IDE/SYS and SCSI/SYS code were partially corrupted by MDOS 7.00 (presumably) fortunately I have copies on floppy for when I can put my own system back together. I also made a dump of the image to PC but it isn't the final rev.

 

Share this post


Link to post
Share on other sites

OK, made quite a bit of progress.  The SCSI system is booting from the V1.00 eprom.  Updated files when you get a chance is appreciated whenever you get a chance.

 

Beery

 

  • Like 1

Share this post


Link to post
Share on other sites

Excellent work. 

Hmm, now that I think about it the updated SCIS/SYS executable might be on the Heatwave BBS platter that I had to retire (and the reason file transfers are offline).   If Shift838 has a copy and wants to share here that's fine. I'll scout around this week as time permits.

Share this post


Link to post
Share on other sites
10 minutes ago, InsaneMultitasker said:

Excellent work. 

Hmm, now that I think about it the updated SCIS/SYS executable might be on the Heatwave BBS platter that I had to retire (and the reason file transfers are offline).   If Shift838 has a copy and wants to share here that's fine. I'll scout around this week as time permits.

No hurry Tim as I know you are busy.  Today is my day off this week, so doing some posting here documenting things, etc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...