Jump to content

Recommended Posts

Here's a shot from my 600XL, if it helps.  It has been upgraded to 64K of internal RAM and Rev. C BASIC, so those items are correct.

IMG_0258.jpg

  • Thanks 1

Share this post


Link to post
Share on other sites

Here is my test on stock PAL 600XL. The OS ROM is not detected correctly ;( IMG_4666.thumb.JPG.4e11d384630e1102aa5a9be5a27521dd.JPG  ps. thanks for sending a test version and please let me know if more tests are needed:)

Edited by mikesk8
added PAL
  • Thanks 1

Share this post


Link to post
Share on other sites
14 hours ago, x=usr(1536) said:

Here's a shot from my 600XL, if it helps.  It has been upgraded to 64K of internal RAM and Rev. C BASIC, so those items are correct.

thanks for the feedback 👍

6 hours ago, mikesk8 said:

Here is my test on stock PAL 600XL. The OS ROM is not detected correctly ;( ps. thanks for sending a test version and please let me know if more tests are needed:)

thank you very much for the test at least no longer detects it as 400/800, just the same thing happens to me in the emulator does not detect me well when it is 600XL of 16k. I will continue investigating the case ....😅

when I have something I'll let you know for another test.😉

4 hours ago, tmp said:

a cosmetic issue, it says "RAM : 1088 KBtari" here

thanks for taking the time to report it. 👍

Share this post


Link to post
Share on other sites

IMG_4671.thumb.JPG.0acb7e844e598e604e5f5682c1e9055c.JPG Thanks. It seems all issues are solved now! :) All the data are correct on my stock 600xl :)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
On 9/15/2021 at 7:53 AM, mikesk8 said:

 Thanks. It seems all issues are solved now! :) All the data are correct on my stock 600xl :)

No problem, I'm happy for you to test and report bugs. We are now releasing the final version 1.7 for everyone.😉

 

  • Like 3

Share this post


Link to post
Share on other sites

Very nice program... I am going thru all of my A8 hardware now and this is coming in handy.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/20/2021 at 1:20 PM, bf2k+ said:

Very nice program... I am going thru all of my A8 hardware now and this is coming in handy.

I'm glad that's what it was created for, if you find something strange don't hesitate to let us know here. 😉

Share this post


Link to post
Share on other sites

Here's a strange one...  this 800XL has a 256k Rambo upgrade in it.  HWD is reporting 40kb Ram.  Sorry for all the reflected lights in the image.  Also it should be a stock Basic ROM probably rev B.

 

image.thumb.png.a224d3cf781ee42d5732b7a7111b7f1c.png

Share this post


Link to post
Share on other sites
On 10/7/2021 at 1:36 PM, bf2k+ said:

Here's a strange one...  this 800XL has a 256k Rambo upgrade in it.  HWD is reporting 40kb Ram.  Sorry for all the reflected lights in the image.  Also it should be a stock Basic ROM probably rev B.

 

image.thumb.png.a224d3cf781ee42d5732b7a7111b7f1c.png

thank you very much for the report😉, it seems to think it's a 400/800 that's why I detected 40kb.

can you run the following line in basic to see if I am correct.

? PEEK(64728)

Share this post


Link to post
Share on other sites

peek(64728) = 76

 

Both of my Rambo 256k machines are exhibiting the same behavior.

Share this post


Link to post
Share on other sites
On 10/11/2021 at 9:06 PM, bf2k+ said:

peek(64728) = 76

 

Both of my Rambo 256k machines are exhibiting the same behavior.

Thank you very much, with that I rule out problems in the OS-A or OS-B detection.😁

 

Now I did some tests and I was able to replicate the symptom in the emulator, when you have some time try this version.

hw-detect_b.xex

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...