Jump to content
rensoup

Unicorns season: Prince of Persia for the A8!

Recommended Posts

28 minutes ago, xxl said:

what are you here for? does not take you 40 years back? :D
 
You can always use the native Atari data carrier (which is Cartridge), and you won't complain that this makes Atari a game console, not a super professional and extremely well thought-out computer system ;-) 

 

chill out :)

Come on, don't bitch around.

 

Tell us if XBIOS is capable of more than 1*SIO which seems quite unclear when I look at some other threads here on AA.

And if it is then tell @rensoup how to use it for the good of all of us.

  • Thanks 2

Share this post


Link to post
Share on other sites
19 minutes ago, Mazzspeed said:

I hope there isn't some underlying code in xbios causing this issue with SIDE3 as has been the case with certain configs and code written by yourself in the past, as that's in no way acceptable.

most of the underlying code to not work on your hardware has the original synfile + :D

you're talking nonsense.

 

21 minutes ago, Mazzspeed said:

If that's not the case, I apologize.

I do not take offense at trolls

 

  • Haha 1

Share this post


Link to post
Share on other sites
2 hours ago, pps said:

Another thing I noticed: The .car crashes on ATARI OS in Altirra, but runs fine with Altirra OS selected.

 

 

This is down to a odd choice of implementation here in the replacement code under to OS

 

image.png.7e547c1c1dbfe4e4a397de02682c0bc0.png

 

If I change that to a NOP ($EA) then it proceeds until the same thing here...

 

image.png.dd680df15bd1e19deda6d2a24355ddac.png

 

Patching that too make the game work.

 

I suspect as the KIL is 'ignored' on real hardware and the game proceeds fine but an emulator will trigger the debugger.

 

@rensoup is this intentional?

  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, Wrathchild said:

That's not how it works, use the 'Cartridge/Program' menu if you have the programmer/cable or use the 'Tools/Convert BIN to ATR image' but that requires cutting the 16 byte header from the car file first, e.g. via a hex editor or loading/saving-as from Altirra. Here's an ATR to program the 8Mb MaxFlash cart in case anyone needs it.

PoP_Atarimax_20210610.atr 1 MB · 2 downloads

Haha, just did this by myselves and wanted to post it here ;)

 

I can confirm now, that doing it this way, you are able to flash a 8MBit ATARIMaxFlash cartridge and run PoP fine even with ATARI OS on real machine. Don't know why the given .CAR crashes the emulator, but real machine is fine ;)

 

btw. would be nice to have the .mcw for being able to flash the cart with the USB flasher, but hey that is luxury then ;)

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, pps said:

would be nice to have the .mcw

That wouldn't make any sense as its not a menu disk

Share this post


Link to post
Share on other sites
Just now, Wrathchild said:

That wouldn't make any sense as its not a menu disk

It makes sense, as you could flash it then with the USB flasher with a lot more speed.

Share this post


Link to post
Share on other sites

I can't understand any reason for all this stupid stressing about xbios and loading time.

What's the problem? If you want to play the game, on 40 yo machines, you should have the time to play AND also the time to load the game. How many times ppl want to load the whole game in one gaming session? One fucking time? Maybe 2 times.

The haters should be thankful for xbios, POP and all the other A8 stuff, developed by ppl as hobbyists.

If the haters could do it better, so why the haters don't do it better? Some ppl would like to load from tape, some from disk and some from cart. 

 

I'm just thankful for the stuff as it is. I can't do it better so I'll take it as it is.

 

Who Cares Episode 8 GIF by ABC Network

  • Like 7

Share this post


Link to post
Share on other sites

 

13 minutes ago, pps said:

It makes sense, as you could flash it then with the USB flasher with a lot more speed.

Really? Out of the time it will take to program the cart, loading it via a double click or selecting the image via the Cartridge/Program is a tiny fraction.

 

Anyway, the mcw file is a definition of the binaries included in the menu and the option for the menu, colours, font, OS-B, file launch etc.

 

You can't add an 8MBit cart image to a menu as it won't fit on the cart!

 

You can, of course, ask Steve/Classics to add support it though.

Share this post


Link to post
Share on other sites
23 minutes ago, MARIO130XE said:

I can't understand any reason for all this stupid stressing about xbios and loading time.

What's the problem? If you want to play the game, on 40 yo machines, you should have the time to play AND also the time to load the game. How many times ppl want to load the whole game in one gaming session? One fucking time? Maybe 2 times.

Indeed you can't understand...

1. No problem to wait for loading the level even with 1xSIO, since you don't get interruptions during play (I even wrote this, but you pick what you prefer apparently).

2. Contrary to 1. the intro and attract mode (demo) suffers big time with those interruptions for ultraslow loading with enforced 1xSIO. No music, no story pages, just breaks for too many seconds and the whole effect of the intro is gone.

3. Why do you dismiss the fact that peripherials for 8-bit Atari allowed for turbo speeds for let's say 35+ years, already? It's xBIOS limitation (apparently) bringing it down to 1xSIO where 3xSIO is AVAILABLE. And these are well-established solutions FROM the ERA. Atari is about both hardware and software we love.

4. Even cart version has these pauses for loading (mouse or princess wait-animation), although much shorter, so they harm the effect less, but on cart there should be 100% fluency, one can imagine.

23 minutes ago, MARIO130XE said:

The haters should be thankful for xbios, POP and all the other A8 stuff, developed by ppl as hobbyists.

If the haters could do it better, so why the haters don't do it better? Some ppl would like to load from tape, some from disk and some from cart. 

I can clearly see only one hater here, others are expressing opinions politely and in general give thanks and appreciate the conversion, even if there are some aspects some don't quite like, most of the game is great.

It's public forum, public discussion so any project in any retro community triggers comments and feedback, especially the big title like PoP involves lot of emotions. Deal with it, even if it doesn't suit your "just appreciate and shut-up" attitude.

P.S.
Using f-word is cheap and doesn't stamp you any authority, just the opposite.

Edited by Jacques
  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, Wrathchild said:

 

Really? Out of the time it will take to program the cart, loading it via a double click or selecting the image via the Cartridge/Program is a tiny fraction.

 

Anyway, the mcw file is a definition of the binaries included in the menu and the option for the menu, colours, font, OS-B, file launch etc.

 

You can't add an 8MBit cart image to a menu as it won't fit on the cart!

 

You can, of course, ask Steve/Classics to add support it though.

Ah sorry, had thought that you can only flash, what is loaded into the Studio actually. Did not remember that if nothing is open, you are prompted to choose a bin or atr to flash :|

Share this post


Link to post
Share on other sites
3 minutes ago, pps said:

Ah sorry

No worries, just not wanting others to get the wrong impression about the software/technology

  • Like 1

Share this post


Link to post
Share on other sites

And all of you know - even if @XXL deliberately done something there's no force on AtariAge to change his mind.

 

Enjoy the game as it is.

Edited by zbyti
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, xxl said:

most of the underlying code to not work on your hardware has the original synfile + :D

you're talking nonsense.

 

I do not take offense at trolls

 

I don't like you, I don't trust you.

 

Call me a troll all you like, I've read what you've done in the past, there's only one troll here.

 

Edited by Mazzspeed

Share this post


Link to post
Share on other sites

Pre-final release title screen comparison :)

 

Amiga/PC:

obraz.thumb.png.a26f90fea14551e2391a9025650b5532.png.ac7242e2351cebe8af8167064b3bd2ce.png

 

CPC:

obraz.thumb.png.caf0bcbcc4d750f76a4c82035ee1dd0b.png.c7451160da38ea37c634ea88ef784185.png

 

C64:

obraz.png.93dbb39020ff391361c0c369b41370ea.png.0f6c560e394268a7b1a9c532cb9c2436.png

 

Atari?

atari000.jpg.6d906bf86ac6d4165d28b5b14829fa28.jpg

 

Is it just an interim title screen or is going to stay?

The title logo on top and the palette is great, but I miss the palace which is almost invisible in the backround (will it be there in final picture?), and it's a bit weird with the mouse acting as main character (she has her tiny role in the game, but still) 🙃

Clearly she had eaten early-proposal title screen🤭

 

popmockupintro3.png.bea0dd360bcfbdde6609dbd900a99c92.png.3efce36757922cb9e553641d97941929.png

 

Anyway, the newer is nicer (and surely micer).

Edited by Jacques

Share this post


Link to post
Share on other sites
13 minutes ago, zbyti said:

And all of you know - even if @XXL deliberately done something there's no force on AtariAge to change his mind.

 

You are certainly right for the part which involves the private feud between xxl and candle.

 

But as far as I remember xxl himself somewhere wrote that XBIOS is capable of doing highspeed SIO.

But it seems that nobody knows how to activate it which cannot be in the sense of xxl who wants XBIOS to be used by great Atari software.

Share this post


Link to post
Share on other sites
Just now, Wrathchild said:

No worries, just not wanting others to get the wrong impression about the software/technology

You helped me to refresh my knowledge of MaxFlashStudio again, too ;)

 

24 minutes ago, Jacques said:

3. Why do you dismiss the fact that peripherials for 8-bit Atari allowed for turbo speeds for let's say 35+ years, already? It's xBIOS limitation (apparently) bringing it down to 1xSIO where 3xSIO is AVAILABLE. And these are well-established solutions FROM the ERA. Atari is about both hardware and software we love.

Please do not forget, that xBIOS is a tiny system, that allows to do a lot disc based work, that would need a DOS instead, that uses a lot more of RAM, so some projects would be impossible without xBIOS. So, yes it has it's limitations, but these are needed because of having as much as possible of free RAM with as much of possible DOS functions.

 

Another small system that provides similar functions to xBIOS is uDOS by Stefan Dorndorf. Even there you are limited to single SIO speed as of size matters.

 

Personally I can't understand why XXL chooses to put code in his projects (not all of them), that makes loading on U1MB systems impossible, but if he does not want to change this, I will respect this. In result I can't use this things on my real ATARI, as I have U1MB equipped machine as main ATARI.

Would be very cool, if he at some day will change his opinion , so I could use all of the things on real machine, too. But I can't understand, why some people are so aggressive here. This community is to small to fight together. Working together makes us stronger than fighting. Look what progress was made with the RMT2LZSS sounds. There people worked together and now we have a lot better possibilities to make nice sounds on ATARI.

Don't always fight against @xxl or @emkay. Better talk together to have better solutions for us all.

________now BTT!__________

PoP looks and plays like a charm on my STEREO U1MB 600 XL. Thanks for this great conversion project. The final game should be prepared for a physical release. This is worth any price!

So cool that PoP finally arrives on our beloved ATARI!

  • Like 8

Share this post


Link to post
Share on other sites
16 minutes ago, DjayBee said:

You are certainly right for the part which involves the private feud between xxl and candle.

 

But as far as I remember xxl himself somewhere wrote that XBIOS is capable of doing highspeed SIO.

But it seems that nobody knows how to activate it which cannot be in the sense of xxl who wants XBIOS to be used by great Atari software.

Well call me paranoid, but based on certain comments in the last page or two alone from a certain member, it appears that someone believes in a 'pure' Atari experience - Not an experience polluted by pesky modern upgrades, even if they are utilizing features designed into the original machine by Atari engineers themselves.

 

I was open minded and fairly rational until I read the above mentioned comments from a certain member, now I smell something and I really hope I'm wrong.

Edited by Mazzspeed

Share this post


Link to post
Share on other sites
4 minutes ago, DjayBee said:

But it seems that nobody knows how to activate it which cannot be in the sense of xxl who wants XBIOS to be used by great Atari software.

nobody knows what he really want ;)

  • Haha 2

Share this post


Link to post
Share on other sites
9 minutes ago, pps said:

Personally I can't understand why XXL chooses to put code in his projects (not all of them), that makes loading on U1MB systems impossible, but if he does not want to change this, I will respect this. In result I can't use this things on my real ATARI, as I have U1MB equipped machine as main ATARI.

Would be very cool, if he at some day will change his opinion , so I could use all of the things on real machine, too. But I can't understand, why some people are so aggressive here. This community is to small to fight together. Working together makes us stronger than fighting. Look what progress was made with the RMT2LZSS sounds. There people worked together and now we have a lot better possibilities to make nice sounds on ATARI.

Don't always fight against @xxl or @emkay. Better talk together to have better solutions for us all.

________now BTT!__________

PoP looks and plays like a charm on my STEREO U1MB 600 XL. Thanks for this great conversion project. The final game should be prepared for a physical release. This is worth any price!

So cool that PoP finally arrives on our beloved ATARI!

 

Very well said, Ralf. 

 

 

BTT: Btw, what's actually the reason for the flickering borders in the title screens? 🤔

Share this post


Link to post
Share on other sites

At first, a big thank you to all involved for the new version! I am really happy that I can play POP on the Atari 8Bit after all these years!

 

Had only a quick test via emulation, but all versions (disk and car) worked fine there. Test emulation was done with an appropriate old environment, Win XP and Atari 800 Win (setup with 1088k RAM, PAL, XL-OS Rev. 2). Will test the released versions on real Ataris later this day. None of my Ataris are equipped with U1MB and SIDE3, will therefore test with 512k SRAM by mega-hz and 512k SRAM by tf_hh and with + without AVG cart. and Speedy 1050 drive. (Could also try to program/flash my SIC! 2MBit cart., but do not remember how it is done and/or what software is required to do it.)

 

Alas, it looks like history repeats itself here, simply read the replies about Stunt Car Racer and the replies about POP here and it looks like XBIOS has something to do with them in both cases... 😒  So, all programmers should be warned or at least be informed (so they know before-hand) what reactions will happen in the A8 scene, if they use XBIOS with their program(s).

 

  • Like 1

Share this post


Link to post
Share on other sites

I find the idea of giving attention to the mouse in the title really funny. 

It gives an idea of soemone who is telling the story (a mouse told me ... :) )

If it's possible to show the palace (?) a little better, why not. 

 

 

  • Like 2

Share this post


Link to post
Share on other sites

Idea for the "Palace in the title". 

It should be darker than the sky. Then put some windows in where some light comes trough.

  • Like 1

Share this post


Link to post
Share on other sites

The AtariMax .CAR image loading under SIDE3. That's as good as it gets, the other two .CAR images simply go to a blue screen, at least the AtariMax image starts loading only to stop and bomb to the self test screen. Changing the OS ROM to Altirra OS does nothing at all, you get the exact same thing.

 

 

 

Here's the Megacart image, just crashes to a blue screen. The SIC image does the exact same thing:

 

 

Edited by Mazzspeed
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   1 member

×
×
  • Create New...