Jump to content
tmop69

Converting EA3 to SSS cart

Recommended Posts

1 hour ago, tmop69 said:

In attachment the file.

MORPHY_C.BIN 16 kB · 2 downloads

This shouldn't work as a C file.. C is for 8k, non-banked ROMs. Is it working for other people? If I change the type to 8 it works, but Classic99 starts in the wrong bank so I have to force a bank change first. ;)

Regarding the disk access - changing the disk configuration in Classic99 doesn't disable the disk startup, though I thought it didn't write anything with CALL FILES(0)... I'll check that. You can create a custom cartridge to overwrite the Classic99 Disk DSR, and that will prevent startup, but might not be satisfactory in the end.

 

Anyway, as a quick hack, I reversed the bank order and changed the type byte to 9 in the filename, this works for me in Classic99... there's nothing wrong with the other file except to make it work in Classic99 you'd need to use an INI to tell Classic99 the banking type.

 

 

MORPHY_9.BIN

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Tursi said:

This shouldn't work as a C file.. C is for 8k, non-banked ROMs. Is it working for other people? If I change the type to 8 it works, but Classic99 starts in the wrong bank so I have to force a bank change first. ;)

Regarding the disk access - changing the disk configuration in Classic99 doesn't disable the disk startup, though I thought it didn't write anything with CALL FILES(0)... I'll check that. You can create a custom cartridge to overwrite the Classic99 Disk DSR, and that will prevent startup, but might not be satisfactory in the end.

 

Anyway, as a quick hack, I reversed the bank order and changed the type byte to 9 in the filename, this works for me in Classic99... there's nothing wrong with the other file except to make it work in Classic99 you'd need to use an INI to tell Classic99 the banking type.

 

 

MORPHY_9.BIN 16 kB · 1 download

 

Hi Tursi,

 

I've generated first the ROM from Classic99 (renamed to _9) and is working fine with it. I have reversed the bank order to run it on MiSTer and FinalGROM (renamed with _8). If you drag this _8 file on Classic99 you cannot see the voice to run the game on the menu, but if you rename it to _C it was working fine. However, I have tested again today and now I'm getting an error message! Yesterday I have changed the .ini file on Classic99 and then reversed back to the original one. I have disabled SAMS, disks and speech, but now it seems that is not working anymore. Really strange, I probably messed-up something during the various attempts. My Classic99 is version QI399.010.

 

Anyway you now provided the working file for Classic99. 🙂  

 

  • Like 1

Share this post


Link to post
Share on other sites
15 hours ago, tmop69 said:

 

Hi Tursi,

 

I've generated first the ROM from Classic99 (renamed to _9) and is working fine with it. I have reversed the bank order to run it on MiSTer and FinalGROM (renamed with _8). If you drag this _8 file on Classic99 you cannot see the voice to run the game on the menu, but if you rename it to _C it was working fine. However, I have tested again today and now I'm getting an error message! Yesterday I have changed the .ini file on Classic99 and then reversed back to the original one. I have disabled SAMS, disks and speech, but now it seems that is not working anymore. Really strange, I probably messed-up something during the various attempts. My Classic99 is version QI399.010.

 

Anyway you now provided the working file for Classic99. 🙂  

 

If you had all of the files in the same folder (_8, _9, _C), that would explain it working. If you look at the debug log (first place you should ALWAYS look for weird behaviour), you'll see that Classic99 is loading them ALL if you are using User->Open or drag and drop. If the right one loads last, then it works.

 

The reason is the old C/D/G issue. Since User->Open is an automatic mode, Classic99 doesn't assume that it knows what all the files associated with one cartridge are, so it just tries them all, and loads any that it finds (even if they overlap). So, it looks for 3,8,9,C,D, and G versions of the filename passed in.

 

So if you're in there making different versions of the ROM and testing in Classic99, make sure you change the filename as well as the last character, or put them in different folders, OR just use a Classic99.ini entry so the emulator doesn't have to guess. ;)

 

  • Like 3

Share this post


Link to post
Share on other sites
7 hours ago, Tursi said:

If you had all of the files in the same folder (_8, _9, _C), that would explain it working. If you look at the debug log (first place you should ALWAYS look for weird behaviour), you'll see that Classic99 is loading them ALL if you are using User->Open or drag and drop. If the right one loads last, then it works.

 

The reason is the old C/D/G issue. Since User->Open is an automatic mode, Classic99 doesn't assume that it knows what all the files associated with one cartridge are, so it just tries them all, and loads any that it finds (even if they overlap). So, it looks for 3,8,9,C,D, and G versions of the filename passed in.

 

So if you're in there making different versions of the ROM and testing in Classic99, make sure you change the filename as well as the last character, or put them in different folders, OR just use a Classic99.ini entry so the emulator doesn't have to guess. ;)

 

yes, I had in the same directory both _9 and _C files, so this explains why it was working and then,  when I've renamed/moved one of the files, it failed. I've not checked the log window. 🙂 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...