Jump to content
Sign in to follow this  
Stguild

130XE with 1MB RAM Needs Help.

Recommended Posts

I have a 130 XE that has a 1MB upgrade in it. It works but it looks like a little kid installed it and its a mess. Is there anyone out there that could take it and reinstall it for me? You would need to clean up the wiring and resolder it all.

 

 

 

  • Haha 1

Share this post


Link to post
Share on other sites

It would help if you indicated where in the world you're located and post a photo of the starting condition of said mess. :)

  • Haha 2

Share this post


Link to post
Share on other sites

I am in the US. Ohio. Her are a few pictures of the mess inside it. I also have no idea what the toggle switch does.

20191214_145030.jpg

20191214_145025.jpg

20191214_145014.jpg

Share this post


Link to post
Share on other sites

That looks terrible, not sure even a kid would make a mess like that 😎

 

Whats under the black tape ? 

  • Like 1

Share this post


Link to post
Share on other sites

That's not a 1meg XE.. 

That's a 320k..

 

How do I know? 

Only 2 additional PIA bits are used by that expansion (only 2 wires going to the PIA chip).

 

The 130xe used 2bits for extended ram in stock configuration..  Adding 2 more gives you 16 (2^4) banks of 16k.. 16 x 16 = 256...  So 64k base ram plus 256k extended.. Thats 320k..  Very popular upgrade..  

 

There's also the fact that there's only 1 bank of (256k)DRAM chips in the extended bank. They did make 1meg DRAMs but no one used them for homebrew atari 8 bit ram expansions because they require additional wiring to connect, and even more additional circuitry for refresh because ANTIC will not refresh that many address bits of DRAM by itself..

 

What's under the black tape, you ask? 

 

Probably a 74HC86..  You see the momentary push button on the back of the case? 

 

Hold that button and hit reset to cold-reset the machine without wiping out the contents of the extended ram..  You have to boot back up and use a special ramdisk handler to reconfigure the ramdisk without initializing it, but you can cold boot the machine and still have your data in ram.. 

 

Anywayze.. What you have there is a "Scott Petersen 320k upgrade", with a "Bob Wooley freezer switch" mod added.. 

 

It looks fine to me.. make sure there's no broken wires, and no exposed wires touching anything metal.. Put it back together and enjoy.. 

 

There are plenty of demos that use the extra ram, and you can use it as a 256k ramdisk in both SpartaDOS X, and disk based versions of SpartaDOS.. 

 

If I was you I'd either 

 

(a) leave it alone and enjoy your 320k XE... 

 

Or (b) Buy an "Ultimate 1 Meg" Expansion from Lotharek and find a competant hardware guy to put it in for you. 

 

Regards,

Ken Jones

Metalguy66

 

 

 

Edited by MEtalGuy66
  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...