Jump to content
Serpentor

Atari Flashback X Deluxe Firmware Updates

Recommended Posts

Just curious if the hack to play additional games is still necessary?  I see on the official firmware release notes page they have enabled add-ons from the USB in the latest update.  Is anyone who updated their firmware able to confirm this?  I only see the USB info in the notes on the Deluxe version of the X.

 

https://firmwareupdate.atgames.net/release-notes

Edited by Serpentor

Share this post


Link to post
Share on other sites
9 minutes ago, Wizzard said:

Hack is not necessary, I am using updated official fw and it works.

 

 

That is great to know!  Thank you for the reply.  I was hesitant to update because I thought it might break the ability to hack it somehow.  I much prefer using official firmware, so this is great.

 

Edit: After downloading the update from ATGames, it appears they used the same method as the hack to enable the USB port.  They even lifted the guy's pictures and used them in their firmware update guide!

Edited by Serpentor

Share this post


Link to post
Share on other sites

I think you can change the firmware as you want. I used that hack to deluxe version so I lost all my bonus games. AtGames helped me to get it back though.

Share this post


Link to post
Share on other sites
5 minutes ago, Wizzard said:

I think you can change the firmware as you want. I used that hack to deluxe version so I lost all my bonus games. AtGames helped me to get it back though.

They seem to be very helpful to the community.  May I ask one more question?  What cable did you use to add the thumb drive?  I have seen a few that have been confirmed to work, but they all add more ports than needed.  I am looking for one that simply splits to one USB port and a pass-through for the power.

Share this post


Link to post
Share on other sites
7 hours ago, Wizzard said:

Sure, first I ordered the one from Aliexpress, but it took too long to deliver so I ordered this https://m.alza.co.uk/premiumcord-usb-a-female-micro-usb-male-female-d3783672.htm and it works, so I did not even try that from Aliexpress after it was delivered.

 

Thank you.  I like the cleaner look of the solid black cords, so that one looks nice.

Share this post


Link to post
Share on other sites
13 hours ago, Wizzard said:

I think you can change the firmware as you want. I used that hack to deluxe version so I lost all my bonus games. AtGames helped me to get it back though.

Could you share the method of getting the bonus games back?

 

Now if they could just get t upgraded to Stella 6... :)

Share this post


Link to post
Share on other sites
Could you share the method of getting the bonus games back?
 
Now if they could just get t upgraded to Stella 6...
Sure, I just flashed the firmware AtGames sent me which contained whole image including all the games. They asked me not to share the image cause I think this is the only difference between regular version and deluxe.

Share this post


Link to post
Share on other sites

Tried to do the official upgrade but it's not working.

 

EDIT: Solved. I installed the RockChip Drivers manually and that solved it. Their installer exe wasn't really doing anything apparently.

Edited by Robotube

Share this post


Link to post
Share on other sites
4 minutes ago, Robotube said:

Tried to do the official upgrade but it's not working.

 

The Android tool just doesn't ever see the device. Definitely using a data cable and not a power cable. Followed directions to a T. For some reason, the Android tool constantly says "No Device" and will not connect.

 

Driver was installed, I've restarted...tried all the obvious stuff. Tried uninstalling and reinstalling the driver. Nothing. I've definitely connected to other Android devices via ADB before. In fact, I tried to see the Atari Flashback X through Command Line ADB, and it won't appear. Not sure what;s up.

 

Any suggestions?

Try a different cable. Mine was very touchy, but it worked with the third cable I tried.

Share this post


Link to post
Share on other sites

I set up both my new Flashback X and Retron77 systems today. I installed the latest 0.1.18 firmware in the Flashback X, which lists "- Fixed audio delay issue" in the changelog. I installed the latest community build in the Retron77.

 

With both connected to the same exact input on my TV, the retron77 shows virtually no noticeable audio delay/sync issues when the TV is set to game mode to reduce lag. But the Flashback X shows a noticeable amount of audio lag - enough that I'd call it unplayable. I tried adjusting every possible sync setting in my TV and receiver, tried sending the sound to my soundbar instead, and even set the audio to TV speakers only, and even with auto sync enabled or adjusting the sync adjustments as far as I could go, I couldn't get it low enough to be acceptable. Meanwhile, playing the Retron77 has only the tiniest amount of lag due to the TV processing, virtually unnoticeable (even in game mode there's some lag, though much less than standard viewing mode).

 

I tried the Flashback X right out of the box and then installed the 0.1.18 firmware, and honestly couldn't see any improvement in audio sync between the out-of-box firmware and the newest firmware. I think this unit still suffers from audio lag and I Hope they look into this further. I'm happy the new firmware allows us to load roms using the y-cable, but this audio issues makes the system undesirable to play as it is currently.

 

I created a thread for it here:

https://atariage.com/forums/topic/300395-atari-flashback-x-audio-delaylag/

 

Somebody posted a graph there showing the audio lag is noticeably higher than the Retron77. Is this something that they can fix?

 

 

 

Share this post


Link to post
Share on other sites

I have the non Deluxe version of the Flashback X.  I successfully applied the official December firmware.  Using an OTG I can see the USB stick inserted and the Atari ROMs I have in .A26 format.  However non of them actually load.   Is this because I have the non Deluxe version.   I notice the release notes for the non-deluxe does not indicate support for this.

 

Thanks

Share this post


Link to post
Share on other sites
49 minutes ago, Sinjinhawke said:

I have the non Deluxe version of the Flashback X.  I successfully applied the official December firmware.  Using an OTG I can see the USB stick inserted and the Atari ROMs I have in .A26 format.  However non of them actually load.   Is this because I have the non Deluxe version.   I notice the release notes for the non-deluxe does not indicate support for this.

 

Thanks

I also have the non-deluxe version and can run . a26 files without problems via otg adapter. Did you formatted the stick in fat32 mbr?

Maybe the stick u use is not compatible to the fbx?

Share this post


Link to post
Share on other sites
12 minutes ago, Ronner51 said:

I also have the non-deluxe version and can run . a26 files without problems via otg adapter. Did you formatted the stick in fat32 mbr?

Maybe the stick u use is not compatible to the fbx?

I did use two sticks with mbr formatting.  The fact that it works for you is re-assuring.   I’ll have to dig up some more sticks to find one that works.  Thank you. 

Share this post


Link to post
Share on other sites
4 minutes ago, Robotube said:

Be sure your filenames do NOT contain any spaces! They will appear in your ROM list but will not load.

And that was it.   Cool.  Now to remove spaces from hundreds of files.   
 

thank you. 

Share this post


Link to post
Share on other sites
8 minutes ago, Robotube said:

You can do this in a batch at the command line. There are various ways. Just google "Remove spaces in filenames command line"

 

 

 

 

I figured there was a way and will do it.  I just needed Demon Attack done ASAP.  My go to game.   Thank you.  

Share this post


Link to post
Share on other sites
21 hours ago, Sinjinhawke said:

I figured there was a way and will do it.  I just needed Demon Attack done ASAP.  My go to game.   Thank you.  

You can run these lines, one at a time, from Windows Powershell:

 

Get-ChildItem * | Rename-Item -NewName { $_.Name -replace ' ','_' }
Get-ChildItem * | Rename-Item -NewName { $_.Name -replace '__','_' }
Get-ChildItem * | Rename-Item -NewName { $_.Name -replace '_\.','.' }

This will replace all spaces with underscores (_), remove any two consecutive underscores as well as underscores at the end of the file name.

 

NOTE: Make sure change directory (CD) into the correct folder before you run these. You don't want to mistakenly run these in a system folder. 😁

Edited by ft55555
  • Like 1

Share this post


Link to post
Share on other sites

I did something very similar with a batch file run from within the folder with the files.  Worked like a charm.   Now my cool looking Flashback X is playing all the old classics.  
 

thank you. 

Share this post


Link to post
Share on other sites
On 1/7/2020 at 8:21 AM, fiudr said:

Somebody posted a graph there showing the audio lag is noticeably higher than the Retron77. Is this something that they can fix?

AtGames is aware of this issue internally.  It sounded like a real patch was forthcoming but has not happened.  Would probably help if more people emailed AtGames at [email protected] and kindly requested that a fix be released to the public for both Flashback 9 and Flashback X.

 

Share this post


Link to post
Share on other sites
On 1/12/2020 at 3:21 PM, chad5200 said:

AtGames is aware of this issue internally.  It sounded like a real patch was forthcoming but has not happened.  Would probably help if more people emailed AtGames at [email protected] and kindly requested that a fix be released to the public for both Flashback 9 and Flashback X.

 

I'll email them and politely ask for them to address the issue.

 

Share this post


Link to post
Share on other sites

Atari Flashback X Deluxe: Special Edition (MODEL NO: AR3060S)
V.0.1.5 official firmware update (released on Feb 12, 2020)

 

0.1.5

## Highlights
-Fixed audio delay issues
-Enabled Firmware update from external USB drive
-Enabled add-ons from external USB drive
-Added APL function
 
## Miscellaneous
-Updated UI

 

https://firmwareupdate.atgames.net

 

 

Edited by Draxxon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...