Jump to content
DarkLord

Another one rejoins the fray....

Recommended Posts

Quite some time ago Rustymutt was kind enough to sell me a beat up Mega STe. The case

was messed up but everything else was good. I finally got around to dragging out a non-working

Mega STe that I had stored in my man-cave and combined the two.

 

Yay, it works!  :)

 

Only issues I've encountered so far is that the "A" key doesn't work on the keyboard. I've got

a spare Mega STe keyboard as well as a brand new Mega ST keyboard so I'll try those later.

 

The other issue is that the power LED in the left side of the case is not working. The bracket

is there (and rusty - seems like I've seen other posts about that issue) but there isn't any

cable. Anyone have a spare, or pictures showing what it looks like and how it connects?

 

Thanks.... /me happy.  :)

 

 

My Atari Mega STe-01.jpg

My Atari Mega STe-02.jpg

My Atari Mega STe-03.jpg

  • Like 8

Share this post


Link to post
Share on other sites

Congrats that is a beauty! :3 Glad to see this sweet machine working again! ❤️ I love the Mega ST form factor.

 

I recently got a MegaST4 that is upgraded with an Turbo 16, and it is also a peach of a system.

Share this post


Link to post
Share on other sites

3mm led on a 24" length of twisted wire.. to a 2 pin female header. Plugs in right behind the RTC battery.  J290 positive to the left.

 

James

  • Thanks 1

Share this post


Link to post
Share on other sites
On 1/4/2020 at 9:37 AM, Jinroh said:

Congrats that is a beauty! :3 Glad to see this sweet machine working again! ❤️ I love the Mega ST form factor.

 

I recently got a MegaST4 that is upgraded with an Turbo 16, and it is also a peach of a system.

Mega ST case is not exactly same as Mega STE or TT case. Later 2 are same. Diff is in hard disk position, for instance.

Share this post


Link to post
Share on other sites
On 1/4/2020 at 3:37 AM, Jinroh said:

Congrats that is a beauty! :3 Glad to see this sweet machine working again! ❤️ I love the Mega ST form factor.

 

I recently got a MegaST4 that is upgraded with an Turbo 16, and it is also a peach of a system.

 

I love both the Mega ST (the DarkForce! BBS is powered by one of these) and the Mega STe's forms.

 

I just think they are drop dead gorgeous.  :)

 

Share this post


Link to post
Share on other sites
On 1/4/2020 at 1:56 PM, Bikerbob said:

3mm led on a 24" length of twisted wire.. to a 2 pin female header. Plugs in right behind the RTC battery.  J290 positive to the left.

 

James

 

Awesome, thanks for the info. I'm going to take one last look through a couple of my

"extra" parts boxes, in case I've got one stashed away and forgot about it....

 

Thanks again.  :)

 

Share this post


Link to post
Share on other sites
On 1/5/2020 at 3:45 AM, ParanoidLittleMan said:

Mega ST case is not exactly same as Mega STE or TT case. Later 2 are same. Diff is in hard disk position, for instance.

Oh yes that is right they have some difference, I had forgotten!

 

Nevertheless I do love the form factors. ❤️

 

Share this post


Link to post
Share on other sites

For many of the wonderful case designs, including the STacy and Mega STe, pay

homage to:

 

Ira Velinsky

 

Another far sighted and talented individual who left this world far too soon! 

 

<respect!>

  • Like 2

Share this post


Link to post
Share on other sites
On 1/7/2020 at 3:55 PM, DarkLord said:

 

Awesome, thanks for the info. I'm going to take one last look through a couple of my

"extra" parts boxes, in case I've got one stashed away and forgot about it....

 

Thanks again.  :)

 

There were discussions on Facebook about the corroded LEDs holder on the Mega STe/TT, and I was going to 3D print some and try them out. 

If they work well enough and don't take me a life time to print, I will print some up for people.  I already got the LEDs and pin housings for them. 

Share this post


Link to post
Share on other sites
18 hours ago, leech said:

There were discussions on Facebook about the corroded LEDs holder on the Mega STe/TT, and I was going to 3D print some and try them out. 

If they work well enough and don't take me a life time to print, I will print some up for people.  I already got the LEDs and pin housings for them. 

Hey, that would be great. I don't do Facebook but keep me in mind and mark me down for one when you do finish it.

 

Thanks!  :)

 

Share this post


Link to post
Share on other sites
7 minutes ago, DarkLord said:

Hey, that would be great. I don't do Facebook but keep me in mind and mark me down for one when you do finish it.

 

Thanks!  :)

 

Can do!  I don't really like Facebook myself, so good to keep away from that.  I literally just use it for various groups because for reasons unknown, some people / developers stopped using forums.

Share this post


Link to post
Share on other sites

Still a tad loose, the options are 3mm or 5mm LEDs, but I think the standard one is more like 2mm.  Also about a 21-22 inch wire, which most of the ones I'm finding for sale are in the 8" range.  I did find a place that sells a single LED with wire and header that has a 16inch wire, but they're 2 USD each, plus 6 shipping... but I only really looked on amazon, I bet electronics shops will have better options at better prices.  I just managed to be lucky and pull my original LED out of the rusty mess.

 

Also to note, I somehow stripped the screw hole a little (old plastics!)  So might have to do my trick of the little plastic beads that can be put in hot water, which melts them into a goo, which you then put into a screw hole, and then the screw.  When it cools, the screw hole is repaired :)  If it stays in, I won't bother. 

Anyhow, if I print the holders with the 'raft' it takes like 10 minutes, but the raft itself is probably as much plastic as the part, it's just because my printer usually likes to mess up things unless it has a really good adherence to the bed.  I'll see if I can print up a few at a time for people.

 

Would people rather have the 3mm, which is still a little loose on the original LEDs, or should I print the 5mm ones?  I do have grommets for these on the way, they shouldn't exactly rust with a plastic part!

20200113_222357.jpg

Share this post


Link to post
Share on other sites

I remember that message thread on the plastic repair. Good stuff.  :)

 

This is all looking pretty good to me. I guess either way would be okay. Maybe

hot glue gun the loose one or use the larger size....

 

Thanks.

 

Share this post


Link to post
Share on other sites
12 minutes ago, DarkLord said:

I remember that message thread on the plastic repair. Good stuff.  :)

 

This is all looking pretty good to me. I guess either way would be okay. Maybe

hot glue gun the loose one or use the larger size....

 

Thanks.

 

Once the grommets arrive, I'll test that out.  Still need to find a source for LEDs that have the long wires, unless people can rescue their original one, or have the equipment to solder new wires and I guess that's some sort of heat shrink tubing they put over them.  Might look into doing that.  That way it's just a matter of pulling off the old one, unscrewing the holder, then putting the new one in.

Share this post


Link to post
Share on other sites

I think tonight I'll try printing up like 10 of them and see how that goes, then maybe if the shipping is cheap enough send some out.  I should probably figure out how many are wanted/needed.  I mean I have three machines myself I could put them in :P

 

Edit: on that note, I do have my original (1st ST!) Mega STe I should see if I can repair at some point.  Last time I tried to boot it up, with TOS 2.06, it gave me just a white screen, and nothing else.  Couldn't get the serial / diagnostic cartridge to do anything different either.  But now I have some deOxit, and maybe I can give it a nice alcohol bath that will improve things.  Though I think I stole the 2.06 ROMs from it for my backup one I ordered...

Edited by leech

Share this post


Link to post
Share on other sites

Don't be afraid to price these fairly - you're doing all the work so you deserve a profit.

 

I'm in for sure. That's one.  :)

 

Ouch, sorry about that machine. Hate to see any Atari not working but especially the

higher end/rarer ones....

 

Share this post


Link to post
Share on other sites
59 minutes ago, DarkLord said:

Don't be afraid to price these fairly - you're doing all the work so you deserve a profit.

 

I'm in for sure. That's one.  :)

 

Ouch, sorry about that machine. Hate to see any Atari not working but especially the

higher end/rarer ones....

 

Yeah, that machine had the hard drive cover off and was stashed away where mice got into it, so of course there was a lot I had to clean off with alcohol before.  So I think when I work on it next I will remove chips and use deOxit.  Plus I think I need to put memory back in.  Will have to try to find another keyboard if I want to run them all at once. 

Still need to find another floppy drive light for it.  I stole the one off of it for the TT that never had one ha!

Now if someone could model one and I could find some translucent plastic...

Share this post


Link to post
Share on other sites

Always something eh?  :)

 

Speaking of mice, my son had a Mazda CX-5 when they used to live in a small apartment (rural) complex. They used to park it at night next

to a garbage dumpster. One night, him and his wife pull out to go to dinner and the car just dies. Won't restart, won't do anything.. When they

got it into the shop (it was still under warranty, fortunately) the mechanics found that mice had built a nest in the wiring harness and chewed

through it in several places.

 

They think they crawled in there at night, when the motor was shut off but still warm.

 

PS Good thing about the warranty - total bill was close to $3000.00!

Share this post


Link to post
Share on other sites

Damn rodents!  I think the closest I've had to that was one of my parents cars where the cats would occasionally like to crawl inside the car at night when it was warm... fortunately I don't think we ever actually turned the car into a cat blender though I've heard other people have...

Share this post


Link to post
Share on other sites

Quick question for anyone who is using an internal Ultrasatan with their Mega STe....

 

Did you use the original hard drive bay to house the unit? I'm assuming that would

be the way to go.

 

Looking at the US units for sale at Lothareks' web site - it says it uses the +5v floppy

drive lead - does that mean it disables the internal floppy drive?

 

Thanks everyone.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...