Jump to content
Curt Vendel

XM has shipped!

Recommended Posts

1 hour ago, Curt Vendel said:

The PIA fully enables the SIO port and will allow hardware hackers to enable a 2nd POKEY or many other features beyond what the XM will already do.

 

Does this mean the SIO port has less hardware functionalities compared to the 8-bit computers? 

Share this post


Link to post
Share on other sites
4 hours ago, DarthCloud said:

All set

IMG_20200416_162322.jpg

Great! Curt doesn't need to redesign it to fit your cabinet. :P

  • Like 3
  • Haha 5

Share this post


Link to post
Share on other sites

Lucky, though that's nothing a sawzall or large hammer couldn't fix.

  • Haha 1

Share this post


Link to post
Share on other sites
5 hours ago, Allan said:

Does this mean the SIO port has less hardware functionalities compared to the 8-bit computers? 

No, as a matter of fact, other than it not having Motor connected or power out (due to not wanting to overstress the power draw on things) the SIO port, once a PIA is installed, makes it a full SIO compatible port.   I just don't envision people using Tape drives on it and any peripherals would use their own power source, so those pinouts are not connected on the XM SIO.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, RevEng said:

Lucky, though that's nothing a sawzall or large hammer couldn't fix.

Or dynamite!  ;-)

 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites
11 hours ago, Curt Vendel said:

No, as a matter of fact, other than it not having Motor connected or power out (due to not wanting to overstress the power draw on things) the SIO port, once a PIA is installed, makes it a full SIO compatible port.   I just don't envision people using Tape drives on it and any peripherals would use their own power source, so those pinouts are not connected on the XM SIO.

 

 

There are probably a few devices, like my Sdrive2 that use the SIO power, but it's probably not something many people will do.  They can always wire the power pin if they want to.

  • Like 2

Share this post


Link to post
Share on other sites
11 hours ago, Curt Vendel said:

No, as a matter of fact, other than it not having Motor connected or power out (due to not wanting to overstress the power draw on things) the SIO port, once a PIA is installed, makes it a full SIO compatible port.   I just don't envision people using Tape drives on it and any peripherals would use their own power source, so those pinouts are not connected on the XM SIO.

 

 

Thank you for the clarifying.

 

Maybe they could also use one of Lotharek's SIO Splitters with a power supply. Also I just remembered that the tape drives are self powered. I know the XE modem requires the power line. The 1030 modem has it's own power supply. I'm not sure if there is anything else that uses the SIO power line. Maybe some printer adapters.

Share this post


Link to post
Share on other sites

Allan,

 

Here, watch my video of me babbling about the PIA, the POKEY, SIO and just things in general...

 

 

  • Like 11

Share this post


Link to post
Share on other sites
On 4/16/2020 at 8:53 PM, Curt Vendel said:

No, as a matter of fact, other than it not having Motor connected or power out (due to not wanting to overstress the power draw on things) the SIO port, once a PIA is installed, makes it a full SIO compatible port.   I just don't envision people using Tape drives on it and any peripherals would use their own power source, so those pinouts are not connected on the XM SIO.

That's unfortunate, since the MIDIMATE and recent MIDI compatible boards use the motor signal to place them on the SIO bus. This technique was also used for the RVERTER, thus enabling a very simple RS232 device to also work. In both cases it's not about drawing any real power from the motor pin, but instead using it as a signal line in conjunction with the SIO Data-In, Data-Out, and CLK-In. But I believe Fuji-Net will bring this functionality without needing the motor line.

 

Share this post


Link to post
Share on other sites
15 minutes ago, mytek said:

That's unfortunate, since the MIDIMATE and recent MIDI compatible boards use the motor signal to place them on the SIO bus. This technique was also used for the RVERTER, thus enabling a very simple RS232 device to also work. In both cases it's not about drawing any real power from the motor pin, but instead using it as a signal line in conjunction with the SIO Data-In, Data-Out, and CLK-In. But I believe Fuji-Net will bring this functionality without needing the motor line.

 

 

Well if someone like yourself is inclined to use it with such devices you will have to mod the unit to do so. 

Share this post


Link to post
Share on other sites
2 hours ago, Rick Dangerous said:

Is it possible to find out if I am still on the list? I think I pre-ordered this about 6 years ago. 🙂

Just go to 7800xm.com and click on the link at the bottom of the page for pre-orders and submit your info.

 

i never sold any in 2014 so I don’t think you actually pre-ordered one but if you have your receipt and emails please send them on the form.

  • Like 1

Share this post


Link to post
Share on other sites

Any news or status updates to report by chance on overall progess,etc ? I waited 2 weeks before asking, as hard as that was :grin:

  • Like 1
  • Haha 2
  • Sad 1

Share this post


Link to post
Share on other sites

Nice to finally see this happening! I just submitted my old pre order with an updated address (I'm in a whole other state now lol). Can't wait to finally get my hands on this.

  • Like 1

Share this post


Link to post
Share on other sites

I went and re-submitted my old Legacy Engineering receipt e-mail as a screenshot, and submitted the order number along with updated address and everything.  Congrats on managing to get it out, Curt!  After all the hell you've gone through with your health, consider this a job well done sir!

  • Like 1

Share this post


Link to post
Share on other sites

Resubmitted what I have. Due to my not being on here in....forever....I don't have my email or receipt or order number. Hopefully Curt still has something on his end but I pre-ordered in 2010 so.... ¯\_(ツ)_/¯. Hopefully it works out, should have kept the emails!

  • Like 1

Share this post


Link to post
Share on other sites
48 minutes ago, Cebus Capucinis said:

Resubmitted what I have. Due to my not being on here in....forever....I don't have my email or receipt or order number. Hopefully Curt still has something on his end but I pre-ordered in 2010 so.... ¯\_(ツ)_/¯. Hopefully it works out, should have kept the emails!

Have you done a search amongst your emails for "Legacy Engineering"?  Was what I had to do, back when Curt still had that site

Share this post


Link to post
Share on other sites
10 minutes ago, NightSprinter said:

Have you done a search amongst your emails for "Legacy Engineering"?  Was what I had to do, back when Curt still had that site

Apparently my old Hotmail account it was on got wiped at some point. Inbox completely empty. :( Admittedly, I haven't used that e-mail address since I was last here before now in....2013 as well, so.....yeah. It's on me. Fingers crossed that Curt can save the day. :)

Share this post


Link to post
Share on other sites
On 5/15/2020 at 12:32 PM, Cebus Capucinis said:

Apparently my old Hotmail account it was on got wiped at some point. Inbox completely empty. :( Admittedly, I haven't used that e-mail address since I was last here before now in....2013 as well, so.....yeah. It's on me. Fingers crossed that Curt can save the day. :)

 

If you don't use those accounts for X amount of time they get deactivated IIRC so it's not really your fault. It has been 10 years after all.

Share this post


Link to post
Share on other sites

I remember paying for this back in like 2010 when things first got started. Do we think sometime in 2020 we may actually get this? 10 is a nice round number...

  • Like 2
  • Haha 1

Share this post


Link to post
Share on other sites

I would have pre-ordered I'm sure, but I went inactive on here back in 2007 and just came back now in 2020.  🙂  Hope there are some left over for those of us late to the game!

Share this post


Link to post
Share on other sites
On 5/15/2020 at 11:39 AM, Cebus Capucinis said:

Resubmitted what I have. Due to my not being on here in....forever....I don't have my email or receipt or order number. Hopefully Curt still has something on his end but I pre-ordered in 2010 so.... ¯\_(ツ)_/¯. Hopefully it works out, should have kept the emails!

I've found quite a lot of the old orders, now its just getting everyone's updated info, which is a major help obviously...  I'm going to be going from confirmed definite orders and when I get through those, the ones where I can't find anything and they don't have anything, we will try to work together to dig something, anything up.... several people have said they bought others orders, but never got anything from the seller...  that's like buying a car from someone who doesn't have the registration... those people need to track down the sellers and get that info..

 

I did add in the Motor control line onto the SIO ports.... adding in external power is going to add more to the cost and require more time.   The XM's run fine on every 7800 we've tested... if a 7800 has a 7805 VR that is already on its way out and the XM pushes it over, there are plenty of people who can offer to do the repair, its a 20 min repair procedure...   So I ditched adding the external power option.

 

I'm now just waiting for the final Consumer BIOS to be completed.   There are 3 people involved with it.  Mark, and two others and it is a GORGEOUS system...    I am going to put together a simple sneak preview and will post up when I get the all clear.

 

 

 

  • Like 14

Share this post


Link to post
Share on other sites
1 hour ago, Curt Vendel said:

I've found quite a lot of the old orders, now its just getting everyone's updated info, which is a major help obviously...  I'm going to be going from confirmed definite orders and when I get through those, the ones where I can't find anything and they don't have anything, we will try to work together to dig something, anything up.... several people have said they bought others orders, but never got anything from the seller...  that's like buying a car from someone who doesn't have the registration... those people need to track down the sellers and get that info..

 

I did add in the Motor control line onto the SIO ports.... adding in external power is going to add more to the cost and require more time.   The XM's run fine on every 7800 we've tested... if a 7800 has a 7805 VR that is already on its way out and the XM pushes it over, there are plenty of people who can offer to do the repair, its a 20 min repair procedure...   So I ditched adding the external power option.

 

I'm now just waiting for the final Consumer BIOS to be completed.   There are 3 people involved with it.  Mark, and two others and it is a GORGEOUS system...    I am going to put together a simple sneak preview and will post up when I get the all clear.

 

 

 

No worries Curt! I know I bought direct so at least that's not a problem, but hell, if nothing can be found nothing can be found - that's on me as a buyer to keep receipts! That's what I get for leaving AA for....7 years :D Can't come back and expect everyone to just remember every transaction I ever did.

 

Worst case if nothing comes up I'll just snag another one :)

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...