Jump to content
fiudr

Atari Flashback X - audio delay/lag

Recommended Posts

I set up both my new Flashback X and Retron77 systems today. I installed the latest 0.1.18 firmware in the Flashback X, which lists "- Fixed audio delay issue" in the changelog. I installed the latest community build in the Retron77.

 

With both connected to the same exact input on my TV, the retron77 shows virtually no noticeable audio delay/sync issues when the TV is set to game mode to reduce lag. But the Flashback X shows a noticeable amount of audio lag - enough that I'd call it unplayable. I tried adjusting every possible sync setting in my TV and receiver, tried sending the sound to my soundbar instead, and even set the audio to TV speakers only, and even with auto sync enabled or adjusting the sync adjustments as far as I could go, I couldn't get it low enough to be acceptable. Meanwhile, playing the Retron77 has only the tiniest amount of lag due to the TV processing, virtually unnoticeable (even in game mode there's some lag, though much less than standard viewing mode).

 

I tried the Flashback X right out of the box and then installed the 0.1.18 firmware, and honestly couldn't see any improvement in audio sync between the out-of-box firmware and the newest firmware. I think this unit still suffers from audio lag and I Hope they look into this further. I'm happy the new firmware allows us to load roms using the y-cable, but this audio issues makes the system underisblae to play as it is currently.

 

  • Like 1

Share this post


Link to post
Share on other sites

The Flashback 9 has the same audio lag.  I agree, this makes it very hard to play.

 

I am disappointed to hear that the Flashback X (even after they specifically released a patch to address the audio delay) still has this same audio problem.  There was word that a patch was forthcoming for the FB9 but that has yet to happen.

 

I was planning on getting a Flashback X specifically because it sounded like they fixed it... but since they have not, I will hold off.

 

My Retron77 also does NOT have the extended audio delay that the Flashback 9 has, so my experience is identical to yours when it comes to the Retron 77.

 

Here is an audio analysis I did playing Pitfall.  The spike on the left is me hitting the button.  Then you can see how long it takes for the audio of the of the jump sound to play.  This analysis was done with the same TV with the same HDMI cable on the same input with the same GAME MODE setting for both the Retron 77 and the Flashback 9.

 

Retron77-FB9-Audio-Delay-Compare.png

  • Like 3

Share this post


Link to post
Share on other sites

Good stuff guys! Great to see the data and how lag affects some gamers more than others. I'm particularly bothered by it myself, which is why I prefer original hardware on a CRT, but it seems these products are slooooowly getting better over time in that regard. Baby steps.

 

More info to be found in the dedicated forums for these type of units here:    :)

 

https://atariage.com/forums/forum/19-dedicated-systems/
 

https://atariage.com/forums/forum/69-atgames-flashback-and-portable-consoles/

Share this post


Link to post
Share on other sites

Thanks for confirming the audio lag. That audio analysis says it all. I hooked the Flashback X up and spent hours trying to reduce the lag on my setup with no results, and was left disappointed. Thankfully, the Retron77 is functioning much better.

 

This was my first Flashback unit, and it's especially disappointing considering they claimed to have issued a fix in the latest firmware, even though it apparently did nothing. It didn't help that the main joystick doesn't work well (up doesn't work well), and oddly Space Invaders is not the Space Invaders I grew up with on the 2600. I don't know what version it is but it's not the original 2600 version.

 

If I knew about the audio lag, I would have saved the money and skipped it.

 

 

Share this post


Link to post
Share on other sites

Sorry for the offtopic, but does Retron 77 support boxarts/thumbnails of custom games loaded from SD card? I am thinking about buying it too, just for my collection :)

Share this post


Link to post
Share on other sites
3 hours ago, chad5200 said:

The Flashback 9 has the same audio lag.  I agree, this makes it very hard to play.

 

I am disappointed to hear that the Flashback X (even after they specifically released a patch to address the audio delay) still has this same audio problem.  There was word that a patch was forthcoming for the FB9 but that has yet to happen.

 

I was planning on getting a Flashback X specifically because it sounded like they fixed it... but since they have not, I will hold off.

 

My Retron77 also does NOT have the extended audio delay that the Flashback 9 has, so my experience is identical to yours when it comes to the Retron 77.

 

Here is an audio analysis I did playing Pitfall.  The spike on the left is me hitting the button.  Then you can see how long it takes for the audio of the of the jump sound to play.  This analysis was done with the same TV with the same HDMI cable on the same input with the same GAME MODE setting for both the Retron 77 and the Flashback 9.

 

Retron77-FB9-Audio-Delay-Compare.png

I have a flashback 9 Gold and notice no audio delay.  If there is any, it's minimal.  I know if there was enough lag, I would have taken it back.  Glad I didn't get the regular flashback 9.

Share this post


Link to post
Share on other sites
8 hours ago, atarifan88 said:

I have a flashback 9 Gold and notice no audio delay.

 

I am sure you have audio delay.  You just haven't noticed.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
2 hours ago, save2600 said:

Everyone input AND audio delay... DUH!  Whether you perceive it or not, it's there. Your perception of tolerance is the key and differentiates between casual and real playa. You real or faux? Life is like emulation... close but no cigar. Must choose one: real or faux? You faux? Such is the circle jerk of life.   ;)
 

Faux systems belong here: https://atariage.com/forums/forum/19-dedicated-systems/  ...take my faux, PLEASE!

 

 

5480D464-3573-4587-92E2-85B7CE49D0A1.gif

Not sure if you are serious in this post, but regardless of what system we play doesn't determine if we are real or false gamers. To each their own. I personally dont notice what is less than a half second delay. If anyone here determines that as the difference between being a true gamer or not, they have some serious OCD issues. Enough said! 🙄

  • Haha 1

Share this post


Link to post
Share on other sites

Yeah, the Retron 77 has much less audio lag, to the point where it's not an issue for me, whereas the audio lag on the Flashback X makes it pretty much unplayable. Just because I use these systems doesn't mean I'm not a "real" fan of these games. I grew up with the system.

 

Stella on the PC has no noticeable lag that I can detect.

 

Edited by fiudr

Share this post


Link to post
Share on other sites
Posted (edited)

Has there been any info or updates to address the audio lag of the Flashback X?

 

There is a new official firmware update for the deluxe Flashback X - V. 0.1.5 (released on Feb 12, 2020), but the last update for the standard Flashback X is still V. 0.1.18 (released on Dec 3, 2019), which doesn't fix the audio lag issue. I have no idea what that deluxe update was for since I have the standard Flashback X. Both updates list "Fixed audio delay issue" but it did not fix the audio delay issue for my standard Flashback X.

 

If others would like to contact them about this, their email is [email protected]

 

Edited by fiudr

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...