Jump to content
Sign in to follow this  
oakcitycomics

FIXED: Doom error

Recommended Posts

Finally got around to testing out my Jag SD this past month with some serious hours invested. I've noticed only one issue and its not always repeatable.

 

I've tried with multiple Doom roms just to make sure its not a bad dump. I also have the MRQ files and the latest released firmware. If I start the game on lvl two it will freeze about about 30 seconds in and then lock up the system. But not always. its kind of 50/50 and its only with this lvl. If I start the game from lvl 1 and play forward no issues. 

Share this post


Link to post
Share on other sites

Interesting, I've not seen this, I'll have to give it a try. Doom runs entirely from RAM once the level has loaded, as I remember, so its a weird one to have an issue.

Share this post


Link to post
Share on other sites
4 hours ago, oakcitycomics said:

Finally got around to testing out my Jag SD this past month with some serious hours invested. I've noticed only one issue and its not always repeatable.

 

I've tried with multiple Doom roms just to make sure its not a bad dump. I also have the MRQ files and the latest released firmware. If I start the game on lvl two it will freeze about about 30 seconds in and then lock up the system. But not always. its kind of 50/50 and its only with this lvl. If I start the game from lvl 1 and play forward no issues. 

 

Is your ROM of this headerless?

DOOM runs fine here to the end (even with music!)

Share this post


Link to post
Share on other sites
7 hours ago, SainT said:

Interesting, I've not seen this, I'll have to give it a try. Doom runs entirely from RAM once the level has loaded, as I remember, so its a weird one to have an issue.

Yea its a bit odd, and its not always repeatable. I only noticed it because I was trying to do all the hidden areas in a lvl with out looking them up online. So was revisiting lvls randomly. Lvl 3 was the only one that had an issue it was random when it would or would not if starting lvl 2 directly from the main menu. I tried it again with my original cart just to see if it was maybe an issue with my Jaguar or the game but I could never get it to freeze up on the real cart

 

Edited by oakcitycomics

Share this post


Link to post
Share on other sites
5 hours ago, CyranoJ said:

 

Is your ROM of this headerless?

DOOM runs fine here to the end (even with music!)

I'm assuming not headerless, since the SD cart does not ask me to load it via an address or headerless like some of the beta games. I tried 2 Doom roms one was labeled (world) from an old archive I used with my Skunk when I had it. The other was a Redump file 

 

Share this post


Link to post
Share on other sites

I will give it a go tonight as well. Does it freeze at the same point 30 secs in or is it irrelevant where you are ie if you start lvl2 and don't move, does it still sometimes crash?

Share this post


Link to post
Share on other sites
6 hours ago, CyranoJ said:

 

Is your ROM of this headerless?

DOOM runs fine here to the end (even with music!)

 

7 hours ago, SainT said:

Interesting, I've not seen this, I'll have to give it a try. Doom runs entirely from RAM once the level has loaded, as I remember, so its a weird one to have an issue.

Lvl 3 not lvl 2 sorry it was super late last night when I posted this was sleep deprived. Its lvl 4. I'll see if I can make a video of it

 

Edited by oakcitycomics
  • Confused 1

Share this post


Link to post
Share on other sites
17 minutes ago, str0m said:

I will give it a go tonight as well. Does it freeze at the same point 30 secs in or is it irrelevant where you are ie if you start lvl2 and don't move, does it still sometimes crash?

Sorry its lvl 3 not lvl 2, I was sleep deprived when I first posted. It happens right away if its going to freeze 

 

Edited by oakcitycomics

Share this post


Link to post
Share on other sites
2 hours ago, oakcitycomics said:

 

Lvl 3 not lvl 2 sorry it was super late last night when I posted this was sleep deprived. Its lvl 4. I'll see if I can make a video of it

 

Dude - maybe a straight answer would help us all here.  Is it level 2, 3, or 4?  Just provide 1 level in the answer

Share this post


Link to post
Share on other sites
5 minutes ago, Goochman said:

Dude - maybe a straight answer would help us all here.  Is it level 2, 3, or 4?  Just provide 1 level in the answer

Lvl 3 I went back and corrected.  The lvl with the large acid pit once you open the door

  • Thanks 1

Share this post


Link to post
Share on other sites

Fired it up, left it doing demo for 30 mins, played through from level 1 to 5, back to menu, started on level 3, 3 times, power cycles jag, 3 more goes starting straight on level 3, no issue....

 

Well except the terrible jag controller, oh I hate the d pad lol, fps games just no good on old style pads. Its actually quite impressive gfx wise, first time I've tried it. The version with music will be better

Share this post


Link to post
Share on other sites
1 hour ago, str0m said:

Fired it up, left it doing demo for 30 mins, played through from level 1 to 5, back to menu, started on level 3, 3 times, power cycles jag, 3 more goes starting straight on level 3, no issue....

 

Well except the terrible jag controller, oh I hate the d pad lol, fps games just no good on old style pads. Its actually quite impressive gfx wise, first time I've tried it. The version with music will be better

Its hit or miss if it will or wont. But the easiest way to reproduce the error at least on my system. Start the game and let it sit till the demo, on my copy it always demos on lvl 3 and half the time it will freeze and lock up the system. This is more reliable then starting a game on lvl 3. Here is a video. You can see when it freezes the status bar on the bottom starts to flicker and the system is completely locked up you can't even hit *# to restart. You have to fully power down the Jag. 

 

 

Share this post


Link to post
Share on other sites

30second error.mkvHere is a better example of it freezing around 30 second mark. I use a cheap $10 usb capture device so video quality isn't the best but its better then a cell phone. I used same method as mentioned above. Let the Jaguar go to demo on my copy its always lvl 3. You can tell if it will crash if the status back flickers sometime it freezes right away and locks up. Otherwise it will play for a few seconds then crash the system like in this video. Starting the game on lvl 3 from the menu will do the same but not as often. This is just an easier way to reproduce the error more repeatable 

@SainT @CyranoJ

30second error.mkv

Edited by oakcitycomics

Share this post


Link to post
Share on other sites
2 minutes ago, CyranoJ said:

That is 100% not the GD cart. I'd have your caps checked on the board.

I'm not sure its my Jag. I've tested it on two systems both K models. Also I'm not able to produce it with a real Doom cart no mater how many times I try. 

Share this post


Link to post
Share on other sites

There is a GPU interrupt right above that line that is flickering. Looks like it's not firing off 100%. At this point the game is 100% in RAM.  The cart has passed the checksum at boot and been verified. The only other thing it could be is a wonky PSU.

Share this post


Link to post
Share on other sites
5 minutes ago, CyranoJ said:

There is a GPU interrupt right above that line that is flickering. Looks like it's not firing off 100%. At this point the game is 100% in RAM.  The cart has passed the checksum at boot and been verified. The only other thing it could be is a wonky PSU.

Odd that its happening on both my systems and only with the SD cart. I am using the official Atari PSU so who knows. I have some high quality 9v 2a power supplies I'll reverse the polarity on one of them and give it a go 

 

Share this post


Link to post
Share on other sites

Here its produced again on a different Jag with a new psu. This Jag is a K13C model my other one is a K143. So I'm at a loss as its producible on both and not producible with a retail Doom cart. Doom is the only game I've had issues with on the JagSD. I ordered a M model Jaguar off ebay so will see how that goes when it gets here 

Edited by oakcitycomics

Share this post


Link to post
Share on other sites

I noticed that if I delete the .e2p file from the Doom folder and start the Jaguar up fresh I can play as long as I want and even soft reset(#*) over and over again and even let the intro demo play over an over of lvl 3 and never will it glitch. I've tried it now 5 times.

If I power off the jaguar and then come back and boot up doom with the .e2p from a previous doom game it will glitch randomly when starting lvl 3 either from lvl start of intro demo. It froze for me 2 out of 6 hard reboots and only lvl 3 and only if using a .e2p from a previous boot. Not sure if it helps but attached is the .e2p my cart creates 

@SainT

Doom (World).e2p

Edited by oakcitycomics

Share this post


Link to post
Share on other sites

Just had a look at my files and card. Whilst I have renamed the rom to just Doom.j64, going by the time stamps I am using "Doom (USA, Europe)" and not "Doom (World)" which I also have so it could be that "World" one is causing you the problem. I had no issues even after power cycle and no flashing

 

22/08/2019  10:50         4,194,304 Doom (USA, Europe).j64
20/08/2016  11:31         4,194,304 Doom (World).j64

Share this post


Link to post
Share on other sites
6 hours ago, str0m said:

Just had a look at my files and card. Whilst I have renamed the rom to just Doom.j64, going by the time stamps I am using "Doom (USA, Europe)" and not "Doom (World)" which I also have so it could be that "World" one is causing you the problem. I had no issues even after power cycle and no flashing

 

22/08/2019  10:50         4,194,304 Doom (USA, Europe).j64
20/08/2016  11:31         4,194,304 Doom (World).j64

I tried several doom roms' including Goodjag 2.01 set. Didn't make a difference.  What model Jaguar is yours? 

Share this post


Link to post
Share on other sites

Will look when I get home from work. Does it say on a sticker underneath or something? Mine does have the odd sound issue with real carts and on SD where it crackles but only in a couple of games, need to post a thread about that in the main forum but I've not had any sort of crashing with any game real or on SD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...