Jump to content
leech

Mega STE/TT LED replacements!

Recommended Posts

Can I however suggest gathering all the European shipments in a single one, and then one of us posts to the others? I think that would basically evaporate the cost between the US and Europe, it would just leave the costs within Europe. Those that agree, we could probably arrange between ourselves to pay the extra 2nd shipment, so we would just pay you for the mounts and our share of shipping.

 

Also, check these guys: They indicate ~27 USD cost between US and Germany: https://www.parcelmonkey.com/quick-shipping-calculator/results?quote_result_id=e9cc3fb4-e1ce-4e87-a1bb-c2974d7e158f

Share this post


Link to post
Share on other sites

Yeah, I was wondering if I should just make a bunch and sell to some of the retro shops and let them ship them out to people.  Since generally stores have accounts with shippers, inlike me who is building these by hand / printer, then shipping individually.

Share this post


Link to post
Share on other sites
2 hours ago, DarkLord said:

That actually sounds like a good idea.

 

Question is who?  Now that I have a crimper for the housing pins on the way (doing those by hand got irritating after I have done like 8 of them..) Once I get that here, I should be able to finish the rest of them off.  Probably could print some more too.  But finding a reseller would be very much preferred.

Share this post


Link to post
Share on other sites

Bruce maybe? I'd say Brad at Best Electronics but I'm not sure about that.

 

As far as Europe goes - Chris Swinson (Exxos) - I'd think would be an obvious

choice.

Share this post


Link to post
Share on other sites
10 hours ago, DarkLord said:

Bruce maybe? I'd say Brad at Best Electronics but I'm not sure about that.

 

As far as Europe goes - Chris Swinson (Exxos) - I'd think would be an obvious

choice.

I think the problem with Brad is he has a minimum charge for things.  Though this is definitely an 'also need' part.  I sent my Lynxes off to be fixed by MacRorie and the Brewing Academy, not sure if he'd be interested in selling the LED replacements.  I do agree with Chris in Europe.  Does he still linger in the forums, I think at one point he bailed out and now pretty much just hangs out on his own forums.

Edited by leech
clarifications.

Share this post


Link to post
Share on other sites

Right, forgot about that - something like $50 minimum, right?

 

I've not personally seen him at Atari Age or Atari Forum in a while, but as you

said, he has his own forums which have a fair amount of traffic on their own,

and covers some pretty leading edge/exciting stuff like the TF accelerators.

 

Share this post


Link to post
Share on other sites
4 minutes ago, DarkLord said:

Got mine in today - working on it.  :)

 

Sweet, I assume that means it didn't break, which was my biggest concern.

Share this post


Link to post
Share on other sites

Houston, we have a green light, I say again, we have a green light, it's a go!  :)

 

As I posted earlier, got it in today. Good shape, nothing broken. Everything

went smooth, just wanted to mention 2 things. First, the LED is a snug fit

in the grommet - it popped out on its own 2-3 times. I moistened it, then

used a hot glue gun just to make sure it would stay. (yeah, yeah, I used

snug, moistened and  popped out all in one sentence. All you "The Office"

fans please calm down).  :)

 

Second, the connector that plugs into the motherboard is pretty loose. It

is staying, but it's just not as tight as I would like <ahem>. I've got the

same problem with the LED on the hard drive. In fact, it's so loose now

that it won't keep a connection. That post is all rusted up too, just like

the main power light one was. Guess we need someone with a 3D

printer to make up some replacement kits for that as well. <hint hint> :)

 

Other than those small details, it's all good. Pretty bright too! Here

are a few pictures:

 

 

P1010003.JPG

P1010007.JPG

P1010012.JPG

P1010017.JPG

P1010023.JPG

P1010024.JPG

Share this post


Link to post
Share on other sites

My trick to get them to stay in (and I mean really stay in) was to push the LED into the grommet enough that the 'lip' at the base of the LED is inside the grommet.  I just did this on one I have sitting on my table, and 'helicoptered' it around my room and it didn't pop out.

Share this post


Link to post
Share on other sites

salut

 

Im intéressé pour led jaune ou ambre pour hdd mega ste .... et puissance verte

 

im living in France

 

 

Edited by bevenais

Share this post


Link to post
Share on other sites
16 minutes ago, leech said:

My trick to get them to stay in (and I mean really stay in) was to push the LED into the grommet enough that the 'lip' at the base of the LED is inside the grommet.  I just did this on one I have sitting on my table, and 'helicoptered' it around my room and it didn't pop out.

Coolness - Now I'll know what to do next time.  :)

 

Share this post


Link to post
Share on other sites
7 minutes ago, bevenais said:

salut

 

Im intéressé pour led jaune ou ambre pour hdd mega ste .... et puissance verte

 

im living in France

 

 

List time!

Dark Lord : 1

rickerbh : 2

remowilliams : 2

jcnventura : 2

Bama : 4

bevenais : 1

 

I've been emailing Exxos about him including these on his store.  Will try to work something out, if there is high enough demand.  he has a 3D printer himself, but hasn't had the time to really put it to use.

Share this post


Link to post
Share on other sites
10 minutes ago, bevenais said:

ok

its possible in yellow led for mega ste HDD ?

 

 

Needs some design around it.  The problem is that the holder is part of the entire drive cage.  So any sort of 3D printed solution would have to either A) replace the drive cage (which probably wouldn't be strong enough to hold a full sized hard drive, though I've printed drive holders for SSDs), or B) would need to be something where you'd take the drive cage off, cut off the rusted piece, then attach (either via a plastic sheath or drilling a screw hole) to hold the plastic LED holder in place.

 

Trying to think out how exactly to do that.  I currently have a TT and Mega STe drive bay I can look at, but if they aren't terribly rusted, I'd rather not go chopping them up :P

Share this post


Link to post
Share on other sites

 

 

I thought I would simply remove the grommets with broken LED, clean it well and then stick your grommets with a yellow LED 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, bevenais said:

 

 

I thought I would simply remove the grommets with broken LED, clean it well and then stick your grommets with a yellow LED 

That could easily be done.  I ordered some yellow LEDs, I will see how that turns out, and will post back. 

Share this post


Link to post
Share on other sites

I will take 1 in green.  Also if you have one in yellow (just the led/grommet with connector) for the HD side that would be nice too.  Let me know when they are ready to ship and where to send payment.

 

The list:

rickerbh : 2

remowilliams : 2

jcnventura : 2

Bama : 4

bevenais : 1

tjlazer : 1 green led kit + 1 yellow led/cable/grommet/connector for HD

Edited by tjlazer

Share this post


Link to post
Share on other sites

Was just re-reading my earlier post with pictures and realized I somehow forgot

to give a big T H A N K  Y O U to Leech for a job well done bringing a much needed

replacement item to our beloved Mega STe's!

 

 

Share this post


Link to post
Share on other sites

They are working out well.  I think I may just make up a batch of 20 or so and send off to exxos, and let him sell them internationally.  Then for anyone in the US, I can send them out.  But I will first check shipping prices for those that already declared interest. 

It is giving me good soldering practice, I don't shake as much as I used to, nor have I burned more than my pants a little recently... ha!

These are extremely easy to put together.  Should be a lot easier with the crimper I got for the housing pins though! 

@DarkLord

Your holder was seriously degraded!  The one on my TT isn't anywhere near that bad, I need to check the two Mega STEs though.

Share this post


Link to post
Share on other sites
1 hour ago, leech said:

 

@DarkLord

Your holder was seriously degraded!  The one on my TT isn't anywhere near that bad, I need to check the two Mega STEs though.

It was!  :)

 

(and the HDD part is just as bad if not worse)

 

Share this post


Link to post
Share on other sites
1 hour ago, leech said:

 

Nice. Thank you Fujiman! <2 thumbs up>

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...